summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-10-01 16:13:43 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-10-01 16:13:43 +0200
commit557142304c474c082f121962b2166f1755953813 (patch)
tree3c4f7fac60d1eccbcaec05758a271f8f2218e4b9 /app-emacs/setup
parentapp-emacs/helm: bump to 3.8.8 (diff)
downloadgentoo-557142304c474c082f121962b2166f1755953813.tar.gz
gentoo-557142304c474c082f121962b2166f1755953813.tar.bz2
gentoo-557142304c474c082f121962b2166f1755953813.zip
app-emacs/setup: bump to 1.3.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/setup')
-rw-r--r--app-emacs/setup/Manifest1
-rw-r--r--app-emacs/setup/setup-1.3.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/setup/Manifest b/app-emacs/setup/Manifest
index b4db34aaf6b7..239acbc44b35 100644
--- a/app-emacs/setup/Manifest
+++ b/app-emacs/setup/Manifest
@@ -1,2 +1,3 @@
DIST setup-1.2.0.tar.gz 19709 BLAKE2B 704340f9ab8a3e10fdeafed88365fb3151fe8c9600960defcce0021850a1846ffc5e7a3c02a4567371c18b4bdf5b81c80544fe82c22a150ca4d4505818ba8148 SHA512 705e188876316eb76938229395676a9068e735074d63865dd9a2a21d83face2768f958f76cf9c88b6cb3d4668e271ee043d7aa81a40d3b384fb1bc75bb1f0af5
DIST setup-1.3.0.tar.gz 20112 BLAKE2B 7e8b29c6a2be68572ede8845bc1cdfc8e00acdaf1db972124ab18f2ec6ab216a481dc4c40ff256e7bdefd2558cafb686af8a51728e0b1c093ca369fa4a093c09 SHA512 cd088dba4f258a3440ec78e5742b6a2f5d1dba46e3382ea3b40967b640c80fd292b7edc1421f07561c270c4404d95c0fd55bd166265c79c131e0037f2181cb66
+DIST setup-1.3.2.tar.gz 19985 BLAKE2B d2166d22d13bfd4e01fef9ca25372dab30af237394abc3d55e78c50d5fa26aa09fa82b4f0940b73f27012e0fce1e3b76c802dc271463c89f9ab5e664023c0722 SHA512 14eebda45b713f657be391d71f51d86642a1d36155c1bc914fca170fe5718b136da726685559531cc8e738cc9cbc823f02eb231339b75eeb19e4e02085455120
diff --git a/app-emacs/setup/setup-1.3.2.ebuild b/app-emacs/setup/setup-1.3.2.ebuild
new file mode 100644
index 000000000000..8d1afc8e3210
--- /dev/null
+++ b/app-emacs/setup/setup-1.3.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+# The upstream does not create git tags for releases.
+MY_HASH=28926bd11eef6118f4e169d10c1c36b8c4e545ae
+
+inherit elisp
+
+DESCRIPTION="Macro to simplify repetitive configuration patterns"
+HOMEPAGE="https://git.sr.ht/~pkal/setup"
+SRC_URI="https://git.sr.ht/~pkal/${PN}/archive/${MY_HASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_HASH}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}