summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-19 03:29:30 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-19 03:29:30 +0100
commit5d6d7d5f705f77197ecbcb9fc1c63ae4bd1f8f0a (patch)
treeca815e6cc19780923b5a7bf553f8caad1572507e /app-emacs/lsp-mode
parentdev-dotnet/fsautocomplete: new package, add 0.68.0 (diff)
downloadgentoo-5d6d7d5f705f77197ecbcb9fc1c63ae4bd1f8f0a.tar.gz
gentoo-5d6d7d5f705f77197ecbcb9fc1c63ae4bd1f8f0a.tar.bz2
gentoo-5d6d7d5f705f77197ecbcb9fc1c63ae4bd1f8f0a.zip
app-emacs/lsp-mode: bump to 8.0.1_pre20231218
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/lsp-mode')
-rw-r--r--app-emacs/lsp-mode/Manifest1
-rw-r--r--app-emacs/lsp-mode/lsp-mode-8.0.1_pre20231218.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-emacs/lsp-mode/Manifest b/app-emacs/lsp-mode/Manifest
index ce3116fa88d6..ed734f672c07 100644
--- a/app-emacs/lsp-mode/Manifest
+++ b/app-emacs/lsp-mode/Manifest
@@ -1 +1,2 @@
DIST lsp-mode-8.0.0_p20220620.tar.gz 15464614 BLAKE2B 10e50a52e2a725b1a275b81514bb268619b128370f8989970c75c87bc37516588e798c5f2531b73689d9d102fbd6b965841c6d8a0c337cb8d9052b632a01e289 SHA512 d464418df6eb99d8a1f4cad8c9e31ca057286f846afbb0078fdff21cfc685ffc158b1b37d22224372bee67eb5298f20bb4db83ed466c09e4b4b3a83db865ef09
+DIST lsp-mode-8.0.1_pre20231218.tar.gz 16396690 BLAKE2B e841e1cda6e26ba1d646ea8ffeee7212fb3352e4ed73c323212e9bd883ddbe3461918b3ab435a16e6568d2fdaf97b165accd8876625415dfa428259c0c93998f SHA512 d3f5a26e40b7b569ba185d605208bd888aed6430f1fa5b608db47ba727e72fb540646a3908b80ab04db763d9be9adb8b58ef88165f31c874749ed26f7086c0fc
diff --git a/app-emacs/lsp-mode/lsp-mode-8.0.1_pre20231218.ebuild b/app-emacs/lsp-mode/lsp-mode-8.0.1_pre20231218.ebuild
new file mode 100644
index 000000000000..1910811a73ae
--- /dev/null
+++ b/app-emacs/lsp-mode/lsp-mode-8.0.1_pre20231218.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT=5b2f3741bb797371bba2932653ca829167f9745a
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Emacs client/library for the Language Server Protocol"
+HOMEPAGE="https://emacs-lsp.github.io/lsp-mode/"
+SRC_URI="https://github.com/emacs-lsp/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/dash-2.18.0
+ >=app-emacs/f-0.20.0
+ app-emacs/ht
+ app-emacs/lv
+ app-emacs/markdown-mode
+ app-emacs/spinner
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/deferred
+ app-emacs/ecukes
+ app-emacs/el-mock
+ app-emacs/espuds
+ app-emacs/flycheck
+ app-emacs/undercover
+ )
+"
+
+DOCS=( AUTHORS CHANGELOG.org README.md refcard )
+BYTECOMPFLAGS="-L . -L clients"
+ELISP_REMOVE="
+ test/lsp-clangd-test.el
+ test/lsp-common-test.el
+ test/lsp-integration-test.el
+" # Remove failing tests.
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert-runner "${S}" -t "!no-win" -t "!org"
+
+src_compile() {
+ elisp_src_compile
+ elisp-compile clients/*.el
+}
+
+src_install() {
+ elisp_src_install
+ elisp-install "${PN}/clients" clients/*
+}