summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/elib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/elib')
-rw-r--r--app-emacs/elib/Manifest1
-rw-r--r--app-emacs/elib/elib-1.0-r1.ebuild34
-rw-r--r--app-emacs/elib/files/50elib-gentoo.el1
-rw-r--r--app-emacs/elib/files/elib-1.0-texinfo-5.patch14
-rw-r--r--app-emacs/elib/metadata.xml5
5 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/elib/Manifest b/app-emacs/elib/Manifest
new file mode 100644
index 000000000000..ddeba21bb9d2
--- /dev/null
+++ b/app-emacs/elib/Manifest
@@ -0,0 +1 @@
+DIST elib-1.0.tar.gz 58335 SHA256 2109764b6220e2936e7d98effc323723f688f148dc66519cdb79d07bfe82f134 SHA512 ca5d6e0861f3d8d049911a9e4455169263bd781992103baacadae560fce0fedddb734617338cb5fac51420fcb2035622042836fa7198fe7bec312a0015da266d WHIRLPOOL 3093777dcddade3d4c69deaff9b9c23a2e53f6ec747e536e435d352e881230d183299663fc73a0173bda94d3862aef744ea5f4e387c1fd5cb9002091b3a71847
diff --git a/app-emacs/elib/elib-1.0-r1.ebuild b/app-emacs/elib/elib-1.0-r1.ebuild
new file mode 100644
index 000000000000..f637daed9fc9
--- /dev/null
+++ b/app-emacs/elib/elib-1.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp eutils
+
+DESCRIPTION="The Emacs Lisp Library"
+HOMEPAGE="http://jdee.sourceforge.net"
+SRC_URI="http://jdee.sunsite.dk/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-texinfo-5.patch"
+ sed -i 's:--infodir:--info-dir:g' Makefile || die
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ dodir "${SITELISP}/elib"
+ dodir /usr/share/info
+ emake prefix="${ED}/usr" infodir="${ED}/usr/share/info" install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc ChangeLog NEWS README TODO
+}
diff --git a/app-emacs/elib/files/50elib-gentoo.el b/app-emacs/elib/files/50elib-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/elib/files/50elib-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/elib/files/elib-1.0-texinfo-5.patch b/app-emacs/elib/files/elib-1.0-texinfo-5.patch
new file mode 100644
index 000000000000..53d18d248355
--- /dev/null
+++ b/app-emacs/elib/files/elib-1.0-texinfo-5.patch
@@ -0,0 +1,14 @@
+--- elib-1.0-orig/elib.texi
++++ elib-1.0/elib.texi
+@@ -33,9 +33,9 @@
+ @sp 4
+ @comment The title is printed in a large font.
+ @center @titlefont{User's Guide}
+-@sp
++@sp 1
+ @center @titlefont{to}
+-@sp
++@sp 1
+ @center @titlefont{Elib - The Emacs Lisp Library}
+ @sp 2
+ @center version 1.0
diff --git a/app-emacs/elib/metadata.xml b/app-emacs/elib/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/elib/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>