summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-18 19:20:31 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-18 19:20:31 +0200
commitcdae0ef9e87e7f7b6aa87482a427c4c393f4b76a (patch)
treeb3eb88e2726f0ec2353bd04511af4d45fc25a5b6 /app-editors
parentdev-perl/Class-Loader: -r bump for EAPI7 (diff)
downloadgentoo-cdae0ef9e87e7f7b6aa87482a427c4c393f4b76a.tar.gz
gentoo-cdae0ef9e87e7f7b6aa87482a427c4c393f4b76a.tar.bz2
gentoo-cdae0ef9e87e7f7b6aa87482a427c4c393f4b76a.zip
app-editors/ghostwriter: Fix build with Qt 5.15
Closes: https://bugs.gentoo.org/728408 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ghostwriter/files/ghostwriter-1.8.1-qt-5.15.patch21
-rw-r--r--app-editors/ghostwriter/ghostwriter-1.8.1.ebuild5
2 files changed, 25 insertions, 1 deletions
diff --git a/app-editors/ghostwriter/files/ghostwriter-1.8.1-qt-5.15.patch b/app-editors/ghostwriter/files/ghostwriter-1.8.1-qt-5.15.patch
new file mode 100644
index 000000000000..0f7425ff35e7
--- /dev/null
+++ b/app-editors/ghostwriter/files/ghostwriter-1.8.1-qt-5.15.patch
@@ -0,0 +1,21 @@
+From f8f4ec0a1b53d1f3e670817f051c59444851cf7f Mon Sep 17 00:00:00 2001
+From: Jakob Gahde <j5lx@fmail.co.uk>
+Date: Tue, 9 Jun 2020 10:30:44 +0200
+Subject: [PATCH] Fix build error with Qt 5.15
+
+---
+ src/MarkdownEditor.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/MarkdownEditor.cpp b/src/MarkdownEditor.cpp
+index c5e46d5..c103173 100644
+--- a/src/MarkdownEditor.cpp
++++ b/src/MarkdownEditor.cpp
+@@ -30,6 +30,7 @@
+ #include <QUrl>
+ #include <QPixmap>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QFileInfo>
+ #include <QDir>
+
diff --git a/app-editors/ghostwriter/ghostwriter-1.8.1.ebuild b/app-editors/ghostwriter/ghostwriter-1.8.1.ebuild
index 0943a04747d6..eb51f8371cc7 100644
--- a/app-editors/ghostwriter/ghostwriter-1.8.1.ebuild
+++ b/app-editors/ghostwriter/ghostwriter-1.8.1.ebuild
@@ -30,7 +30,10 @@ DEPEND="${RDEPEND}"
DOCS=( CREDITS.md README.md )
-PATCHES=( "${FILESDIR}/${P}-appdata-path.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-appdata-path.patch"
+ "${FILESDIR}/${P}-qt-5.15.patch" # git master
+)
src_prepare() {
default