summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-10-04 21:50:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-10-04 21:50:40 +0300
commit04ebdc8b8617ba09e3ea4003a69544b4a714702c (patch)
treed65f8626bc068a54ee99d5ef677c68d519a521f8 /app-editors
parentdev-python/django: Remove old (diff)
downloadgentoo-04ebdc8b8617ba09e3ea4003a69544b4a714702c.tar.gz
gentoo-04ebdc8b8617ba09e3ea4003a69544b4a714702c.tar.bz2
gentoo-04ebdc8b8617ba09e3ea4003a69544b4a714702c.zip
app-editors/vscode: add 1.83.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscode/Manifest3
-rw-r--r--app-editors/vscode/vscode-1.83.0.ebuild112
2 files changed, 115 insertions, 0 deletions
diff --git a/app-editors/vscode/Manifest b/app-editors/vscode/Manifest
index 937e527820e9..9f686f20f7da 100644
--- a/app-editors/vscode/Manifest
+++ b/app-editors/vscode/Manifest
@@ -10,3 +10,6 @@ DIST vscode-1.82.2-arm64.tar.gz 132356434 BLAKE2B 4d74c79286a3294a73db629eb318af
DIST vscode-1.82.3-amd64.tar.gz 135431570 BLAKE2B 044ac09d4a75f0bc075e164061be763663e75798f28bbe88b9bb049a80791692fab6b6016e9f07e1b8360370e0faa3d4cce6ad1e3300600851dab268afcebf4b SHA512 f5365fd13e365241e6de2acd2ee86a4616fd346d5db6b81e40a384de5107c602e6fac5d14d02b500f4587cf05a65d0519756b13581f1c92040b47bd39bc2916c
DIST vscode-1.82.3-arm.tar.gz 122196444 BLAKE2B 1c2d7f9dcf08c4f47faf599c39afb8580ecf4812f28cfd83ee7d09e1ffc28ef956ee9e69a9b431e16b8d80028936eb376fab17330e5d0176642ba3d387882018 SHA512 f5e97eeccd1cc4b8dda881cd10534b41bf7f648aee121f1538f8e1afabeb965c4784eb123000e27f3fbb0d866d0b9818e042c7b4401de9793a34c321ada822cd
DIST vscode-1.82.3-arm64.tar.gz 132356391 BLAKE2B 04252655fc0473db6850b946aee1d3e6532c936841f4cea22508e3e42b36d9b5e04861688d53a2ced09de284e11ae534022e11523b6ade66218511ebff856c36 SHA512 76c3255170aab5606c5fc18312973152a0b5bdb60f19b5d295d0d7419ae4233d4df5ba64897c2f7dc3f74093efad9b8c4fa419256b01d149e80e16e7dedd2463
+DIST vscode-1.83.0-amd64.tar.gz 135783477 BLAKE2B ab8d74efddad2717a6e189644a2eb2e6e6a8c51bf84150b722847ba9b7022f181f6a7225b3f0f04f345b5dc2690ff4859425b06d52f1db75c716db87a06de1d1 SHA512 4c71a8b340cdfac577dae7c5f6a70e1d556fa516ff42f562c1ec6f8aaa89b101c4751d936fbb7af426429a70e111262c0a6e230584aaf43691556571d1eefad3
+DIST vscode-1.83.0-arm.tar.gz 122748258 BLAKE2B 535de1d0d61746b501a4377f482e2b09ad470959217ac96455d99738926b2a9c5df7fe2806daba080d0d6bd22df316258c7f04cfdaf1d9fdc966c4585c325455 SHA512 740fb983903a05cc5ca31cedac096fbfe5356df82f11654523b8fc957a7ea7171db9fa8693a21a5e72aadb31d6c76249dd7311052912aff4a81777a22951b65c
+DIST vscode-1.83.0-arm64.tar.gz 133019602 BLAKE2B e11cf5b340d638884ee898040e7cd7791c03e63669a3cdc1efc4efd6542e9ec8a4f0e91d25021763d0bc5530d84c932cd71455561de502cf78b99be5b0d54dda SHA512 35a74ab0cb99825cd652af145bdbed42ccfbb26b43a5e36d87612df8ece7b88020488196535fa8b997d67b09948f8a332f0838b5129cadd396e66080983d3cec
diff --git a/app-editors/vscode/vscode-1.83.0.ebuild b/app-editors/vscode/vscode-1.83.0.ebuild
new file mode 100644
index 000000000000..8a367acedd94
--- /dev/null
+++ b/app-editors/vscode/vscode-1.83.0.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="Multiplatform Visual Studio Code from Microsoft"
+HOMEPAGE="https://code.visualstudio.com"
+SRC_URI="
+ amd64? ( https://update.code.visualstudio.com/${PV}/linux-x64/stable -> ${P}-amd64.tar.gz )
+ arm? ( https://update.code.visualstudio.com/${PV}/linux-armhf/stable -> ${P}-arm.tar.gz )
+ arm64? ( https://update.code.visualstudio.com/${PV}/linux-arm64/stable -> ${P}-arm64.tar.gz )
+"
+S="${WORKDIR}"
+
+RESTRICT="mirror strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ Microsoft-vscode
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE="kerberos"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+ kerberos? ( app-crypt/mit-krb5 )
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ if use amd64; then
+ cd "${WORKDIR}/VSCode-linux-x64" || die
+ elif use arm; then
+ cd "${WORKDIR}/VSCode-linux-armhf" || die
+ elif use arm64; then
+ cd "${WORKDIR}/VSCode-linux-arm64" || die
+ else
+ die "Visual Studio Code only supports amd64, arm and arm64"
+ fi
+
+ # Cleanup
+ rm -r ./resources/app/ThirdPartyNotices.txt || die
+
+ # Disable update server
+ sed -e "/updateUrl/d" -i ./resources/app/product.json || die
+
+ if ! use kerberos; then
+ rm -r ./resources/app/node_modules.asar.unpacked/kerberos || die
+ fi
+
+ # Install
+ pax-mark m code
+ mkdir -p "${ED}/opt/${PN}" || die
+ cp -r . "${ED}/opt/${PN}" || die
+ fperms 4711 /opt/${PN}/chrome-sandbox
+
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/vscode"
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/code"
+ domenu "${FILESDIR}/vscode.desktop"
+ domenu "${FILESDIR}/vscode-url-handler.desktop"
+ domenu "${FILESDIR}/vscode-wayland.desktop"
+ domenu "${FILESDIR}/vscode-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscode.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "keyring support inside vscode" "virtual/secret-service"
+}