summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2024-05-09 19:50:20 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-05-13 09:49:06 +0300
commite41b2bfc76e943bf53df3e23abdf3257df00a674 (patch)
tree0f699876bd7d5a4e62e203954f4e1f730ecd387b /app-editors/xmlcopyeditor
parentwww-client/firefox: support aarch64-unknown-linux-musl (diff)
downloadgentoo-e41b2bfc76e943bf53df3e23abdf3257df00a674.tar.gz
gentoo-e41b2bfc76e943bf53df3e23abdf3257df00a674.tar.bz2
gentoo-e41b2bfc76e943bf53df3e23abdf3257df00a674.zip
app-editors/xmlcopyeditor: fix dependencies
Closes: https://bugs.gentoo.org/923446 Signed-off-by: Chris Mayo <aklhfex@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35918 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors/xmlcopyeditor')
-rw-r--r--app-editors/xmlcopyeditor/files/xmlcopyeditor-1.3.1.0-libxml2-2.12.patch20
-rw-r--r--app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0-r1.ebuild50
2 files changed, 70 insertions, 0 deletions
diff --git a/app-editors/xmlcopyeditor/files/xmlcopyeditor-1.3.1.0-libxml2-2.12.patch b/app-editors/xmlcopyeditor/files/xmlcopyeditor-1.3.1.0-libxml2-2.12.patch
new file mode 100644
index 000000000000..c3036584524c
--- /dev/null
+++ b/app-editors/xmlcopyeditor/files/xmlcopyeditor-1.3.1.0-libxml2-2.12.patch
@@ -0,0 +1,20 @@
+--- a/src/wraplibxml.cpp
++++ b/src/wraplibxml.cpp
+@@ -706,7 +706,7 @@
+
+ wxString WrapLibxml::getLastError()
+ {
+- xmlErrorPtr err = xmlGetLastError();
++ const xmlError *err = xmlGetLastError();
+
+ if ( !err )
+ return nonParserError;
+@@ -722,7 +722,7 @@
+
+ std::pair<int, int> WrapLibxml::getErrorPosition()
+ {
+- xmlErrorPtr err = xmlGetLastError();
++ const xmlError *err = xmlGetLastError();
+ if ( !err )
+ return std::make_pair ( 1, 1 );
+
diff --git a/app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0-r1.ebuild b/app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0-r1.ebuild
new file mode 100644
index 000000000000..7c171ac605c7
--- /dev/null
+++ b/app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit autotools wxwidgets xdg
+
+DESCRIPTION="XML Copy Editor is a fast, free, validating XML editor"
+HOMEPAGE="https://xml-copy-editor.sourceforge.io"
+SRC_URI="https://downloads.sourceforge.net/xml-copy-editor/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 -ppc ~x86 ~amd64-linux ~x86-linux" # -ppc due SSE2 requirement
+IUSE="aqua nls"
+
+RDEPEND="
+ app-text/enchant:2
+ >=dev-libs/libxml2-2.12.5
+ dev-libs/libxslt
+ dev-libs/xerces-c[cpu_flags_x86_sse2,icu]
+ dev-libs/libpcre2
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}"/${P}-libxml2-2.12.patch )
+
+src_prepare() {
+ default
+
+ # bug #440744
+ sed -i -e 's/ -Wall -g -fexceptions//g' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ setup-wxwidgets unicode
+ econf \
+ --with-gtk=3.0 \
+ --with-wx-config="${WX_CONFIG}" \
+ $(use_enable nls)
+}