summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-29 00:08:43 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-29 00:08:43 +0100
commitde2c720021b8aad37dd392a1a395fb47cf474bb9 (patch)
treec6811e690398e9dc57fdb89d51fdc4b9d1fc89ed /app-doc
parentacct-user/ziproxy: Add user for ziproxy (diff)
downloadgentoo-de2c720021b8aad37dd392a1a395fb47cf474bb9.tar.gz
gentoo-de2c720021b8aad37dd392a1a395fb47cf474bb9.tar.bz2
gentoo-de2c720021b8aad37dd392a1a395fb47cf474bb9.zip
app-doc/halibut: fix build with gcc-10
* Thanks to lekto@o2.pl for submitting the patch Closes: https://bugs.gentoo.org/707020 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/halibut/files/halibut-1.2-fno-common.patch22
-rw-r--r--app-doc/halibut/halibut-1.2.ebuild5
2 files changed, 25 insertions, 2 deletions
diff --git a/app-doc/halibut/files/halibut-1.2-fno-common.patch b/app-doc/halibut/files/halibut-1.2-fno-common.patch
new file mode 100644
index 000000000000..e547e304d9c3
--- /dev/null
+++ b/app-doc/halibut/files/halibut-1.2-fno-common.patch
@@ -0,0 +1,22 @@
+--- a/bk_paper.c
++++ b/bk_paper.c
+@@ -75,6 +75,8 @@
+ #include "halibut.h"
+ #include "paper.h"
+
++font_info *all_fonts;
++
+ typedef struct paper_conf_Tag paper_conf;
+ typedef struct paper_idx_Tag paper_idx;
+
+--- a/paper.h
++++ b/paper.h
+@@ -78,7 +78,7 @@ struct ligature_Tag {
+ * metrics are read in.
+ */
+
+-font_info *all_fonts;
++extern font_info *all_fonts;
+
+ struct font_info_Tag {
+ font_info *next;
diff --git a/app-doc/halibut/halibut-1.2.ebuild b/app-doc/halibut/halibut-1.2.ebuild
index 13c64206e3f6..933b648f2be5 100644
--- a/app-doc/halibut/halibut-1.2.ebuild
+++ b/app-doc/halibut/halibut-1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -12,7 +12,8 @@ SRC_URI="https://www.chiark.greenend.org.uk/~sgtatham/${PN}/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_compile() {
tc-export CC