summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-06-18 17:20:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-06-18 17:31:06 +0200
commita6fb4ec5e0b2af91d66c6a0791d5dc6b84c7a02a (patch)
tree8612c0964403b15cd44233bb412dd2e45f8375ea /app-crypt
parentdev-python/selenium: Stabilize 4.9.1-r1 arm, #908787 (diff)
downloadgentoo-a6fb4ec5e0b2af91d66c6a0791d5dc6b84c7a02a.tar.gz
gentoo-a6fb4ec5e0b2af91d66c6a0791d5dc6b84c7a02a.tar.bz2
gentoo-a6fb4ec5e0b2af91d66c6a0791d5dc6b84c7a02a.zip
app-crypt/qca: Fix build with USE=doc
Thanks-to: Thomas Bettler <thomas.bettler@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31427 Closes: https://bugs.gentoo.org/908454 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/qca/qca-2.3.6-r2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-crypt/qca/qca-2.3.6-r2.ebuild b/app-crypt/qca/qca-2.3.6-r2.ebuild
index 0cdc05cdc7ad..c87391d21e98 100644
--- a/app-crypt/qca/qca-2.3.6-r2.ebuild
+++ b/app-crypt/qca/qca-2.3.6-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake kde.org multibuild qmake-utils
+inherit cmake kde.org multibuild out-of-source-utils qmake-utils
DESCRIPTION="Qt Cryptographic Architecture (QCA)"
HOMEPAGE="https://userbase.kde.org/QCA"
@@ -89,6 +89,9 @@ src_configure() {
src_compile() {
multibuild_foreach_variant cmake_src_compile
+ if use doc; then
+ multibuild_for_best_variant cmake_build doc
+ fi
}
src_test() {
@@ -103,10 +106,7 @@ src_install() {
multibuild_foreach_variant cmake_src_install
if use doc; then
- pushd "${BUILD_DIR}" >/dev/null || die
- doxygen Doxyfile || die
- dodoc -r apidocs/html
- popd >/dev/null || die
+ multibuild_for_best_variant run_in_build_dir dodoc -r apidocs/html
fi
if use examples; then