summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Ratiu <adrian.ratiu@collabora.com>2024-10-20 16:49:11 +0300
committerSam James <sam@gentoo.org>2024-10-28 13:34:25 +0000
commit83af658fe676ff865949d57be8d946dc69dd2849 (patch)
tree5fd90eebba41fc68cd3e04a8aaec9f346e0972d2 /app-crypt
parentapp-office/sc-im: fix build w/ USE=-lua (diff)
downloadgentoo-83af658fe676ff865949d57be8d946dc69dd2849.tar.gz
gentoo-83af658fe676ff865949d57be8d946dc69dd2849.tar.bz2
gentoo-83af658fe676ff865949d57be8d946dc69dd2849.zip
app-crypt/gnupg-pkcs11-scd: add 9999 ebuild
This project depends upon the old libassuan v2 due to a build bug which got fixed upstream in the latest "master" branch, however upstream releases are very far in between (last was in Jan 2022) so we add the 9999 ebuild which works nicely with libassuan 3.0. I've asked upstream to cut a new release containing the fix [1] however I don't know how long that will take and we can still have the same problems down the line, so it's useful to have a 9999 git ebuild. Link: [1] https://github.com/alonbl/gnupg-pkcs11-scd/issues/65 Signed-off-by: Adrian Ratiu <adrian.ratiu@collabora.com> Closes: https://github.com/gentoo/gentoo/pull/39056 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg-pkcs11-scd/gnupg-pkcs11-scd-9999.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-crypt/gnupg-pkcs11-scd/gnupg-pkcs11-scd-9999.ebuild b/app-crypt/gnupg-pkcs11-scd/gnupg-pkcs11-scd-9999.ebuild
new file mode 100644
index 000000000000..338e9e3bd924
--- /dev/null
+++ b/app-crypt/gnupg-pkcs11-scd/gnupg-pkcs11-scd-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PKCS#11 support for GnuPG"
+HOMEPAGE="https://sourceforge.net/projects/gnupg-pkcs11/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/alonbl/gnupg-pkcs11-scd.git"
+ inherit autotools git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/alonbl/${PN}/releases/download/${P}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="BSD"
+SLOT="0"
+IUSE="proxy"
+
+DEPEND="
+ dev-libs/openssl:=
+ dev-libs/libassuan:=
+ dev-libs/libgcrypt:=
+ dev-libs/libgpg-error:=
+ dev-libs/pkcs11-helper:="
+RDEPEND="
+ ${DEPEND}
+ proxy? (
+ acct-group/gnupg-pkcs11
+ acct-group/gnupg-pkcs11-scd-proxy
+ acct-user/gnupg-pkcs11-scd-proxy
+ )"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ eautoreconf
+ local myeconfargs=(
+ $(use_enable proxy)
+ --with-proxy-socket=/run/gnupg-pkcs11-scd-proxy/cmd
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use proxy; then
+ newinitd "${FILESDIR}"/gnupg-pkcs11-scd-proxy.initd gnupg-pkcs11-scd-proxy
+ newconfd "${FILESDIR}"/gnupg-pkcs11-scd-proxy.confd gnupg-pkcs11-scd-proxy
+ fi
+}