summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2022-03-06 19:39:36 -0600
committerSam James <sam@gentoo.org>2022-03-08 13:21:19 +0000
commit79c83f53cfdd9a7a356a57531672996b9e463ecc (patch)
treecd04a79a974dee8b3efcab7601e10ea61ced3319 /app-crypt
parentnet-misc/r8125: new package for Realtek r8125 driver (diff)
downloadgentoo-79c83f53cfdd9a7a356a57531672996b9e463ecc.tar.gz
gentoo-79c83f53cfdd9a7a356a57531672996b9e463ecc.tar.bz2
gentoo-79c83f53cfdd9a7a356a57531672996b9e463ecc.zip
app-crypt/tpm2-abrmd: Bump to 2.4.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/tpm2-abrmd/Manifest1
-rw-r--r--app-crypt/tpm2-abrmd/tpm2-abrmd-2.4.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-crypt/tpm2-abrmd/Manifest b/app-crypt/tpm2-abrmd/Manifest
index d9f218e7e518..3f71157aff47 100644
--- a/app-crypt/tpm2-abrmd/Manifest
+++ b/app-crypt/tpm2-abrmd/Manifest
@@ -1 +1,2 @@
DIST tpm2-abrmd-2.4.0.tar.gz 575440 BLAKE2B 20c1fa772b016879adf28a67966450d64924bc1ac22b3111cf7376706335dc92fa8de97183d89c9d3ff5955dfb2a7617869469e9da61eb05847fd29b4a0208fd SHA512 c2ef05ca2db5a33d3067052779aa4c2485a63bd357d5fd90ef9d4644530b37aa28b906064eed3b15729131697a2a9d6b9cc3f05bea04810fd6601e405af48110
+DIST tpm2-abrmd-2.4.1.tar.gz 577259 BLAKE2B 7d97e1069a171f3693fb11b8e2ce0243993f4352aae9fd691bfbf1b8fcef8615b79957f8f662ac00fe59bf7e3830d8abb79c67790f7be1cd3140fd1c7b1ed560 SHA512 0335285678cfceca4f185981ded90d213ff796cadddc9b5d6dbf2db533f81023a0f1089bbd8a8017bccb95190889be23b24d38a176d3368d221479aff4ff7d6c
diff --git a/app-crypt/tpm2-abrmd/tpm2-abrmd-2.4.1.ebuild b/app-crypt/tpm2-abrmd/tpm2-abrmd-2.4.1.ebuild
new file mode 100644
index 000000000000..482e6f408a99
--- /dev/null
+++ b/app-crypt/tpm2-abrmd/tpm2-abrmd-2.4.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd
+
+DESCRIPTION="TPM2 Access Broker & Resource Manager"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-abrmd"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="static-libs test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="acct-group/tss
+ acct-user/tss
+ sys-apps/dbus
+ dev-libs/glib:=
+ app-crypt/tpm2-tss"
+DEPEND="${RDEPEND}
+ test? (
+ app-crypt/swtpm
+ >=app-crypt/tpm2-tss-3.0.0
+ dev-util/cmocka
+ )"
+BDEPEND="virtual/pkgconfig
+ dev-util/gdbus-codegen"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable test unit) \
+ $(use_enable test integration) \
+ --disable-defaultflags \
+ --with-dbuspolicydir="${EPREFIX}/etc/dbus-1/system.d" \
+ --with-systemdpresetdir="$(systemd_get_systemunitdir)/../system-preset" \
+ --with-systemdpresetdisable \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+src_install() {
+ default
+
+ if [[ ${PV} != $(sed -n -e 's/^Version: //p' "${ED}/usr/$(get_libdir)/pkgconfig/tss2-tcti-tabrmd.pc" || die) ]] ; then
+ # Safeguard for bug #833887
+ die "pkg-config file version doesn't match ${PV}! Please report a bug!"
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}