summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2017-08-24 10:07:07 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-24 23:56:12 +0200
commit51a6aef7d31ccebc610092afd9e407f6947fd033 (patch)
tree9e2532c6e3cd17a4dcb02ea278570b8d8fec157a /app-crypt
parentnet-wireless/bluez: Drop old (diff)
downloadgentoo-51a6aef7d31ccebc610092afd9e407f6947fd033.tar.gz
gentoo-51a6aef7d31ccebc610092afd9e407f6947fd033.tar.bz2
gentoo-51a6aef7d31ccebc610092afd9e407f6947fd033.zip
app-crypt/moolticute: new package
Closes: https://github.com/gentoo/gentoo/pull/5520 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/moolticute/Manifest1
-rw-r--r--app-crypt/moolticute/files/50-mooltipass.rule1
-rw-r--r--app-crypt/moolticute/files/moolticuted.init12
-rw-r--r--app-crypt/moolticute/metadata.xml16
-rw-r--r--app-crypt/moolticute/moolticute-0.9.8_beta.ebuild55
-rw-r--r--app-crypt/moolticute/moolticute-9999.ebuild55
6 files changed, 140 insertions, 0 deletions
diff --git a/app-crypt/moolticute/Manifest b/app-crypt/moolticute/Manifest
new file mode 100644
index 000000000000..4d89ad9c7994
--- /dev/null
+++ b/app-crypt/moolticute/Manifest
@@ -0,0 +1 @@
+DIST moolticute-0.9.8_beta.tar.gz 4471922 SHA256 6d1524d104579c03901e1727c7eed3511fe74ce4dc538d846e69d28652129ddb SHA512 9b5829105172b9e461bfccf60de42aa0dc8529e319292006449f54f8590b3cf002c0e9b555b8ab379a6bfe6dad2e40ed142ea140e254337fa035f09e97e49465 WHIRLPOOL de95aed7084b974e370c14bafd989c4f07494fa5bccec64543bb944db73baf3cb0c5cb80bd7fc6314c38b3d30c661862aae72f19e098411f24db73710ffbf60b
diff --git a/app-crypt/moolticute/files/50-mooltipass.rule b/app-crypt/moolticute/files/50-mooltipass.rule
new file mode 100644
index 000000000000..4bfd907d7257
--- /dev/null
+++ b/app-crypt/moolticute/files/50-mooltipass.rule
@@ -0,0 +1 @@
+SUBSYSTEM=="usb", ATTRS{idVendor}=="16d0", ATTRS{idProduct}=="09a0", TAG+="uaccess"
diff --git a/app-crypt/moolticute/files/moolticuted.init b/app-crypt/moolticute/files/moolticuted.init
new file mode 100644
index 000000000000..4a331db1c3a4
--- /dev/null
+++ b/app-crypt/moolticute/files/moolticuted.init
@@ -0,0 +1,12 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+command=/usr/bin/moolticuted
+command_args=""
+pidfile=/var/run/moolticuted.pid
+start_stop_daemon_args="--make-pidfile --background --user nobody --group usb"
+
+depend() {
+ need udev
+}
diff --git a/app-crypt/moolticute/metadata.xml b/app-crypt/moolticute/metadata.xml
new file mode 100644
index 000000000000..ff819ee05d46
--- /dev/null
+++ b/app-crypt/moolticute/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>nemunaire@nemunai.re</email>
+ <name>Pierre-Olivier Mercier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">raoulh/moolticute</remote-id>
+ <bugs-to>https://github.com/raoulh/moolticute/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/moolticute/moolticute-0.9.8_beta.ebuild b/app-crypt/moolticute/moolticute-0.9.8_beta.ebuild
new file mode 100644
index 000000000000..8609d2fec945
--- /dev/null
+++ b/app-crypt/moolticute/moolticute-0.9.8_beta.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/raoulh/moolticute.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/raoulh/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+inherit gnome2-utils qmake-utils udev
+
+DESCRIPTION="Mooltipass crossplatform daemon/tools"
+HOMEPAGE="https://github.com/raoulh/moolticute"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/libusb-1.0.20
+ >=dev-qt/qtcore-5.6:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qttest:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ eqmake5 PREFIX="/usr" Moolticute.pro
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ udev_dorules "${FILESDIR}/50-mooltipass.rule"
+ newinitd "${FILESDIR}/moolticuted.init" moolticuted
+}
+
+pkg_postinst() {
+ udev_reload
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-crypt/moolticute/moolticute-9999.ebuild b/app-crypt/moolticute/moolticute-9999.ebuild
new file mode 100644
index 000000000000..8609d2fec945
--- /dev/null
+++ b/app-crypt/moolticute/moolticute-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/raoulh/moolticute.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/raoulh/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+inherit gnome2-utils qmake-utils udev
+
+DESCRIPTION="Mooltipass crossplatform daemon/tools"
+HOMEPAGE="https://github.com/raoulh/moolticute"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/libusb-1.0.20
+ >=dev-qt/qtcore-5.6:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qttest:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ eqmake5 PREFIX="/usr" Moolticute.pro
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ udev_dorules "${FILESDIR}/50-mooltipass.rule"
+ newinitd "${FILESDIR}/moolticuted.init" moolticuted
+}
+
+pkg_postinst() {
+ udev_reload
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}