summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/stan
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/stan')
-rw-r--r--app-crypt/stan/Manifest1
-rw-r--r--app-crypt/stan/files/stan-0.4.1-errno.patch26
-rw-r--r--app-crypt/stan/metadata.xml5
-rw-r--r--app-crypt/stan/stan-0.4.1.ebuild27
4 files changed, 59 insertions, 0 deletions
diff --git a/app-crypt/stan/Manifest b/app-crypt/stan/Manifest
new file mode 100644
index 000000000000..ffdb6f918666
--- /dev/null
+++ b/app-crypt/stan/Manifest
@@ -0,0 +1 @@
+DIST stan-0.4.1.tar.gz 37471 SHA256 b010ffa03d9ad8e8d7cf2cfc2692faec67f6e177ac54b432b2e2bff50b258f5b SHA512 f7c123c9887a6cf994d66d950fc50c42340b35ae6353b69918be95cc7886b59ed2042a85c40596dcf25724043810c50f81c977c54af26af0e7131c12bda0e00b WHIRLPOOL ab529e5bf9f761f99095d9442d03ff558002db6be85398f6c4925c8b8ea8314f70f461275307e6e7782f3134854bcade2a85cea69efe406c838aaec52065e900
diff --git a/app-crypt/stan/files/stan-0.4.1-errno.patch b/app-crypt/stan/files/stan-0.4.1-errno.patch
new file mode 100644
index 000000000000..a63810c1ac1b
--- /dev/null
+++ b/app-crypt/stan/files/stan-0.4.1-errno.patch
@@ -0,0 +1,26 @@
+--- src/data.c.orig 2005-12-05 13:23:44.000000000 +0200
++++ src/data.c 2005-12-05 13:24:31.000000000 +0200
+@@ -55,7 +55,9 @@
+ #include <stats.h>
+ #include <config.h>
+
+-extern int errno, verbose, progress, bits;
++#include <errno.h>
++
++extern int verbose, progress, bits;
+ extern tnode_t **treap;
+ extern bnode_t *bintree;
+ size_t size = 0;
+--- src/stan.c.orig 2005-12-05 13:23:49.000000000 +0200
++++ src/stan.c 2005-12-05 13:24:57.000000000 +0200
+@@ -46,7 +46,9 @@
+ #include <bits.h>
+ #include <config.h>
+
+-int errno, verbose = 0, progress = 0, bits = 0;
++#include <errno.h>
++
++int verbose = 0, progress = 0, bits = 0;
+
+ void print_usage()
+ {
diff --git a/app-crypt/stan/metadata.xml b/app-crypt/stan/metadata.xml
new file mode 100644
index 000000000000..d68fe974c15a
--- /dev/null
+++ b/app-crypt/stan/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+</pkgmetadata>
diff --git a/app-crypt/stan/stan-0.4.1.ebuild b/app-crypt/stan/stan-0.4.1.ebuild
new file mode 100644
index 000000000000..401b67f9dfd4
--- /dev/null
+++ b/app-crypt/stan/stan-0.4.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+inherit autotools eutils
+
+DESCRIPTION="Stan is a console application that analyzes binary streams and calculates statistical information"
+HOMEPAGE="http://www.roqe.org/stan/"
+SRC_URI="http://www.roqe.org/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-errno.patch"
+ sed -i -e "s/-O3/${CFLAGS}/" configure.in || die "sed failed"
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.in || die
+ eautoreconf
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc README || die
+}