summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2023-07-30 19:27:05 +0300
committerMatthew Smith <matthew@gentoo.org>2023-07-31 18:08:58 +0100
commitcd3ce4989d9ad03b383537b95869307d5f262aeb (patch)
tree36142ad4a9bfe8ed82f01d537a70fb16eb36c302 /app-crypt/certbot-dns-dnsimple
parentapp-crypt/certbot-dns-dnsimple: adopt package (diff)
downloadgentoo-cd3ce4989d9ad03b383537b95869307d5f262aeb.tar.gz
gentoo-cd3ce4989d9ad03b383537b95869307d5f262aeb.tar.bz2
gentoo-cd3ce4989d9ad03b383537b95869307d5f262aeb.zip
app-crypt/certbot-dns-dnsimple: add 2.6.0
Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'app-crypt/certbot-dns-dnsimple')
-rw-r--r--app-crypt/certbot-dns-dnsimple/Manifest1
-rw-r--r--app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.6.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-crypt/certbot-dns-dnsimple/Manifest b/app-crypt/certbot-dns-dnsimple/Manifest
index 6e68f1eb7af9..8dc9745d17ef 100644
--- a/app-crypt/certbot-dns-dnsimple/Manifest
+++ b/app-crypt/certbot-dns-dnsimple/Manifest
@@ -1 +1,2 @@
+DIST certbot-2.6.0.gh.tar.gz 1336339 BLAKE2B 0c0575ad553ebe0f3ab56da750572bca46b30d034033e43c30c3793c114050ad824a277eab0be5a47326ea099e58e9a421448b53fc1b9173afae9a0ec308ac62 SHA512 d694156886484511f5a38fb5e40f98b2e2dbe4bc5110c95b2084ec03b39cb0eb9bbc623c7bca4a81054e980c8dbac752949042391813298a27be7e70410882e3
DIST certbot-dns-dnsimple-1.31.0.gh.tar.gz 1371459 BLAKE2B 95fc9f29b1e91f5bc12a9b7146d00f4f3b4647eeda8e866c46c17d8d8a2443bd46cfa04758e8571e84b2bbf70bd68943c47ceaf6d830d3e5121e41d9548da051 SHA512 a2f6d7714bfc8e2c400e69be038404da138b53f0dc09e071048d560ba9e9527cc0b786b8d210b62c3d07c3aeadaee12dc0d060d144af4b5c3178576fde65b052
diff --git a/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.6.0.ebuild b/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.6.0.ebuild
new file mode 100644
index 000000000000..9169bbe14d00
--- /dev/null
+++ b/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-2.6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="DNSimple Authenticator plugin for Certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://certbot-dns-dnsimple.readthedocs.io/en/stable/"
+# Use common certbot tarball
+SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.gh.tar.gz"
+
+S="${WORKDIR}/certbot-${PV}/${PN}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/dns-lexicon-3.2.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest