summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-05-29 23:16:46 +0100
committerMarek Szuba <marecki@gentoo.org>2022-05-29 23:16:46 +0100
commitf9741ffa8b1eaf283306886240a31e887012ad7a (patch)
treefe821155780d2d8864910c1dd7ec028e6f99349d /app-containers/apptainer
parentapp-text/xiphos: disable the editor (diff)
downloadgentoo-f9741ffa8b1eaf283306886240a31e887012ad7a.tar.gz
gentoo-f9741ffa8b1eaf283306886240a31e887012ad7a.tar.bz2
gentoo-f9741ffa8b1eaf283306886240a31e887012ad7a.zip
app-containers/apptainer: trim upstream CFLAGS
-DFORTIFY_SOURCE=2 is a Gentoo default and it being explicitly mentioned makes things more difficult for those who would rather use level 3. Nuking -Werror should require no explanation. Closes: https://bugs.gentoo.org/847895 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-containers/apptainer')
-rw-r--r--app-containers/apptainer/apptainer-1.0.2.ebuild4
-rw-r--r--app-containers/apptainer/files/apptainer-1.0.2-trim_upstream_cflags.patch24
2 files changed, 28 insertions, 0 deletions
diff --git a/app-containers/apptainer/apptainer-1.0.2.ebuild b/app-containers/apptainer/apptainer-1.0.2.ebuild
index 9f711a070ada..56b48324770c 100644
--- a/app-containers/apptainer/apptainer-1.0.2.ebuild
+++ b/app-containers/apptainer/apptainer-1.0.2.ebuild
@@ -30,6 +30,10 @@ BDEPEND="virtual/pkgconfig"
CONFIG_CHECK="~SQUASHFS"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.2-trim_upstream_cflags.patch
+)
+
DOCS=( README.md CONTRIBUTORS.md CONTRIBUTING.md )
src_configure() {
diff --git a/app-containers/apptainer/files/apptainer-1.0.2-trim_upstream_cflags.patch b/app-containers/apptainer/files/apptainer-1.0.2-trim_upstream_cflags.patch
new file mode 100644
index 000000000000..b1329b5d9d3e
--- /dev/null
+++ b/app-containers/apptainer/files/apptainer-1.0.2-trim_upstream_cflags.patch
@@ -0,0 +1,24 @@
+--- a/mconfig
++++ b/mconfig
+@@ -42,14 +42,14 @@
+
+ # user_cflags - user-defined CFLAGS without all the cflags_opts
+ user_cflags="$CFLAGS"
+-cflags_opts="-Wall -Werror -Wfatal-errors -Wno-unknown-warning-option \
++cflags_opts="-Wall -Wfatal-errors -Wno-unknown-warning-option \
+ -Wstrict-prototypes -Wpointer-arith -Wbad-function-cast \
+ -Woverlength-strings -Wframe-larger-than=2047 \
+ -Wno-sign-compare -Wclobbered -Wempty-body -Wmissing-parameter-type \
+ -Wtype-limits -Wunused-parameter -Wunused-but-set-parameter \
+ -Wno-discarded-qualifiers -Wno-incompatible-pointer-types \
+ -pipe -fmessage-length=0 -fPIC"
+-cflags="$CFLAGS -D_FORTIFY_SOURCE=2 -Wformat -Wformat-security -fstack-protector --param ssp-buffer-size=4"
++cflags="$CFLAGS -Wformat -Wformat-security -fstack-protector --param ssp-buffer-size=4"
+ ldflags=$LDFLAGS
+
+ package_name=apptainer
+--- a/mlocal/frags/go_runtime_opts.mk
++++ b/mlocal/frags/go_runtime_opts.mk
+@@ -1 +1 @@
+-CGO_CFLAGS += -O2 -D_FORTIFY_SOURCE=2 -Wformat -Wformat-security -fstack-protector --param ssp-buffer-size=4
++CGO_CFLAGS += -O2 -Wformat -Wformat-security -fstack-protector --param ssp-buffer-size=4