summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-06-13 11:41:24 +0100
committerMarek Szuba <marecki@gentoo.org>2024-06-13 12:36:54 +0100
commitc657731a4add4f9d49bdaad3cabbfe31352d1c37 (patch)
tree9456a70e5f6172062e957b774dd9cadfd45ef91e /app-containers/apptainer
parentnet-misc/connman-gtk: drop 1.1.1-r1 (diff)
downloadgentoo-c657731a4add4f9d49bdaad3cabbfe31352d1c37.tar.gz
gentoo-c657731a4add4f9d49bdaad3cabbfe31352d1c37.tar.bz2
gentoo-c657731a4add4f9d49bdaad3cabbfe31352d1c37.zip
app-containers/apptainer: drop 1.3.0
No versions vulnerable to CVE-2024-3727 left in the tree. Bug: https://bugs.gentoo.org/934141 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-containers/apptainer')
-rw-r--r--app-containers/apptainer/Manifest1
-rw-r--r--app-containers/apptainer/apptainer-1.3.0.ebuild92
2 files changed, 0 insertions, 93 deletions
diff --git a/app-containers/apptainer/Manifest b/app-containers/apptainer/Manifest
index befd02721059..cdb61e57210b 100644
--- a/app-containers/apptainer/Manifest
+++ b/app-containers/apptainer/Manifest
@@ -1,2 +1 @@
-DIST apptainer-1.3.0.tar.gz 17103544 BLAKE2B ed42b763a20b2b71cce6081b903697dc506073f91f9d928d49801165289d15c1416044af8fcedddcbd2a260c17a2e6488ed3d06b1edb4fb5f5ca5e9d14a14312 SHA512 a72afcac8e783f43732517314a94ffe039ab8f29027bcc398295fed97b123e6777039c016b6655a3cefbcba7e69832f62f3418b11e1bbd0452edc702ecaef69e
DIST apptainer-1.3.2.tar.gz 17129103 BLAKE2B a2c15d408dc956a4bc8cb154dadfe0e60aa8b4216277ff4afd508058f9425722fb66200e7d4ab33cf5a73aee34761ac198e7b31439ab69dfaceebb9f768b58e6 SHA512 c3112c8254c995f83e3ae424ecf734e8ca9583c34cd8b0e56fdde2a7ef8d5145ac68a7a2c9575b071515a2cb681d11423fe57a5a3910750d3bc697c85c15585d
diff --git a/app-containers/apptainer/apptainer-1.3.0.ebuild b/app-containers/apptainer/apptainer-1.3.0.ebuild
deleted file mode 100644
index 5f69289300ad..000000000000
--- a/app-containers/apptainer/apptainer-1.3.0.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit linux-info toolchain-funcs
-
-DESCRIPTION="The container system for secure high-performance computing"
-HOMEPAGE="https://apptainer.org/"
-SRC_URI="https://github.com/apptainer/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples +network suid systemd"
-
-# Do not complain about CFLAGS etc. since go projects do not use them.
-QA_FLAGS_IGNORED='.*'
-
-DEPEND="app-crypt/gpgme
- >=dev-lang/go-1.20.0
- dev-libs/openssl
- sys-apps/util-linux
- sys-fs/cryptsetup
- sys-fs/squashfs-tools
- sys-libs/libseccomp
- !suid? (
- sys-fs/e2fsprogs[fuse]
- sys-fs/squashfuse
- )"
-RDEPEND="${DEPEND}
- !sys-cluster/singularity"
-BDEPEND="virtual/pkgconfig"
-
-CONFIG_CHECK="~SQUASHFS"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.0.2-trim_upstream_cflags.patch
-)
-
-DOCS=( README.md CONTRIBUTORS.md CONTRIBUTING.md )
-
-src_configure() {
- local myconfargs=(
- -c "$(tc-getBUILD_CC)" \
- -x "$(tc-getBUILD_CXX)" \
- -C "$(tc-getCC)" \
- -X "$(tc-getCXX)" \
- --prefix="${EPREFIX}"/usr \
- --sysconfdir="${EPREFIX}"/etc \
- --runstatedir="${EPREFIX}"/run \
- --localstatedir="${EPREFIX}"/var \
- $(usex network "" "--without-network") \
- $(use_with suid)
- )
- ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
-}
-
-src_compile() {
- emake -C builddir
-}
-
-src_install() {
- emake DESTDIR="${D}" -C builddir install
- keepdir /var/${PN}/mnt/session
-
- if use systemd; then
- sed -i -e '/systemd cgroups/ s/no/yes/' "${ED}"/etc/${PN}/${PN}.conf \
- || die "Failed to enable systemd use in configuration"
- else
- sed -i -e '/systemd cgroups/ s/yes/no/' "${ED}"/etc/${PN}/${PN}.conf \
- || die "Failed to disable systemd use in configuration"
- fi
-
- einstalldocs
- if use examples; then
- dodoc -r examples
- fi
-}
-
-pkg_postinst() {
- if ! use suid; then
- local oldver
- for oldver in ${REPLACING_VERSIONS}; do
- if ver_test "${oldver}" -lt 1.1.0; then
- ewarn "Since version 1.1.0 ${PN} no longer installs setuid-root components by default, relying on unprivileged user namespaces instead. For details, see https://apptainer.org/docs/admin/main/user_namespace.html"
- ewarn "Make sure user namespaces (possibly except network ones for improved security) are enabled on your system, or re-enable installation of setuid root components by passing USE=suid to ${CATEGORY}/${PN}"
- break
- fi
- done
- fi
-}