summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-cdr/gcdemu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-cdr/gcdemu')
-rw-r--r--app-cdr/gcdemu/Manifest2
-rw-r--r--app-cdr/gcdemu/gcdemu-2.1.1.ebuild58
-rw-r--r--app-cdr/gcdemu/gcdemu-3.0.0.ebuild63
-rw-r--r--app-cdr/gcdemu/metadata.xml11
4 files changed, 134 insertions, 0 deletions
diff --git a/app-cdr/gcdemu/Manifest b/app-cdr/gcdemu/Manifest
new file mode 100644
index 000000000000..4d297de17c2c
--- /dev/null
+++ b/app-cdr/gcdemu/Manifest
@@ -0,0 +1,2 @@
+DIST gcdemu-2.1.1.tar.bz2 40156 SHA256 cd1d59fb6dadbc05f5865c1654089563aeb28ef9ea4216da2e223f8376887c5c SHA512 1d8d9cc29a1d7a69681fbd4dc540a97172d81ac3d018bd98af469746901c8841dd5fd23ca8ae6fce68e41b43d98fb693acba1b621ed6b72c97972038cde1c47a WHIRLPOOL 0dbc04b57c5026a642a268b6bbba9d55ca27c92c1a606048a7395ebc07527e83ea05578c398725ed3782f4cf678769e0b77c686f07fe3061334875a375da3a05
+DIST gcdemu-3.0.0.tar.bz2 45506 SHA256 1357a02720f05644929bae167fcc64dc58784f406aa426bcd806955cc458aad4 SHA512 c4d0d64638e0f7ecccfe11ab1a8527ba2002a5bbb382b2d4e8b58eaaa0a10140ee85b8d62ba93fe4ecdc2882301dfe62a08373dbb9e5404d5ddf7592cd5f0b7d WHIRLPOOL 18c8615ad6ae166c2111e7dd2f1c1d46b4128d99bb11a3f7e2f297c58dfff3e38ad981547703b13af940b0d1e6e3bccb7098180fde51458bfe34e3b19a66a465
diff --git a/app-cdr/gcdemu/gcdemu-2.1.1.ebuild b/app-cdr/gcdemu/gcdemu-2.1.1.ebuild
new file mode 100644
index 000000000000..6036f35101c2
--- /dev/null
+++ b/app-cdr/gcdemu/gcdemu-2.1.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+CMAKE_MIN_VERSION="2.8.5"
+PYTHON_COMPAT=( python2_7 )
+PLOCALES="de fr no pl sl zh_CN"
+
+# cmake-utils after gnome2, to make sure cmake-utils is used for building
+inherit gnome2 cmake-utils l10n python-single-r1
+
+DESCRIPTION="Gtk+ GUI for controlling cdemu-daemon"
+HOMEPAGE="http://cdemu.org/"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-cdr/cdemu-daemon:0/6
+ >=dev-libs/glib-2.28:2
+ dev-libs/gobject-introspection
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/librsvg:2
+ sys-apps/dbus
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]"
+DEPEND="${COMMON_DEPEND}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.21
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang src/gcdemu
+ # build system doesn't respect LINGUAS :/
+ l10n_find_plocales_changes po "" ".po"
+ rm_po() {
+ rm po/$1.po || die
+ }
+ l10n_for_each_disabled_locale_do rm_po
+}
+
+src_configure() {
+ DOCS="AUTHORS README"
+ local mycmakeargs=( -DPOST_INSTALL_HOOKS=OFF )
+ cmake-utils_src_configure
+}
diff --git a/app-cdr/gcdemu/gcdemu-3.0.0.ebuild b/app-cdr/gcdemu/gcdemu-3.0.0.ebuild
new file mode 100644
index 000000000000..0ee700a83237
--- /dev/null
+++ b/app-cdr/gcdemu/gcdemu-3.0.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+CMAKE_MIN_VERSION="2.8.5"
+PYTHON_COMPAT=( python2_7 )
+PLOCALES="no sl sv"
+
+# cmake-utils after gnome2, to make sure cmake-utils is used for building
+inherit gnome2 cmake-utils l10n python-single-r1
+
+DESCRIPTION="Gtk+ GUI for controlling cdemu-daemon"
+HOMEPAGE="http://cdemu.org/"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-cdr/cdemu-daemon:0/7
+ >=dev-libs/glib-2.28:2
+ dev-libs/gobject-introspection
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/librsvg:2
+ sys-apps/dbus
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]"
+DEPEND="${COMMON_DEPEND}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.21
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang src/gcdemu
+}
+
+src_configure() {
+ DOCS="AUTHORS README"
+ local mycmakeargs=( -DPOST_INSTALL_HOOKS=OFF )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ # Build system doesn't respect LINGUAS, and changing list of installed
+ # translations requires error-prone editing of CMakeLists.txt
+ rm_po() {
+ rm -r "${ED}"/usr/share/locale/$1 || die
+ ls "${ED}"/usr/share/locale/* &> /dev/null || rmdir "${ED}"/usr/share/locale || die
+ }
+ l10n_for_each_disabled_locale_do rm_po
+}
diff --git a/app-cdr/gcdemu/metadata.xml b/app-cdr/gcdemu/metadata.xml
new file mode 100644
index 000000000000..e56b6a0cf661
--- /dev/null
+++ b/app-cdr/gcdemu/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tetromino@gentoo.org</email>
+ <name>Alexandre Rostovtsev</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">cdemu</remote-id>
+ </upstream>
+</pkgmetadata>