summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-11-11 15:07:18 +0100
committerPetr Vaněk <arkamar@gentoo.org>2024-11-11 15:14:10 +0100
commit897e9bf1f4caa2f14296287327e79c77eba1128c (patch)
treebfe273d7689d77b8f90bc23fb39daa8092b04f0b /app-backup
parentapp-doc/eclass-manpages: add 20241111 (diff)
downloadgentoo-897e9bf1f4caa2f14296287327e79c77eba1128c.tar.gz
gentoo-897e9bf1f4caa2f14296287327e79c77eba1128c.tar.bz2
gentoo-897e9bf1f4caa2f14296287327e79c77eba1128c.zip
app-backup/borgmatic: add 1.9.1
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.9.1.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index 57e590f82422..f6681df97e31 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,2 +1,3 @@
DIST borgmatic-1.8.14.tar.gz 623966 BLAKE2B fd52bc5be4f63e1207a0bedcf654af075082d31af76ddc65ea30a3259f1ec093c826612e114fd9f9fa46668f80eed3b2b6a88262fbb9e4db49c36ba31efa70c5 SHA512 74daecbf02f957b21121dff073c2e114c87b1afdf6b3408b8fc2bf465102425cca60e4bdc8bc8d0e2d0a9c20b1f514eb7c9a2e136e71cb61969e07a38841235a
DIST borgmatic-1.9.0.tar.gz 636235 BLAKE2B ff71f8c811ca185926369402de5f2b1bd750135fcc66d54744056292994b781fba501945cf5dc39cc727d2c8f2ef360e79b4f2ba7a868f29bf0304722cae9649 SHA512 767b11451377d9ab046fe36272d523f1ec7c72fe162cc3eef09583f4e9a6e0d4bae09bb446b746a47e73fb4afdac1d0206b75b93a9fb2859987909f17aa87c43
+DIST borgmatic-1.9.1.tar.gz 636657 BLAKE2B 6061b49d501be28afe7a3a6ac928ec77233bb354e494e14584c1cdeb76e5c06cb9fe06e97f0eb0be4a5aa03c7f0359ce47a7b45044e95358b80ab0986ed5d9b8 SHA512 c86fd5a0d1db065df8e0f4366e2742be798e225cd3af2baea86e27f165cd9956f059f5d51f85f49715c40db51e7aca93a64f5a8fcefceec316a588560875ce69
diff --git a/app-backup/borgmatic/borgmatic-1.9.1.ebuild b/app-backup/borgmatic/borgmatic-1.9.1.ebuild
new file mode 100644
index 000000000000..3be6deb7c2b4
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.9.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd pypi
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="
+ https://torsion.org/borgmatic/
+ https://projects.torsion.org/borgmatic-collective/borgmatic
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="apprise"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ ')
+ apprise? ( $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ ') )"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.14-systemd_service_bin_path.patch
+ "${FILESDIR}"/${PN}-1.9.0-no_test_coverage.patch
+ "${FILESDIR}"/${PN}-1.9.0-build-backend.patch
+)
+
+# A fragile test whose only purpose is to make sure the NEWS file
+# has been updated for the current version.
+EPYTEST_DESELECT=(
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " ${PN} config generate"
+ elog
+ elog "Systemd users wishing to periodically run ${PN} can use the provided timer and service units."
+ else
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.9.0; then
+ ewarn "Please be warned that ${PN}-1.9.0 has introduced several breaking changes."
+ ewarn "For details, please see"
+ ewarn
+ ewarn " https://github.com/borgmatic-collective/borgmatic/releases/tag/1.9.0"
+ ewarn
+ break
+ fi
+ done
+ fi
+}