summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2020-03-05 09:28:57 -0500
committerRichard Freeman <rich0@gentoo.org>2020-03-05 09:28:57 -0500
commit0cf8c16da326403dd9f5a176b5ef7981575e8a57 (patch)
tree6290d47c38f151533603f2f12e8889683d20aa77 /app-backup/duplicity
parentwww-client/seamonkey: Dependency adjustments (diff)
downloadgentoo-0cf8c16da326403dd9f5a176b5ef7981575e8a57.tar.gz
gentoo-0cf8c16da326403dd9f5a176b5ef7981575e8a57.tar.bz2
gentoo-0cf8c16da326403dd9f5a176b5ef7981575e8a57.zip
app-backup/duplicity: bump
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'app-backup/duplicity')
-rw-r--r--app-backup/duplicity/Manifest1
-rw-r--r--app-backup/duplicity/duplicity-0.8.11.1596.ebuild50
-rw-r--r--app-backup/duplicity/files/duplicity-0.8.11.1596-fix-docs.patch21
3 files changed, 72 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index 07c65d3ac03f..fe2a5ebc7599 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -2,3 +2,4 @@ DIST duplicity-0.7.10.tar.gz 1543523 BLAKE2B a38c5310d6949d36f74620ef617f7909432
DIST duplicity-0.7.12.tar.gz 1552442 BLAKE2B 4a7d0609748bffa147994a4abdb88bc0d62905c1423dc91caa4b8e5bb0c5953e26df72f647697685cfa3caed3741658d00d1a2b62b8c47bb1ac61da8973df9ca SHA512 8a532e7bb548c170184666a0ba2b41a15f3002c14edd64b1b1eb4df862647fc6dfde797d6ecf38e326d7c160c31ff521baf351e520835495e1d0e2ddbdb19f0f
DIST duplicity-0.7.19.tar.gz 1727321 BLAKE2B 6441a2ce777b3b08c52ede8602a73080be372dec1c1788441c7e7135533aeeb3be48012db4bdfc2a78c7ca23d368637ccc7aa0f0361369ac9f42c00a1541e023 SHA512 26d1724a635c368e04f2a94f974ef6962c52b23345db59af3343e7221295caa0215ae119fff6ab44daa4622236683eb9d3dae742bf0d4cf08c02e3f63071001b
DIST duplicity-0.8.09.tar.gz 1856764 BLAKE2B b5d0dd3270c237694000dc36a65a4293c43264edf933a195692d2847d008a898d5cf95c0b21b285503023ef8885278485cebabc2d2b7094ae65e13d277c80e5a SHA512 e4045a1c1adbf0927ee5325f02b79e7c0b38034080be4b563f20f1af593c8c1943a772fe7f212730e60f7c7cee93756426fe769a62050d42651fd1af7f6ba50a
+DIST duplicity-0.8.11.1596.tar.gz 1872223 BLAKE2B ad3ee2536731d1a6e8fb3fd87bb69b8ce8b43bb90688fe957cfb2718ad44f57db98c3aec4805356a7d44bea681f6ec9603aa082dbf86e58684fbe8000d1676b5 SHA512 67940d73d8213559ba88ec21e1326aca0dd065888cbf2e3c68f0f515ba9246100fd6e6d0bd1f12cb678702559f2266b7905931506d2ff6fe6fd35c673593479b
diff --git a/app-backup/duplicity/duplicity-0.8.11.1596.ebuild b/app-backup/duplicity/duplicity-0.8.11.1596.ebuild
new file mode 100644
index 000000000000..8482e3100d26
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.8.11.1596.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/$(ver_cut 1-3)/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs.patch"
+)
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/files/duplicity-0.8.11.1596-fix-docs.patch b/app-backup/duplicity/files/duplicity-0.8.11.1596-fix-docs.patch
new file mode 100644
index 000000000000..6b8c710f3160
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-0.8.11.1596-fix-docs.patch
@@ -0,0 +1,21 @@
+--- duplicity-0.8.11.1596/setup.py 2020-03-05 09:18:42.532941503 -0500
++++ duplicity-0.8.11.1596/setup.py 2020-03-05 09:20:10.612061492 -0500
+@@ -88,18 +88,6 @@
+ u'bin/rdiffdir.1'
+ ]
+ ),
+- (u'share/doc/duplicity-%s' % version_string,
+- [
+- u'AUTHORS',
+- u'CHANGELOG',
+- u'Changelog.GNU',
+- u'COPYING',
+- u'README',
+- u'README-LOG',
+- u'README-REPO',
+- u'README-TESTING',
+- ],
+- ),
+ ]
+
+ if not os.environ.get(u'READTHEDOCS') == u'True':