summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-backup/ccollect
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-backup/ccollect')
-rw-r--r--app-backup/ccollect/Manifest3
-rw-r--r--app-backup/ccollect/ccollect-0.5.1.ebuild45
-rw-r--r--app-backup/ccollect/ccollect-0.7.1.ebuild73
-rw-r--r--app-backup/ccollect/ccollect-0.8.ebuild76
-rw-r--r--app-backup/ccollect/metadata.xml7
5 files changed, 204 insertions, 0 deletions
diff --git a/app-backup/ccollect/Manifest b/app-backup/ccollect/Manifest
new file mode 100644
index 000000000000..d85c285f945c
--- /dev/null
+++ b/app-backup/ccollect/Manifest
@@ -0,0 +1,3 @@
+DIST ccollect-0.5.1.tar.bz2 37397 SHA256 c3748b3aa52f8696b4cc5c6e760f5d94647c025348824303eef826aa9e7fe5e9 SHA512 93409ff0652575897fd63535daa32bd14baac329eafcbcb6f89d18a9686053360ae7a7953e39f67d68b5ceccd8c8e475132641ae1db2d1d289a91cb5054471eb WHIRLPOOL 049602daba95e3c3939e2d75d3094e74e18712d216a96c81ca32c722f7e40c5dc0b27e9ea5ee2a89c931ff096660f978d112d0a79441eaba4579fb71c16635b7
+DIST ccollect-0.7.1.tar.bz2 38054 SHA256 f1914a53954367a0110acc7e187298f5a0f7e40dd847baa328fa357aa3ea8640 SHA512 b436c7210c30b05c476a518b624c75f45a81eafe308bc6c8a16991910a85e02ee87b306511b8aaaf00bfe0cc05b0ba740eb8d839751cf8967e3f24a943460f10 WHIRLPOOL 837029c6c5ed933621a72c22193b2de567145254aaa0fcd5899b5bd74d3be3a4f4ee62cac88535c417d4a04d41f493e95f5862216d17942cca3f5657f3b2955e
+DIST ccollect-0.8.tar.bz2 60376 SHA256 d0b82b9b4fcd1601d8ea5fd2dae1fb22b1aaf23f12b5cfbf8b27b767e847929a SHA512 dc4b2a8687c636938154f8a4a4048c3f0ef13f6d6e3f6e66d8dcc8f544f3a390a98a8dbfb3ba2ba9019decbec5d628f07461dd3f803e14b2203972936ebf96f3 WHIRLPOOL fe2aaa405ab9f9038a5371170df86cbef2066d87ab948c59ddd2d55311af6a5a14d5bc0b6021c07d3123fb5f7ca5a59eff6f59c552db64f7f80999b31f6f9f9b
diff --git a/app-backup/ccollect/ccollect-0.5.1.ebuild b/app-backup/ccollect/ccollect-0.5.1.ebuild
new file mode 100644
index 000000000000..aacc1e12c101
--- /dev/null
+++ b/app-backup/ccollect/ccollect-0.5.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="(pseudo) incremental backup with different exclude lists using
+hardlinks and rsync"
+HOMEPAGE="http://unix.schottelius.org/ccollect/"
+SRC_URI="http://unix.schottelius.org/ccollect/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc x86"
+IUSE="doc"
+
+DEPEND="doc? ( >=app-text/asciidoc-7.0.2 )"
+RDEPEND="net-misc/rsync"
+
+src_compile() {
+ if use doc; then
+ make documentation
+ else
+ einfo 'Nothing to compile'
+ fi
+}
+
+src_install() {
+ dobin ccollect.sh
+
+ insinto /usr/share/${PN}/tools
+ doins tools/*
+
+ if use doc; then
+ dodoc doc/*
+
+ # dodoc is not recursive. So do a workaround.
+ insinto /usr/share/doc/${PF}/examples/
+ doins -r "${S}"/conf
+ fi
+}
+
+pkg_postinst() {
+ ewarn "If you're upgrading from 0.3.X or less, please run"
+ ewarn "/usr/share/ccollect/tools/config-pre-0.4-to-0.4.sh"
+ ewarn "because the old configuration is no longer compatible."
+}
diff --git a/app-backup/ccollect/ccollect-0.7.1.ebuild b/app-backup/ccollect/ccollect-0.7.1.ebuild
new file mode 100644
index 000000000000..736d9e036ce5
--- /dev/null
+++ b/app-backup/ccollect/ccollect-0.7.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+DESCRIPTION="(pseudo) incremental backup with different exclude lists using hardlinks and rsync"
+HOMEPAGE="http://unix.schottelius.org/ccollect/"
+SRC_URI="http://unix.schottelius.org/ccollect/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="doc examples"
+
+DEPEND="doc? ( >=app-text/asciidoc-8.1.0
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt )"
+RDEPEND="net-misc/rsync"
+
+src_compile() {
+ if use doc; then
+ emake XSL=/usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl documentation || die "building docs failed"
+ fi
+}
+
+src_install() {
+ dobin ccollect.sh
+ dosym ccollect.sh /usr/bin/ccollect
+
+ local tools="add_source analyse_logs check_config delete_source list_intervals logwrapper stats"
+ for t in ${tools} ; do
+ newbin tools/ccollect_${t}.sh ccollect_${t}
+ done
+
+ insinto /usr/share/${PN}/tools
+ doins tools/config-pre* tools/{gnu-du-backup-size-compare,report_success}.sh
+
+ dodoc CREDITS README
+ pushd doc/changes
+ for n in * ; do
+ newdoc ${n} NEWS-${n}
+ done
+ popd
+
+ if use doc; then
+ dohtml doc/*.htm doc/*.html
+ dohtml -r doc/man
+ doman doc/man/*.1
+ fi
+
+ if use examples ; then
+ # dodoc is not recursive. So do a workaround.
+ insinto /usr/share/doc/${PF}/examples/
+ cp -Rdp "${S}/conf" "${D}/usr/share/doc/${PF}/examples/"
+ fi
+}
+
+pkg_postinst() {
+ ewarn "If you're upgrading from 0.6.x or less, you'll have to"
+ ewarn "upgrade your existing configuration as follows:"
+ ewarn "1. Make the scripts in /usr/share/ccollect/scripts executable"
+ ewarn "2. Run all config-pre-\$VER-to-\$VER.sh in /usr/share/ccollect/scripts"
+ ewarn " ascending order, where \$VER is greater or equal than the version"
+ ewarn " you upgraded from."
+ ewarn "Example:"
+ ewarn " You upgraded from 0.5, thus you have to run:"
+ ewarn " /usr/share/ccollect/tools/config-pre-0.6-to-0.6.sh"
+ ewarn " /usr/share/ccollect/tools/config-pre-0.7-to-0.7.sh"
+ elog "Please note that many tools are now installed directly to /usr/bin"
+ elog "as recommended by upstream."
+}
diff --git a/app-backup/ccollect/ccollect-0.8.ebuild b/app-backup/ccollect/ccollect-0.8.ebuild
new file mode 100644
index 000000000000..3909db756728
--- /dev/null
+++ b/app-backup/ccollect/ccollect-0.8.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+DESCRIPTION="(pseudo) incremental backup with different exclude lists using hardlinks and rsync"
+HOMEPAGE="http://www.nico.schottelius.org/software/ccollect/"
+SRC_URI="http://www.nico.schottelius.org/software/${PN}/download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ~sparc x86"
+IUSE="doc examples"
+
+DEPEND="doc? ( >=app-text/asciidoc-8.1.0
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt )"
+RDEPEND="net-misc/rsync"
+
+# tests need ssh-access
+RESTRICT="test"
+
+src_compile() {
+ if use doc; then
+ emake XSL=/usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl documentation || die "building docs failed"
+ fi
+}
+
+src_install() {
+ dobin ccollect.sh
+ dosym ccollect.sh /usr/bin/ccollect
+
+ local tools="add_source analyse_logs archive_config check_config delete_source list_intervals logwrapper stats"
+ for t in ${tools} ; do
+ newbin tools/ccollect_${t}.sh ccollect_${t}
+ done
+
+ insinto /usr/share/${PN}/tools
+ doins tools/config-pre* tools/{gnu-du-backup-size-compare,report_success}.sh
+
+ dodoc CREDITS README
+ pushd doc/changes
+ for n in * ; do
+ newdoc ${n} NEWS-${n}
+ done
+ popd
+
+ if use doc; then
+ dohtml doc/*.htm doc/*.html
+ dohtml -r doc/man
+ doman doc/man/*.1
+ fi
+
+ if use examples ; then
+ # dodoc is not recursive. So do a workaround.
+ insinto /usr/share/doc/${PF}/examples/
+ doins -r conf/*
+ fi
+}
+
+pkg_postinst() {
+ ewarn "If you're upgrading from 0.6.x or less, you'll have to"
+ ewarn "upgrade your existing configuration as follows:"
+ ewarn "1. Make the scripts in /usr/share/ccollect/scripts executable"
+ ewarn "2. Run all config-pre-\$VER-to-\$VER.sh in /usr/share/ccollect/scripts"
+ ewarn " ascending order, where \$VER is greater or equal than the version"
+ ewarn " you upgraded from."
+ ewarn "Example:"
+ ewarn " You upgraded from 0.5, thus you have to run:"
+ ewarn " /usr/share/ccollect/tools/config-pre-0.6-to-0.6.sh"
+ ewarn " /usr/share/ccollect/tools/config-pre-0.7-to-0.7.sh"
+ elog "Please note that many tools are now installed directly to /usr/bin"
+ elog "as recommended by upstream."
+}
diff --git a/app-backup/ccollect/metadata.xml b/app-backup/ccollect/metadata.xml
new file mode 100644
index 000000000000..12de470c180a
--- /dev/null
+++ b/app-backup/ccollect/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>