summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-02-22 13:22:20 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-02-22 13:22:20 +0100
commit2f36d2e213c588ffd0b238697cfeb2e657cdd9cd (patch)
tree7eabeef035bd0fa8cdc336bc4949a259c7366805 /app-arch
parentdev-lang/mujs: Cleanup old versions (bug 595538). (diff)
downloadgentoo-2f36d2e213c588ffd0b238697cfeb2e657cdd9cd.tar.gz
gentoo-2f36d2e213c588ffd0b238697cfeb2e657cdd9cd.tar.bz2
gentoo-2f36d2e213c588ffd0b238697cfeb2e657cdd9cd.zip
app-arch/lz5: Initial version
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/lz5/Manifest1
-rw-r--r--app-arch/lz5/lz5-2.0.ebuild34
-rw-r--r--app-arch/lz5/metadata.xml13
3 files changed, 48 insertions, 0 deletions
diff --git a/app-arch/lz5/Manifest b/app-arch/lz5/Manifest
new file mode 100644
index 000000000000..375ffb0e25ac
--- /dev/null
+++ b/app-arch/lz5/Manifest
@@ -0,0 +1 @@
+DIST lz5-2.0.tar.gz 207478 SHA256 9d26494da492a9fd79b3baf93512a543f450b169bae01067354bd0179a5e3ede SHA512 be304d4fe95ff237420cdc054ce7751c5b51e9b438f6cfcb3189e138909331175201cf77615d289d4ea016d66118592794b961ea07c318f477a27263eff2b82e WHIRLPOOL edc1aac3b63fd654783ea8d50f836e0c5faf331a136bdf257a279582db7a144058a99f5434c5cb6bc6b80a75808c1efe246277e5ff12a085a88618bcc225e6e1
diff --git a/app-arch/lz5/lz5-2.0.ebuild b/app-arch/lz5/lz5-2.0.ebuild
new file mode 100644
index 000000000000..f79e5980eb17
--- /dev/null
+++ b/app-arch/lz5/lz5-2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="An efficient compressor with very fast decompression"
+HOMEPAGE="https://github.com/inikep/lz5"
+SRC_URI="https://github.com/inikep/lz5/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 BSD-2"
+SLOT="0/2"
+KEYWORDS="~amd64"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ sed -i -e 's/install: lz5$(EXT)/install:/' programs/Makefile || die
+ sed -i -e 's/install: lib liblz5.pc/install:/' lib/Makefile || die
+}
+
+src_compile() {
+ emake -Clib CC="$(tc-getCC)" lib liblz5.pc
+ emake -Cprograms CC="$(tc-getCC)" lz5
+}
+
+src_install(){
+ emake install DESTDIR="${D}" PREFIX="/usr" LIBDIR="/usr/$(get_libdir)"
+ if ! use static-libs; then
+ rm "${D}"/usr/$(get_libdir)/liblz5.a || die
+ fi
+}
diff --git a/app-arch/lz5/metadata.xml b/app-arch/lz5/metadata.xml
new file mode 100644
index 000000000000..99a05a65e745
--- /dev/null
+++ b/app-arch/lz5/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ </longdescription>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cesanta/docker_auth</remote-id>
+ </upstream>
+</pkgmetadata>