summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/star
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/star')
-rw-r--r--app-arch/star/Manifest2
-rw-r--r--app-arch/star/files/star-1.5.1-bufferoverflow.patch21
-rw-r--r--app-arch/star/files/star-1.5.1-changewarnSegv.patch80
-rw-r--r--app-arch/star/files/star-1.5.1-multivolsigsegv.patch12
-rw-r--r--app-arch/star/files/star-1.5.1-stdioconflict.patch92
-rw-r--r--app-arch/star/metadata.xml8
-rw-r--r--app-arch/star/star-1.5.2.ebuild102
-rw-r--r--app-arch/star/star-1.5.3.ebuild100
8 files changed, 417 insertions, 0 deletions
diff --git a/app-arch/star/Manifest b/app-arch/star/Manifest
new file mode 100644
index 000000000000..4221d04c68a7
--- /dev/null
+++ b/app-arch/star/Manifest
@@ -0,0 +1,2 @@
+DIST star-1.5.2.tar.bz2 874558 SHA256 762645b98af13bb9b0512812814ec8e90635d1400c94eb5911e9774daed2addf SHA512 6ea9bd3db79a83c5fae5cb791ea6fc2d79cb464d97702ca0167fdd068df77f047a53037f5be342f138dd950c2c863ee07de0bf3390e37d39a1105634ca8fc9d5 WHIRLPOOL 957a499bdbc7cca5704635c89bd7703fb0018ee22ab99a7cacab4b5241131001f6b9a65b69c227dc513c210d772b4a3a560a1a5d602e6b9dde4778ab1a329876
+DIST star-1.5.3.tar.bz2 889881 SHA256 070342833ea83104169bf956aa880bcd088e7af7f5b1f8e3d29853b49b1a4f5b SHA512 622032a0e87f3df06ab1091af0af99d0362f478f70351cfe3d47195eec0fcc96f458fb6e50cae3531183984b1d390b598176ce008bcc5f29764795f66436efef WHIRLPOOL fd786e38666392813311d04350680bb9e1f4cf892412697652f8531eec95b9954c8e0ec3d1538dc1a7cc469e28dbbc38a0a21f8e210fdf929a65de3b73ab55d6
diff --git a/app-arch/star/files/star-1.5.1-bufferoverflow.patch b/app-arch/star/files/star-1.5.1-bufferoverflow.patch
new file mode 100644
index 000000000000..afc0b4aa2b58
--- /dev/null
+++ b/app-arch/star/files/star-1.5.1-bufferoverflow.patch
@@ -0,0 +1,21 @@
+diff -urNp star-1.5.1-orig/star/longnames.c star-1.5.1/star/longnames.c
+--- star-1.5.1-orig/star/longnames.c 2009-10-16 00:38:55.000000000 +0200
++++ star-1.5.1/star/longnames.c 2010-02-03 13:36:03.000000000 +0100
+@@ -155,7 +155,7 @@ name_to_tcb(info, ptb)
+ if (add)
+ strcatl(ptb->dbuf.t_name, name, "/", (char *)NULL);
+ else
+- strcpy(ptb->dbuf.t_name, name);
++ strncpy(ptb->dbuf.t_name, name, props.pr_maxsname);
+ return (TRUE);
+ }
+
+@@ -198,7 +198,7 @@ name_to_tcb(info, ptb)
+ if (add)
+ strcatl(ptb->dbuf.t_name, &np[1], "/", (char *)NULL);
+ else
+- strcpy(ptb->dbuf.t_name, &np[1]);
++ strncpy(ptb->dbuf.t_name, &np[1], props.pr_maxsname);
+ strncpy(ptb->dbuf.t_prefix, name, np - name);
+ info->f_flags |= F_SPLIT_NAME;
+ return (TRUE);
diff --git a/app-arch/star/files/star-1.5.1-changewarnSegv.patch b/app-arch/star/files/star-1.5.1-changewarnSegv.patch
new file mode 100644
index 000000000000..74d4870d5555
--- /dev/null
+++ b/app-arch/star/files/star-1.5.1-changewarnSegv.patch
@@ -0,0 +1,80 @@
+--- star-1.5/star/checkerr.c.orig-segv 2006-10-31 18:06:25.000000000 +0100
++++ star-1.5/star/checkerr.c 2007-08-27 11:42:39.000000000 +0200
+@@ -183,39 +183,45 @@ LOCAL struct eflags {
+ */
+ LOCAL UInt32_t
+ errflags(eflag, doexit)
+- char *eflag;
+- BOOL doexit;
++ char *eflag;
++ BOOL doexit;
+ {
+- register char *p = eflag;
+- char *ef = _endword(eflag);
+- register struct eflags *ep;
+- register int slen;
+- register UInt32_t nflags = 0;
+-
+- do {
+- for (ep = eflags; ep->fname; ep++) {
+- slen = strlen(ep->fname);
+- if ((strncmp(ep->fname, p, slen) == 0) &&
+- (p[slen] == '|' || p[slen] == ' ' ||
+- p[slen] == '\0')) {
+- nflags |= ep->fval;
+- break;
+- }
+- }
+- if (ep->fname == NULL) {
+- if (doexit)
+- comerrno(EX_BAD, "Bad flag '%s'\n", p);
+- return (0);
+- }
+- p = strchr(p, '|');
+- } while (p < ef && p && *p++ == '|');
+-
+- if ((nflags & ~(UInt32_t)(E_ABORT|E_WARN)) == 0) {
+- if (doexit)
+- comerrno(EX_BAD, "Bad error condition '%s'.\n", eflag);
+- return (0);
+- }
+- return (nflags);
++ register struct eflags *ep;
++ register int slen;
++ register UInt32_t nflags = 0;
++ char *curflags;
++ char *curflag;
++
++ curflags = strdup (eflag);
++ *_endword(curflags) = '\0';
++ curflag = strtok (curflags, "|");
++
++ while (curflag != NULL) {
++ for (ep = eflags; ep->fname; ep++) {
++ slen = strlen (ep->fname);
++ if ((strncmp (ep->fname, curflag, slen)) == 0) {
++ nflags |= ep->fval;
++ goto next;
++ }
++ }
++
++ if (doexit)
++ comerrno (EX_BAD, "Bad flag '%s' \n", curflag);
++
++ free (curflags);
++ return (0);
++ next:
++ curflag = strtok (NULL, "|");
++ }
++
++ free (curflags);
++
++ if ((nflags & ~(UInt32_t)(E_ABORT|E_WARN)) == 0) {
++ if (doexit)
++ comerrno(EX_BAD, "Bad error condition '%s'.\n", eflag);
++ return (0);
++ }
++ return (nflags);
+ }
+
+ LOCAL ec_t *
diff --git a/app-arch/star/files/star-1.5.1-multivolsigsegv.patch b/app-arch/star/files/star-1.5.1-multivolsigsegv.patch
new file mode 100644
index 000000000000..204a29d89e91
--- /dev/null
+++ b/app-arch/star/files/star-1.5.1-multivolsigsegv.patch
@@ -0,0 +1,12 @@
+diff -urNp star-1.5.1-orig/star/buffer.c star-1.5.1/star/buffer.c
+--- star-1.5.1-orig/star/buffer.c 2009-07-13 21:05:02.000000000 +0200
++++ star-1.5.1/star/buffer.c 2011-01-04 13:50:25.452138625 +0100
+@@ -799,7 +799,7 @@ initbuf(nblocks)
+
+ bigptr = bigbuf = ___malloc((size_t) bufsize+10+pagesize,
+ "buffer");
+- bigptr = bigbuf = (char *)roundup((Intptr_t)bigptr, pagesize);
++ bigptr = bigbuf = (char *)roundup((UIntptr_t)bigptr, pagesize);
+ fillbytes(bigbuf, bufsize, '\0');
+ fillbytes(&bigbuf[bufsize], 10, 'U');
+
diff --git a/app-arch/star/files/star-1.5.1-stdioconflict.patch b/app-arch/star/files/star-1.5.1-stdioconflict.patch
new file mode 100644
index 000000000000..e0be2d4eb4c0
--- /dev/null
+++ b/app-arch/star/files/star-1.5.1-stdioconflict.patch
@@ -0,0 +1,92 @@
+diff -urNp star-1.5.1-orig/include/schily/schily.h star-1.5.1/include/schily/schily.h
+--- star-1.5.1-orig/include/schily/schily.h 2009-10-22 23:18:55.000000000 +0200
++++ star-1.5.1/include/schily/schily.h 2010-01-13 13:17:10.000000000 +0100
+@@ -174,7 +174,7 @@ extern int fexecle __PR((const char *, F
+ /* 6th arg not const, fexecv forces av[ac] = NULL */
+ extern int fexecv __PR((const char *, FILE *, FILE *, FILE *, int,
+ char **));
+-extern int fexecve __PR((const char *, FILE *, FILE *, FILE *,
++extern int sch_fexecve __PR((const char *, FILE *, FILE *, FILE *,
+ char * const *, char * const *));
+ extern int fspawnv __PR((FILE *, FILE *, FILE *, int, char * const *));
+ extern int fspawnl __PR((FILE *, FILE *, FILE *, const char *, ...));
+@@ -311,7 +311,7 @@ extern char *findbytes __PR((const void
+ extern char *findinpath __PR((char *__name, int __mode, BOOL __plain_file));
+ extern int findline __PR((const char *, char, const char *,
+ int, char **, int));
+-extern int getline __PR((char *, int));
++extern int sch_getline __PR((char *, int));
+ extern int getstr __PR((char *, int));
+ extern int breakline __PR((char *, char, char **, int));
+ extern int getallargs __PR((int *, char * const**, const char *, ...));
+diff -urNp star-1.5.1-orig/lib/fexec.c star-1.5.1/lib/fexec.c
+--- star-1.5.1-orig/lib/fexec.c 2009-11-15 15:14:28.000000000 +0100
++++ star-1.5.1/lib/fexec.c 2010-01-13 13:17:10.000000000 +0100
+@@ -198,7 +198,7 @@ const char **pav;
+ } while (p != NULL);
+ va_end(args);
+
+- ret = fexecve(name, in, out, err, av, env);
++ ret = sch_fexecve(name, in, out, err, av, env);
+ if (av != xav)
+ free(av);
+ return (ret);
+@@ -212,11 +212,11 @@ fexecv(name, in, out, err, ac, av)
+ char *av[];
+ {
+ av[ac] = NULL; /* force list to be null terminated */
+- return (fexecve(name, in, out, err, av, environ));
++ return (sch_fexecve(name, in, out, err, av, environ));
+ }
+
+ EXPORT int
+-fexecve(name, in, out, err, av, env)
++sch_fexecve(name, in, out, err, av, env)
+ const char *name;
+ FILE *in, *out, *err;
+ char * const av[], * const env[];
+diff -urNp star-1.5.1-orig/lib/libschily-mapvers star-1.5.1/lib/libschily-mapvers
+--- star-1.5.1-orig/lib/libschily-mapvers 2007-10-06 15:21:55.000000000 +0200
++++ star-1.5.1/lib/libschily-mapvers 2010-01-13 13:17:10.000000000 +0100
+@@ -77,7 +77,7 @@ global:
+ fexecl;
+ fexecle;
+ fexecv;
+- fexecve;
++ sch_fexecve;
+ ffileread;
+ ffilewrite;
+ fgetline;
+@@ -123,7 +123,7 @@ global:
+ geterrno;
+ getfiles;
+ getfp;
+- getline;
++ sch_getline;
+ getmainfp;
+ #getstr;
+ #handlecond;
+diff -urNp star-1.5.1-orig/lib/stdio/fgetline.c star-1.5.1/lib/stdio/fgetline.c
+--- star-1.5.1-orig/lib/stdio/fgetline.c 2004-09-25 14:23:36.000000000 +0200
++++ star-1.5.1/lib/stdio/fgetline.c 2010-01-13 13:17:10.000000000 +0100
+@@ -61,7 +61,7 @@ fgetline(f, buf, len)
+ }
+
+ EXPORT int
+-getline(buf, len)
++sch_getline(buf, len)
+ char *buf;
+ int len;
+ {
+diff -urNp star-1.5.1-orig/libfind/find.c star-1.5.1/libfind/find.c
+--- star-1.5.1-orig/libfind/find.c 2009-11-15 16:25:02.000000000 +0100
++++ star-1.5.1/libfind/find.c 2010-01-13 13:17:10.000000000 +0100
+@@ -1747,7 +1747,7 @@ doexec(f, ac, av, state)
+ #endif
+ av[ac] = NULL; /* -exec {} \; is not NULL terminated */
+
+- fexecve(av[0], state->std[0], state->std[1], state->std[2],
++ sch_fexecve(av[0], state->std[0], state->std[1], state->std[2],
+ av, state->env);
+ err = geterrno();
+ #ifdef PLUS_DEBUG
diff --git a/app-arch/star/metadata.xml b/app-arch/star/metadata.xml
new file mode 100644
index 000000000000..486d2934ff92
--- /dev/null
+++ b/app-arch/star/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <upstream>
+ <remote-id type="sourceforge">s-tar</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/star/star-1.5.2.ebuild b/app-arch/star/star-1.5.2.ebuild
new file mode 100644
index 000000000000..b65b048d06a0
--- /dev/null
+++ b/app-arch/star/star-1.5.2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An enhanced (world's fastest) tar, as well as enhanced mt/rmt"
+HOMEPAGE="http://s-tar.sourceforge.net/"
+SRC_URI="mirror://sourceforge/s-tar/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1 CDDL-Schily"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="acl xattr"
+
+DEPEND="
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/_alpha[0-9][0-9]}
+
+src_prepare() {
+ find -type f -exec chmod -c u+w '{}' + || die
+ sed \
+ -e "s:/opt/schily:${EPREFIX}/usr:g" \
+ -e 's:bin:root:g' \
+ -e "s:/usr/src/linux/include:${EPREFIX}/usr/include:" \
+ -i DEFAULTS/Defaults.linux || die
+
+ # Disable libacl autodependency (hacky build system, hacky fix...)
+ if use acl; then
+ sed \
+ -e 's:[$]ac_cv_header_sys_acl_h:disable acl:' \
+ -i "${S}/autoconf/configure" || die
+ fi
+
+ if use xattr; then
+ sed \
+ -e 's:[$]ac_cv_header_attr_xattr_h:disable xattr:' \
+ -i "${S}/autoconf/configure" || die
+ fi
+
+ # Create additional symlinks needed for some archs.
+ pushd "${S}/RULES" > /dev/null
+ local t
+ for t in ppc64 s390x ; do
+ ln -s i586-linux-cc.rul ${t}-linux-cc.rul || die
+ ln -s i586-linux-gcc.rul ${t}-linux-gcc.rul || die
+ done
+ popd > /dev/null
+
+ epatch "${FILESDIR}"/${PN}-1.5.1-changewarnSegv.patch
+}
+
+src_configure() { :; } #avoid ./configure run
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ COPTX="${CFLAGS}" \
+ CPPOPTX="${CPPFLAGS}" \
+ COPTGPROF= \
+ COPTOPT= \
+ LDOPTX="${LDFLAGS}"
+}
+
+src_install() {
+ # Joerg Schilling suggested to integrate star into the main OS using call:
+ # make INS_BASE=/usr DESTDIR="${D}" install
+
+ dobin \
+ star/OBJ/*-*-cc/star \
+ tartest/OBJ/*-*-cc/tartest \
+ star_sym/OBJ/*-*-cc/star_sym \
+ mt/OBJ/*-*-cc/smt
+
+ newsbin rmt/OBJ/*-*-cc/rmt rmt.star
+ newman rmt/rmt.1 rmt.star.1
+
+ # Note that we should never install gnutar, tar or rmt in this package.
+ # tar and rmt are provided by app-arch/tar. gnutar is not compatible with
+ # GNU tar and breakes compilation, or init scripts. bug #33119
+ dosym {star,/usr/bin/ustar}
+ dosym {star,/usr/bin/spax}
+ dosym {star,/usr/bin/scpio}
+ dosym {star,/usr/bin/suntar}
+
+ # match is needed to understand the pattern matcher, if you wondered why ;)
+ doman man/man1/match.1 tartest/tartest.1 \
+ star/{star.4,star.1,spax.1,scpio.1,suntar.1}
+
+ insinto /etc/default
+ newins star/star.dfl star
+ newins rmt/rmt.dfl rmt
+
+ dodoc star/{README.ACL,README.crash,README.largefiles,README.otherbugs} \
+ star/{README.pattern,README.pax,README.posix-2001,README,STARvsGNUTAR} \
+ rmt/default-rmt.sample TODO AN-* Changelog CONTRIBUTING
+}
diff --git a/app-arch/star/star-1.5.3.ebuild b/app-arch/star/star-1.5.3.ebuild
new file mode 100644
index 000000000000..4cb914bca633
--- /dev/null
+++ b/app-arch/star/star-1.5.3.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An enhanced (world's fastest) tar, as well as enhanced mt/rmt"
+HOMEPAGE="http://s-tar.sourceforge.net/"
+SRC_URI="mirror://sourceforge/s-tar/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1 CDDL-Schily"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~ia64 ~mips ~ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="acl xattr"
+
+DEPEND="
+ acl? ( sys-apps/acl )
+ xattr? ( sys-apps/attr )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/_alpha[0-9][0-9]}
+
+src_prepare() {
+ find -type f -exec chmod -c u+w '{}' + || die
+ sed \
+ -e "s:/opt/schily:${EPREFIX}/usr:g" \
+ -e 's:bin:root:g' \
+ -e "s:/usr/src/linux/include:${EPREFIX}/usr/include:" \
+ -i DEFAULTS/Defaults.linux || die
+
+ # Disable libacl autodependency (hacky build system, hacky fix...)
+ if use acl; then
+ sed \
+ -e 's:[$]ac_cv_header_sys_acl_h:disable acl:' \
+ -i "${S}/autoconf/configure" || die
+ fi
+
+ if use xattr; then
+ sed \
+ -e 's:[$]ac_cv_header_attr_xattr_h:disable xattr:' \
+ -i "${S}/autoconf/configure" || die
+ fi
+
+ # Create additional symlinks needed for some archs.
+ pushd "${S}/RULES" > /dev/null
+ local t
+ for t in ppc64 s390x ; do
+ ln -s i586-linux-cc.rul ${t}-linux-cc.rul || die
+ ln -s i586-linux-gcc.rul ${t}-linux-gcc.rul || die
+ done
+ popd > /dev/null
+}
+
+src_configure() { :; } #avoid ./configure run
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ COPTX="${CFLAGS}" \
+ CPPOPTX="${CPPFLAGS}" \
+ COPTGPROF= \
+ COPTOPT= \
+ LDOPTX="${LDFLAGS}"
+}
+
+src_install() {
+ # Joerg Schilling suggested to integrate star into the main OS using call:
+ # make INS_BASE=/usr DESTDIR="${D}" install
+
+ dobin \
+ star/OBJ/*-*-cc/star \
+ tartest/OBJ/*-*-cc/tartest \
+ star_sym/OBJ/*-*-cc/star_sym \
+ mt/OBJ/*-*-cc/smt
+
+ newsbin rmt/OBJ/*-*-cc/rmt rmt.star
+ newman rmt/rmt.1 rmt.star.1
+
+ # Note that we should never install gnutar, tar or rmt in this package.
+ # tar and rmt are provided by app-arch/tar. gnutar is not compatible with
+ # GNU tar and breakes compilation, or init scripts. bug #33119
+ dosym {star,/usr/bin/ustar}
+ dosym {star,/usr/bin/spax}
+ dosym {star,/usr/bin/scpio}
+ dosym {star,/usr/bin/suntar}
+
+ # match is needed to understand the pattern matcher, if you wondered why ;)
+ doman man/man1/match.1 tartest/tartest.1 \
+ star/{star.4,star.1,spax.1,scpio.1,suntar.1}
+
+ insinto /etc/default
+ newins star/star.dfl star
+ newins rmt/rmt.dfl rmt
+
+ dodoc star/{README.ACL,README.crash,README.largefiles,README.otherbugs} \
+ star/{README.pattern,README.pax,README.posix-2001,README,STARvsGNUTAR} \
+ rmt/default-rmt.sample TODO AN-* Changelog CONTRIBUTING
+}