summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-04-28 17:37:22 -0400
committerCraig Andrews <candrews@gentoo.org>2021-04-28 17:37:42 -0400
commit6819e0f6f299cde6cc6bcf2cc1d84101abe80c67 (patch)
treeeb500a81ed888d35d39c91dcde3400d0c1bc6e04 /app-arch/brotli/brotli-9999.ebuild
parentmedia-plugins/kodi-inputstream-ffmpegdirect: added new ebuild (diff)
downloadgentoo-6819e0f6f299cde6cc6bcf2cc1d84101abe80c67.tar.gz
gentoo-6819e0f6f299cde6cc6bcf2cc1d84101abe80c67.tar.bz2
gentoo-6819e0f6f299cde6cc6bcf2cc1d84101abe80c67.zip
app-arch/brotli: add USE="static-libs"
Closes: https://bugs.gentoo.org/786558 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'app-arch/brotli/brotli-9999.ebuild')
-rw-r--r--app-arch/brotli/brotli-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-arch/brotli/brotli-9999.ebuild b/app-arch/brotli/brotli-9999.ebuild
index d84bfa85b3e9..87affbe108c9 100644
--- a/app-arch/brotli/brotli-9999.ebuild
+++ b/app-arch/brotli/brotli-9999.ebuild
@@ -17,7 +17,7 @@ SLOT="0/$(ver_cut 1)"
RDEPEND="python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}"
-IUSE="python test"
+IUSE="python static-libs test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
LICENSE="MIT python? ( Apache-2.0 )"
@@ -29,7 +29,7 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/google/${PN}.git"
inherit git-r3
else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
@@ -73,6 +73,7 @@ src_test() {
multilib_src_install() {
cmake-utils_src_install
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a || die
}
multilib_src_install_all() {
use python && distutils-r1_src_install