summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-11 08:35:00 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-11 09:35:39 +0100
commitab4d80d81c60d69bc8b9612cc64b5759ee57728d (patch)
tree92dc80cc83e14bc8d86c046d593bb6e323e83569 /app-admin
parentdev-python/boto3: Bump to 1.28.84 (diff)
downloadgentoo-ab4d80d81c60d69bc8b9612cc64b5759ee57728d.tar.gz
gentoo-ab4d80d81c60d69bc8b9612cc64b5759ee57728d.tar.bz2
gentoo-ab4d80d81c60d69bc8b9612cc64b5759ee57728d.zip
app-admin/awscli: Bump to 1.29.84
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.29.84.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index c04d5b79f43c..5386a83d2726 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -6,3 +6,4 @@ DIST aws-cli-1.29.79.gh.tar.gz 2574359 BLAKE2B fab1016d0b909c593d5fab7facf23e2cc
DIST aws-cli-1.29.80.gh.tar.gz 2574794 BLAKE2B 0f12c5463d54b11c5222f9ae1fa0d1327402cf4ba8241df720d6e34f4b6d7686627ab105e9d2642d9de115c47e0da6cbebe989d632607bb53528f27360d34d05 SHA512 e9d3676cb6d2e98f077f55faae9db2e67931849ca424828ef0ce36b9cfe9e0c0783100170e3104c0b9ff9336a49c4e1c45f1029059b2e7399a03de4a5630f3bb
DIST aws-cli-1.29.82.gh.tar.gz 2575194 BLAKE2B 31961c3c6bd577871444396e36e50db5176666eefc77166f3b4cfab87386b6707f9c10553bb9fe328ce821b30268b34d3d2e5b4cbf00252390cca46c5e3029ec SHA512 e28945774e62d8df3204495c3a69ff68106d04fab2fe47bf10d0446ddbb310fa3baf079c9ab822ed49dae437429c31062976054336436a51ed3c9579d83480cf
DIST aws-cli-1.29.83.gh.tar.gz 2575803 BLAKE2B 6f3de0dadca3fe412f792f3974429bf84e05e11cdc598b71b16381dee91401d110701a88c70d47c4333a3e07d8d2c88522000da2277743f3453edfc3cf70be04 SHA512 83a3ae460919a6b50dc7b477a1bda69cf8739975bf4772d0db80c9be3ca8a96605cc0a04290a14651adb3adf00e5befb7ad98827b98c82133bf55a5a90217c74
+DIST aws-cli-1.29.84.gh.tar.gz 2576584 BLAKE2B c442a433b0deaacb8b0a94ecb4ce296b60eb6f364bf5626d4ccf606d35b8ad22a2859c29486c9eaa8091edc9f796d271b5b7308638d10f72f128b4548f5250bf SHA512 6f46bde5016df5d227861ed80e847a893144f290dba11c57966f6ccf043690fad42dcc11d18e1b2d27225c8b070063a2c20b8a622628bde37887e44d0e0e7fb5
diff --git a/app-admin/awscli/awscli-1.29.84.ebuild b/app-admin/awscli/awscli-1.29.84.ebuild
new file mode 100644
index 000000000000..e5b1ee0667a3
--- /dev/null
+++ b/app-admin/awscli/awscli-1.29.84.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.7.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}