summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2023-04-16 13:27:56 -0700
committerJohn Helmert III <ajak@gentoo.org>2023-04-16 13:33:56 -0700
commit8ddc3d75d73afec8878252430c047a1be3b9bd75 (patch)
tree13a8f89b5c19801221f609c36d9b77efd0e3d790 /app-admin/gopass-hibp
parentapp-admin/gopass: add 1.15.5 (diff)
downloadgentoo-8ddc3d75d73afec8878252430c047a1be3b9bd75.tar.gz
gentoo-8ddc3d75d73afec8878252430c047a1be3b9bd75.tar.bz2
gentoo-8ddc3d75d73afec8878252430c047a1be3b9bd75.zip
app-admin/gopass-hibp: add 1.15.5
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'app-admin/gopass-hibp')
-rw-r--r--app-admin/gopass-hibp/Manifest2
-rw-r--r--app-admin/gopass-hibp/gopass-hibp-1.15.5.ebuild21
2 files changed, 23 insertions, 0 deletions
diff --git a/app-admin/gopass-hibp/Manifest b/app-admin/gopass-hibp/Manifest
index ddb056fcd474..7ced23e60496 100644
--- a/app-admin/gopass-hibp/Manifest
+++ b/app-admin/gopass-hibp/Manifest
@@ -2,3 +2,5 @@ DIST gopass-hibp-1.15.3-deps.tar.xz 37693396 BLAKE2B 24bb949660e9e38fe03ab2c6d1a
DIST gopass-hibp-1.15.3.tar.gz 24961 BLAKE2B 477a5bdd285e1ff53a24e1f9f7e860b3226bc936a1283d058ba7b614a9578bdaa36fae9367584b182057c0dc114f10dafebea11149f1d3841ff7d263a7a7edd2 SHA512 da0e894a3429c40a3c5351f09edd21a9eb0552fde7cabee9f33f0b37346ef61af24d66aed0e81cc99d8f1ada716a5bf0182c2e604c1bf2b8d38de077c359ad18
DIST gopass-hibp-1.15.4-deps.tar.xz 33365976 BLAKE2B 15c125423cc52b89a93d650c30a94b95452d923884ef3637c5e04aef9885e89dfce4e1f2205ab18a362eea6624439accdb15420bc8fa950d4755cc741638deb6 SHA512 7f1312372ea9f134e81069de62d97d475c402e899248534923a9e5b3557360004dd92a01ca4bb0f1e3289c599bc027999742a9d24aa6922d8b2653f0e18a1f40
DIST gopass-hibp-1.15.4.tar.gz 24968 BLAKE2B 04c20ac2e29fd4268a01aca998ac32884c41b8e9a5f40772427a54a737ada5bcd6da0224a5e5939db082ddb5cc216deb24c9eea6db9320f8c89618bbff5fcfbe SHA512 64cd2beed3c1089b0be474722caba9511abdfac875c1a47ee29d2ec26591edf613801d0d3687a58d1cb67d9235093922fe5372effc96a373f49b09e7ffec54b1
+DIST gopass-hibp-1.15.5-deps.tar.xz 182857584 BLAKE2B 0e0c536b02ac2c22daa299513815351e0890361dd2f3fb7cf2bf33c7c980371321b3e009599242190f51acf14f83be1c32948999e29aa54ad4e6b17a8c9087d0 SHA512 9b81e1a30a111f58b81e2e88a13e955ab406c31922287990968ef21e575d611d7754e0d7e0ee82191fbe6d2f72f3d30cf34b632c5ba548c1d165e218e2803698
+DIST gopass-hibp-1.15.5.tar.gz 27096 BLAKE2B df6a87ba6279d3dc0f1403861e5829d2fd5f5ec1b2aadf4c1cb27d6380d50df482af115ec78ae807e20660c5cd1fbd4336849271959647259a5626896b85f923 SHA512 d32ad613a25b52e9fbdc655ac15ebac8456882be9dcc462f186a888e4f82070cfe295f0e359faa4cf01b3c562d01328ce1dcb835df85707957c79a84c52d9fcf
diff --git a/app-admin/gopass-hibp/gopass-hibp-1.15.5.ebuild b/app-admin/gopass-hibp/gopass-hibp-1.15.5.ebuild
new file mode 100644
index 000000000000..f3c5b3ef350d
--- /dev/null
+++ b/app-admin/gopass-hibp/gopass-hibp-1.15.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Gopass haveibeenpwnd.com integration"
+HOMEPAGE="https://github.com/gopasspw/gopass-hibp"
+SRC_URI="https://github.com/gopasspw/gopass-hibp/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~ajak/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD MPL-2.0 BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND=">=dev-lang/go-1.16"
+RDEPEND="
+ dev-vcs/git
+ >=app-crypt/gnupg-2
+"