summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-06-21 22:24:25 +0200
committerSam James <sam@gentoo.org>2022-06-25 00:07:19 +0100
commitfcbf3607d5b25509c991944e2348b5ae7c48e2d3 (patch)
tree60ae4d1e0dd38575867f9eff6e83f4b59c366e96 /app-admin/entr
parentdev-python/shiboken2: fix build w/ numpy 1.23 (diff)
downloadgentoo-fcbf3607d5b25509c991944e2348b5ae7c48e2d3.tar.gz
gentoo-fcbf3607d5b25509c991944e2348b5ae7c48e2d3.tar.bz2
gentoo-fcbf3607d5b25509c991944e2348b5ae7c48e2d3.zip
app-admin/entr: add 5.2
Closes: https://bugs.gentoo.org/854105 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/26025 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin/entr')
-rw-r--r--app-admin/entr/Manifest1
-rw-r--r--app-admin/entr/entr-5.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-admin/entr/Manifest b/app-admin/entr/Manifest
index 5a4f819d7fde..e4eb818785f5 100644
--- a/app-admin/entr/Manifest
+++ b/app-admin/entr/Manifest
@@ -1,2 +1,3 @@
DIST entr-5.0.tar.gz 25480 BLAKE2B 5de00d6b1042667e209b2c33d7d019bad4833a0711a18d47eddb129ef60f5518c42fc2af3169510f57eb39f861d416ab67d7cd83e4a631cfcaa4cc7ac266f82d SHA512 f485efb7d05f1d099c85d8af2f313e3ed2f36720483afc3004479b5b8754c60c52a108b827efd017c674f01d6ced2878a317addef3960c8cdf9e6b142f2ad5fd
DIST entr-5.1.tar.gz 25674 BLAKE2B e456c415198f4d5be49fd52785cd8cce41756d2ebe14c493891c3fa05f3a763c9e3be65538d3150b484e48e0d23615556dd6c45fdbefc7b2052fc36f265ca685 SHA512 b8ee7dae5bda503af814eb109a0180c9864fa1b1cf5a2fe53c9915b6536e9471f8293c63d138d881da7bf70dfee24a6c271b82ecb6ccb2cb6ea664cabedba202
+DIST entr-5.2.tar.gz 25834 BLAKE2B c14eddaaf26994679991c43b38dcea0f1cbf53ce517af462cfed9dea2c914d9c1719053cb3b9f28f04d0cbf8719fe5612963c1428832e02bd55545ba33c72556 SHA512 b12310b6695f0b3d3d830b651dd182ddf2321aad38f569066cc2e5b17570070e48eb4900725c88c1d31a8ff71099aba78fb7508ad60706265cbdf8f29257eaaa
diff --git a/app-admin/entr/entr-5.2.ebuild b/app-admin/entr/entr-5.2.ebuild
new file mode 100644
index 000000000000..b612d8978151
--- /dev/null
+++ b/app-admin/entr/entr-5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Run arbitrary commands when files change"
+HOMEPAGE="
+ https://eradman.com/entrproject/
+ https://github.com/eradman/entr
+"
+SRC_URI="https://eradman.com/entrproject/code/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+src_configure() {
+ sh configure || die
+ sed -i -e 's#\(^PREFIX \).*#\1\?= /usr#' Makefile.bsd || die
+}
+
+src_compile() {
+ export CC="$(tc-getCC)"
+ default
+}
+
+src_test() {
+ export CC="$(tc-getCC)"
+ default
+}