summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-05-25 22:17:31 -0300
committerMatt Turner <mattst88@gentoo.org>2023-05-25 21:42:52 -0400
commit08db1c5161cea5eee7546410cfcc0a4976d9c7c5 (patch)
tree4bfbbed6d369dcde4d7df339336b81b63ab6f796 /app-accessibility/orca
parentwww-client/epiphany: Version bump to 44.3 (diff)
downloadgentoo-08db1c5161cea5eee7546410cfcc0a4976d9c7c5.tar.gz
gentoo-08db1c5161cea5eee7546410cfcc0a4976d9c7c5.tar.bz2
gentoo-08db1c5161cea5eee7546410cfcc0a4976d9c7c5.zip
app-accessibility/orca: Version bump to 44.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31164 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-accessibility/orca')
-rw-r--r--app-accessibility/orca/Manifest1
-rw-r--r--app-accessibility/orca/orca-44.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index 721b791fd3e7..c317842b2381 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1 +1,2 @@
DIST orca-44.0.tar.xz 3764020 BLAKE2B 0ac7f837cf38cf15b63400d7ca7d631b4e3710680ea50c311ea60b81e57797e81411f6d2f82cde8434fab065e07a14a7e5d9192e73bf29bb79ac6fa9644d985f SHA512 7b1d4a8417283fc7586bd1a308529d8cc3bdc53f080b5bcd6f9dffc686b9eeeb6992df9d970996b44a3339492fb31bdc26c107cc5233521c655e46d4bea7efb2
+DIST orca-44.1.tar.xz 3760772 BLAKE2B 1e2825e9183b86563d85f106f80b7fa84d7d0cc06c818cb72c2a307c9c85a421cbbfc581df7829afde558ddf468bc048382d059ae995661a5163d390585961b4 SHA512 951a60b7efd9b61762404c20b62d476c1ebc3fc2662c0be1feef307fa1761feb5195c89ce725db1585dde4c39d96e1aa74c2b5c934115a3c2669880c3c7ac200
diff --git a/app-accessibility/orca/orca-44.1.ebuild b/app-accessibility/orca/orca-44.1.ebuild
new file mode 100644
index 000000000000..6b60291784d7
--- /dev/null
+++ b/app-accessibility/orca/orca-44.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-core-2.47:2[introspection]
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.36[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}