summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-10 08:22:53 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-10 08:58:05 +0100
commitedca7d9005d2124964c4ab86c97536f14cd7bfb9 (patch)
tree311b313ac0a2bf886aba42dff2870546057cb8fe
parentdev-python/boto3: Bump to 1.20.52 (diff)
downloadgentoo-edca7d9005d2124964c4ab86c97536f14cd7bfb9.tar.gz
gentoo-edca7d9005d2124964c4ab86c97536f14cd7bfb9.tar.bz2
gentoo-edca7d9005d2124964c4ab86c97536f14cd7bfb9.zip
app-admin/awscli: Bump to 1.22.52
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.52.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index fcc842da83a2..b03a78769c1a 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -6,3 +6,4 @@ DIST awscli-1.22.48.tar.gz 2161566 BLAKE2B f9ced24e30951ec517753fa0d1e8c321d9f5d
DIST awscli-1.22.49.tar.gz 2161874 BLAKE2B de97f0f9aeb075049e69c5bbd4bc67d59ba964f6508c92f8c2d1574f77dd4f2d602cd16b07270242c516e68d4119f8df95834935bfbcb16eccc3c1bc0a6cb08a SHA512 d55cf65bb8f70e4f98bd1eb0a79385d0959985b1b969e6f0269e7185c4af2cf3b40e0cd6d736431a489e21e4ec5b055ac0727dd1b2226b6d4dc6b19c4609ff11
DIST awscli-1.22.50.tar.gz 2162541 BLAKE2B cd7dda4d0d36897d299b39798d7ee5810a5b5d45759c548bf02ab66694954e470b00e141d6459dd8741c64dfc565e8227f468bd1f95c020963f0f8151460da18 SHA512 bd8e9b71eb370e409e3b06ff9c20db84f6329eef49b50fedf21225767ef7433f1d941c8f224e82a10159c319a87ab3b69a9255446ee3d0ce6f65c00531c1bb7d
DIST awscli-1.22.51.tar.gz 2163551 BLAKE2B cd7c0b312b96f1dc44f9826a6606deb6d7467b64a674efbb6d8293720c9daa9bdc3cea9d71f2da75fe308fd80bead172f2cfcdba045e6debe44d1e884c0aa64b SHA512 c4bfa7022181c93fd319b18d916ed1af281b4a6bbefb81e693e4479b3ed07200e4c8c8687b79bd0d411b194e049fcbbf8e59c977ce551076b98840f973621bf4
+DIST awscli-1.22.52.tar.gz 2163541 BLAKE2B a8aca6f818141bc8ba9ad8dbe9d0732d8635814530dab483c327d30c85098f9bc7f5ce90ccf930df76ebe724b441ce67af08aba45a4e8a4f5cb228464b4fd3e7 SHA512 8ed0504428dea9869d069ebc077e72c4e0d0099fdf4087acb8d81dc77c5c4d2ae3e04dc5772cd4e21ff80ad4dde1344b9abd180530a5049b6438c2ef1fe5154e
diff --git a/app-admin/awscli/awscli-1.22.52.ebuild b/app-admin/awscli/awscli-1.22.52.ebuild
new file mode 100644
index 000000000000..1f3430af8a9f
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.52.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}