summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-21 18:46:55 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-21 18:50:09 +0100
commitebfbc363ccddf4eda05fff9e24bb166db20a48ee (patch)
tree02fc25da0403b394a5efcb075e4e2efe59ddb028
parentdev-python/jupyter_console: Bump to 6.6.1 (diff)
downloadgentoo-ebfbc363ccddf4eda05fff9e24bb166db20a48ee.tar.gz
gentoo-ebfbc363ccddf4eda05fff9e24bb166db20a48ee.tar.bz2
gentoo-ebfbc363ccddf4eda05fff9e24bb166db20a48ee.zip
dev-python/ypy-websocket: Bump to 0.8.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ypy-websocket/Manifest1
-rw-r--r--dev-python/ypy-websocket/ypy-websocket-0.8.4.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/ypy-websocket/Manifest b/dev-python/ypy-websocket/Manifest
index 73d7212372e7..207742460059 100644
--- a/dev-python/ypy-websocket/Manifest
+++ b/dev-python/ypy-websocket/Manifest
@@ -1,2 +1,3 @@
DIST ypy-websocket-0.8.2.gh.tar.gz 13045 BLAKE2B 44cd1538247b68b54d161800f76f467f67d77d81726b4af01cbeeb045b77aeb7ec8fde7c126c5d54a0792be11bc97d41a624c99a80c2ea8178a358d045e59389 SHA512 6774d646a04afe4dcf72b6ec44bad5092ff40d8647c6650697340ebf6f2a548ba870ac2924de84626f10e88b6603a01c842e5a5d0ef71d3a75fc67a080ca22f6
DIST ypy-websocket-0.8.3.gh.tar.gz 13237 BLAKE2B 49c60b56b5812620212df5165b022501152c170831aff25bc8ff25901ea5ebdc91db2835a923a874bb62b1f0e6864a9d860b951ebafa9589fa16ce8cba9a197e SHA512 fbc2a795d25ba7f228841545b814c29c018126254fed7c59056e99946da9efaf22eb425acd43c85b31df3fd14e8ce91f34f32a309c9586a78a67c8a30e022a79
+DIST ypy-websocket-0.8.4.gh.tar.gz 13416 BLAKE2B 9dd988d6eceb624bae2385180c408971a776f06324407506886c2ef5b8e713277a4c4fb0a2d328a20695d4db8808997c125bfb48faa60c93fe38bb1a1e899766 SHA512 20794b182bbf3958df9f3097ab8c4657acef1ca294c751e0524bc5a36cd7b7a6a2766ae9295cd5f9fc31070813d5b56e0e1e25e22931f63171f88b4757bb1584
diff --git a/dev-python/ypy-websocket/ypy-websocket-0.8.4.ebuild b/dev-python/ypy-websocket/ypy-websocket-0.8.4.ebuild
new file mode 100644
index 000000000000..4394429329a1
--- /dev/null
+++ b/dev-python/ypy-websocket/ypy-websocket-0.8.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to y-crdt "
+HOMEPAGE="
+ https://pypi.org/project/ypy-websocket/
+ https://github.com/y-crdt/ypy-websocket/
+"
+SRC_URI="
+ https://github.com/y-crdt/ypy-websocket/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ <dev-python/aiofiles-23[${PYTHON_USEDEP}]
+ dev-python/aiosqlite[${PYTHON_USEDEP}]
+ <dev-python/y-py-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/y-py-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Requires internet and nodejs
+ tests/test_ypy_yjs.py
+)
+
+distutils_enable_tests pytest