summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2016-01-08 21:27:06 -0600
committerErik Mackdanz <stasibear@gentoo.org>2016-01-08 21:27:06 -0600
commitde05ed5949dc4872b642407719d1336e6367d282 (patch)
treeb64d728f4a2f5e4b45e0dbd194a711348e3e2f24
parentapp-eselect/eselect-php: version bump 0.8.3 -> 0.8.4. (diff)
downloadgentoo-de05ed5949dc4872b642407719d1336e6367d282.tar.gz
gentoo-de05ed5949dc4872b642407719d1336e6367d282.tar.bz2
gentoo-de05ed5949dc4872b642407719d1336e6367d282.zip
sys-fs/lxcfs: bump to 0.16
Package-Manager: portage-2.2.26
-rw-r--r--sys-fs/lxcfs/Manifest1
-rwxr-xr-xsys-fs/lxcfs/files/lxcfs-0.16.initd27
-rw-r--r--sys-fs/lxcfs/files/lxcfs-0.16.service13
-rw-r--r--sys-fs/lxcfs/lxcfs-0.16.ebuild56
4 files changed, 97 insertions, 0 deletions
diff --git a/sys-fs/lxcfs/Manifest b/sys-fs/lxcfs/Manifest
index c4d6c0d47139..2352b2f5235c 100644
--- a/sys-fs/lxcfs/Manifest
+++ b/sys-fs/lxcfs/Manifest
@@ -1,2 +1,3 @@
DIST lxcfs-0.12.tar.gz 34700 SHA256 89fc1caf3787b99dc26dc4b6b35fe216aad09b35c46e4be1d75c0e136f53702c SHA512 0145fe6252990bc14e6db32ab05337df9899c0e4d02ced35a5693da49aa84b4932f3c3bf58422a6d3c12c35a5db73169c4ab79448c928caae61996b0c92b908e WHIRLPOOL 940c9c2dd32547cb1a2a98423e03b3a9b7e8bae00775b45a8bdd7a99ee05ffa9bdf24e863ca65944abef2526d11b6b5532299aabc4ae50c97f42b3c2187ada5b
DIST lxcfs-0.13.tar.gz 35046 SHA256 a0280b1080c95062d75fa0a3f0e743849c7cd8a88b49ff8323a665cbac75224a SHA512 bca32de4857dbcafeca0d206fd202223b35aa5918ffee9d88486cec0d7c686e9b258918204f340f666fb3ac5d382ee84706db4f5268e98c8153e4ccc5de12595 WHIRLPOOL d074d482461e8f98d55f9919eabd98cc6c015fce7f731bb99122c7b16bf40faa37a7c3ffbe2e7aa7375a0313c00e508d79863f1a60e53ab584696fe5abaec5dc
+DIST lxcfs-0.16.tar.gz 35307 SHA256 a43c303ec46f4f25b14b7973726b2dc04231a126763b9fe6e0b080d608c04086 SHA512 536b7b6109b2b9d508c37baa1e4824d0cac37eadc2c046f49db89e24adb5474d6a67410e3c0cbb970c73d2dfe7e3757a4ce08577018c2fdb787668ed31af3a03 WHIRLPOOL 718505531388f517b154aff3cca18d5526a9d18163e22e95a5cd496757f3261b2342d52f0de704d9fe7d41d5623099f3c41493cd17668fc74facf2987b27eea5
diff --git a/sys-fs/lxcfs/files/lxcfs-0.16.initd b/sys-fs/lxcfs/files/lxcfs-0.16.initd
new file mode 100755
index 000000000000..a85021401a7d
--- /dev/null
+++ b/sys-fs/lxcfs/files/lxcfs-0.16.initd
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DAEMON=/usr/bin/lxcfs
+PIDFILE=/run/lxcfs.pid
+
+start() {
+ ebegin "Starting lxcfs"
+
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${DAEMON} \
+ --background \
+ --make-pidfile \
+ -- \
+ -f -o allow_other /var/lib/lxcfs
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping lxcfs"
+ start-stop-daemon --stop --quiet -R TERM/45 -p ${PIDFILE}
+ eend $?
+}
diff --git a/sys-fs/lxcfs/files/lxcfs-0.16.service b/sys-fs/lxcfs/files/lxcfs-0.16.service
new file mode 100644
index 000000000000..ff737c7e78ce
--- /dev/null
+++ b/sys-fs/lxcfs/files/lxcfs-0.16.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=FUSE filesystem for LXC
+ConditionVirtualization=!container
+Before=lxc.service
+
+[Service]
+ExecStart=/usr/bin/lxcfs -f -o allow_other /var/lib/lxcfs
+KillMode=none
+Restart=on-failure
+ExecStop=/usr/bin/fusermount -u /var/lib/lxcfs
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-fs/lxcfs/lxcfs-0.16.ebuild b/sys-fs/lxcfs/lxcfs-0.16.ebuild
new file mode 100644
index 000000000000..d2b444d31b42
--- /dev/null
+++ b/sys-fs/lxcfs/lxcfs-0.16.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils systemd vcs-snapshot
+DESCRIPTION="FUSE filesystem for LXC"
+HOMEPAGE="https://linuxcontainers.org/lxcfs/introduction/"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/lxc/lxcfs.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/lxc/lxcfs/archive/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+#IUSE="test"
+
+# Omit all dbus. Upstream appears to require it because systemd, but
+# lxcfs makes no direct use of dbus.
+RDEPEND="
+ dev-libs/glib:2
+ sys-fs/fuse
+"
+DEPEND="
+ sys-apps/help2man
+ ${RDEPEND}
+"
+
+src_prepare() {
+ ./bootstrap.sh || die "Failed to bootstrap configure files"
+}
+
+src_configure() {
+ econf --localstatedir=/var
+}
+
+# Test suite fails for me
+# src_test() {
+# emake tests
+# tests/main.sh || die "Tests failed"
+# }
+
+src_install() {
+ default
+ dodir /var/lib/lxcfs
+ newinitd "${FILESDIR}"/${P}.initd lxcfs
+ systemd_newunit "${FILESDIR}/${P}.service" lxcfs.service
+}