summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-04-02 21:03:03 +0200
committerPacho Ramos <pacho@gentoo.org>2020-04-02 21:03:13 +0200
commitd88b0a5885a738db1ed76b07600a4b5ab866988b (patch)
tree21dc010a1a29c10492ea16bf72e95ef7ee1ac69c
parentnet-dns/avahi: Shift USE=gtk to mean GTK+3 (diff)
downloadgentoo-d88b0a5885a738db1ed76b07600a4b5ab866988b.tar.gz
gentoo-d88b0a5885a738db1ed76b07600a4b5ab866988b.tar.bz2
gentoo-d88b0a5885a738db1ed76b07600a4b5ab866988b.zip
gnome-extra/gnome-shell-extension-dash-to-panel: Bump to v32
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--gnome-extra/gnome-shell-extension-dash-to-panel/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-dash-to-panel/gnome-shell-extension-dash-to-panel-32.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-dash-to-panel/Manifest b/gnome-extra/gnome-shell-extension-dash-to-panel/Manifest
index 2df15768a218..3bd7fb331d57 100644
--- a/gnome-extra/gnome-shell-extension-dash-to-panel/Manifest
+++ b/gnome-extra/gnome-shell-extension-dash-to-panel/Manifest
@@ -1,3 +1,4 @@
DIST gnome-shell-extension-dash-to-panel-26.tar.gz 21100594 BLAKE2B da90d4f496e10c14c554edb74065c95bf211f6778c097e3b81d863a46d0d3477f281cebac72f334b461f28b998284a861363b27d6c17ef5b1d47947a1f44bf01 SHA512 45bc148d2419db5943d0c2170ea3739a36c5a928c39d070501c5dfbec3910ba08058af1926c42f75d6b3e5918d8c30aef4f38db0af14115c11027520fa582a2f
DIST gnome-shell-extension-dash-to-panel-31.tar.gz 21114019 BLAKE2B 4a495909e9ddf498151272eb8cabf9f4e4cc3b5b9616645a52fcd1d5e43d25d3d70b2840e5cec5531dc0f1abf7093133ebbfb52783e65520aab828c4cc0cf827 SHA512 3b98b9fbff26c7d7972271f01d84ec8c80d677e965519dd0ebc580d383e42fc2c44d4b21a28cf7438b92eaa56fbc6f5e41b1c595f78405e1b1f49cf982b3bc5f
+DIST gnome-shell-extension-dash-to-panel-32.tar.gz 21115648 BLAKE2B cc8e4c89051e43ac1382223e0cb29907e7c9ce998355987aaf1ead7057a3b70acaaf97ae9b97410ee7528952e3b0b23a48043f1981ede4588ae8a76d781335a2 SHA512 9585c9e95d14b3b7b05848b79297a7655c0764c4ab6f4053a1c9eb688352b1533cf06dd74f3f5c78575beedb38a855bfb9872131be9b74cc9cf1588913baae78
DIST tango-gentoo-v1.1.tar.gz 29322 BLAKE2B 83fa2bf37727e60851dd679054fe1b153ebfea58c9a9a40f891f7d68d3b047b02e8effa1d1b4e08d64500a2072ce7200f159c92a352da7124de27e1b05bb6027 SHA512 87d47ddab68361db6d99866c51705dcb3e198f8345a1096859acf2c6cca5099dd23c7fb30d124f52c4933ea38fd45fadffbbe6ecbdfa84f5b60938a4824f9045
diff --git a/gnome-extra/gnome-shell-extension-dash-to-panel/gnome-shell-extension-dash-to-panel-32.ebuild b/gnome-extra/gnome-shell-extension-dash-to-panel/gnome-shell-extension-dash-to-panel-32.ebuild
new file mode 100644
index 000000000000..c5470a35cce9
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-dash-to-panel/gnome-shell-extension-dash-to-panel-32.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils
+
+MY_PN="${PN/gnome-shell-extension-/}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="An icon taskbar for the Gnome Shell"
+HOMEPAGE="https://github.com/home-sweet-gnome/dash-to-panel"
+SRC_URI="
+ https://github.com/home-sweet-gnome/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ branding? ( https://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="branding"
+
+COMMON_DEPEND="dev-libs/glib:2"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.18.0
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ # Enable by default custom opacity to get panel slightly transparent
+ # as was done in older Gnome versions
+ "${FILESDIR}"/${PN}-26-opacity.patch
+)
+
+src_prepare() {
+ default
+
+ # Set correct version
+ export VERSION="${PV}"
+
+ # Don't install README and COPYING in unwanted locations
+ sed -i -e 's/COPYING//g' -e 's/README.md//g' Makefile || die
+
+ # Provide fancy Gentoo icon when requested
+ use branding && eapply "${FILESDIR}"/${PN}-26-branding.patch
+}
+
+src_install() {
+ default
+ if use branding; then
+ insinto /usr/share/gnome-shell/extensions/dash-to-panel@jderose9.github.com/img
+ doins "${WORKDIR}/tango-gentoo-v1.1/scalable/gentoo.svg"
+ fi
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}