summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2021-12-26 15:19:48 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2021-12-26 15:20:39 +0300
commitcb8d247de762a6666b86e2302ebd1ee797f5aa58 (patch)
treedaf918f3e1ce539db28399dff995186a42b4fe8b
parentdev-lang/scala: reorganize DEPEND to let it build. (diff)
downloadgentoo-cb8d247de762a6666b86e2302ebd1ee797f5aa58.tar.gz
gentoo-cb8d247de762a6666b86e2302ebd1ee797f5aa58.tar.bz2
gentoo-cb8d247de762a6666b86e2302ebd1ee797f5aa58.zip
net-proxy/privoxy: remove old
Affected by multiple CVEs, see bug for details. Bug: https://bugs.gentoo.org/829051 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
-rw-r--r--net-proxy/privoxy/Manifest1
-rw-r--r--net-proxy/privoxy/privoxy-3.0.32-r1.ebuild148
2 files changed, 0 insertions, 149 deletions
diff --git a/net-proxy/privoxy/Manifest b/net-proxy/privoxy/Manifest
index 225fc03773b4..2377bed61add 100644
--- a/net-proxy/privoxy/Manifest
+++ b/net-proxy/privoxy/Manifest
@@ -1,2 +1 @@
-DIST privoxy-3.0.32-stable-src.tar.gz 1834528 BLAKE2B c846dada5fd34b80be9f7a75dc4177f3907241f6cf28b4120929687523d449d73b6a78bfe73f0a1086fbb3a8388103beb1e5a62becdffa24bf57d34cbb6cda56 SHA512 da41c0045bf593219df64718645eff984b5df43737811cc0fa12fce7e8ae1ab59eefbe20f23d6ce8f62216cfd81f1a9c319688d15693c25eed36010f3e1d5ffd
DIST privoxy-3.0.33-stable-src.tar.gz 1579540 BLAKE2B 4b76aa2e84160bab346d0548019158edb5562ca1dbf5356f765a6b91967f352f99c45c852254acf3d8e85cf8e8d210c050d1cf69ace3e5dbda8cdd13c1138df3 SHA512 9684455dbce7f6d8f5defd31aa9a7316e0c1dc896525ab4d562d0359462b541b1c366dea9db07b798f3e00b9cbcc44f494d8c431bcb10f2cb05b5bca3cfeaf75
diff --git a/net-proxy/privoxy/privoxy-3.0.32-r1.ebuild b/net-proxy/privoxy/privoxy-3.0.32-r1.ebuild
deleted file mode 100644
index cbcdc645d5f6..000000000000
--- a/net-proxy/privoxy/privoxy-3.0.32-r1.ebuild
+++ /dev/null
@@ -1,148 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools systemd toolchain-funcs
-
-[ "${PV##*_}" = "beta" ] &&
- PRIVOXY_STATUS="beta" ||
- PRIVOXY_STATUS="stable"
-
-HOMEPAGE="https://www.privoxy.org https://sourceforge.net/projects/ijbswa/"
-DESCRIPTION="A web proxy with advanced filtering capabilities for enhancing privacy"
-SRC_URI="mirror://sourceforge/ijbswa/${P%_*}-${PRIVOXY_STATUS}-src.tar.gz"
-
-IUSE="+acl brotli client-tags compression editor extended-host-patterns
-extended-statistics external-filters +fast-redirects +force fuzz
-graceful-termination +image-blocking ipv6 lfs +mbedtls openssl
-png-images selinux ssl +stats +threads toggle tools whitelists
-+zlib"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ppc ppc64 sparc x86"
-LICENSE="GPL-2+"
-
-DEPEND="
- acct-group/privoxy
- acct-user/privoxy
- dev-libs/libpcre
- brotli? ( app-arch/brotli )
- ssl? (
- mbedtls? ( net-libs/mbedtls:= )
- openssl? ( dev-libs/openssl:= )
- )
- zlib? ( sys-libs/zlib:= )
-"
-RDEPEND="${DEPEND}
- extended-host-patterns? ( dev-lang/perl )
- selinux? ( sec-policy/selinux-privoxy )
- tools? (
- net-misc/curl
- dev-lang/perl
- )
-"
-REQUIRED_USE="
- client-tags? ( threads )
- toggle? ( editor )
- compression? ( zlib )
- brotli? ( zlib )
- fuzz? ( zlib )
- ssl? ( ^^ ( mbedtls openssl ) threads )
-"
-
-S="${WORKDIR}/${P%_*}-${PRIVOXY_STATUS}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.0.32-gentoo.patch
- "${FILESDIR}"/${PN}-3.0.28-strip.patch
-)
-
-pkg_pretend() {
- if ! use threads; then
- ewarn
- ewarn "Privoxy may be very slow without threads support, consider to enable them."
- ewarn "See also https://www.privoxy.org/faq/trouble.html#GENTOO-RICERS"
- ewarn
- fi
-}
-
-src_prepare() {
- default
- mv configure.in configure.ac || die
- sed -i "s|/p\.p/|/config.privoxy.org/|g" tools/privoxy-regression-test.pl || die
-
- # autoreconf needs to be called even if we don't modify any autotools source files
- # See main makefile
- eautoreconf
-}
-
-src_configure() {
- local myconf="--without-mbedtls --without-openssl"
- if use ssl; then
- myconf="$(use_with mbedtls) $(use_with openssl)"
- fi
-
- # --with-debug only enables debug CFLAGS
- # --with-docbook and --with-db2html and their deps are useless,
- # since docs are already pregenerated in the source tarball
- econf \
- --sysconfdir=/etc/privoxy \
- --enable-dynamic-pcre \
- --without-assertions \
- --with-user=privoxy \
- --with-group=privoxy \
- $(use_enable acl acl-support) \
- $(use_enable compression) \
- $(use_enable client-tags) \
- $(use_enable editor) \
- $(use_enable extended-host-patterns pcre-host-patterns) \
- $(use_enable extended-statistics) \
- $(use_enable fast-redirects) \
- $(use_enable force) \
- $(use_enable fuzz) \
- $(use_enable graceful-termination) \
- $(use_enable image-blocking) \
- $(use_enable ipv6 ipv6-support) \
- $(use_enable kernel_FreeBSD accept-filter) \
- $(use_enable lfs large-file-support) \
- $(use_enable png-images no-gifs) \
- $(use_enable stats) \
- $(use_enable threads pthread) \
- $(use_enable toggle) \
- $(use_enable whitelists trust-files) \
- $(use_enable zlib) \
- $(use_with brotli) \
- ${myconf}
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}/privoxy.initd-3" privoxy
- systemd_dounit "${FILESDIR}"/${PN}.service
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}/privoxy.logrotate" privoxy
-
- diropts -m 0750 -g privoxy -o privoxy
- keepdir /var/log/privoxy
-
- use extended-host-patterns && newbin tools/url-pattern-translator.pl privoxy-url-pattern-translator.pl
- if use tools; then
- dobin tools/{privoxy-log-parser.pl,privoxy-regression-test.pl}
- newbin tools/uagen.pl privoxy-uagen.pl
- fi
-
- rmdir "${ED}/var/run" || die
- chown privoxy:root "${ED}/etc/privoxy" || die
-}
-
-pkg_postinst() {
- if use extended-host-patterns; then
- ewarn
- ewarn "You enabled extended-host-patterns, now you *must* convert all action files in"
- ewarn "PCRE-compatible format, or privoxy will fail to start. Helper tool"
- ewarn "privoxy-url-pattern-translator.pl is available."
- ewarn
- fi
-}