summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-15 09:52:43 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-15 11:04:19 +0200
commitba7829adc9ca75302bfd62bebfd9e1e01cf71bea (patch)
tree8d1bd69a8734737e7874e7785fd32315c330302d
parentdev-python/zstandard: Bump to 0.23.0 (diff)
downloadgentoo-ba7829adc9ca75302bfd62bebfd9e1e01cf71bea.tar.gz
gentoo-ba7829adc9ca75302bfd62bebfd9e1e01cf71bea.tar.bz2
gentoo-ba7829adc9ca75302bfd62bebfd9e1e01cf71bea.zip
dev-python/jsondiff: Bump to 2.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jsondiff/Manifest1
-rw-r--r--dev-python/jsondiff/jsondiff-2.1.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/jsondiff/Manifest b/dev-python/jsondiff/Manifest
index ac7eac81ab55..24243db80cda 100644
--- a/dev-python/jsondiff/Manifest
+++ b/dev-python/jsondiff/Manifest
@@ -1,3 +1,4 @@
DIST jsondiff-2.0.0-nose2pytest.diff 11525 BLAKE2B e1e9f6996448c5f8454a74dbe5782684d68cbb00eae1793fd010bccd80b682e6f3869082df9546603ce87bee82a99148a948db675b1da8f2815e5290eb632763 SHA512 791e4f8473459e374892067cf90099df23d981857b81cc164e2d0c35c51cbbede160de1b46474b6cb817b8811e2481172807eff31847a7847fc847948cf402f7
DIST jsondiff-2.0.0.gh.tar.gz 15405 BLAKE2B d69e5a9316e8ce32c6fd3e62162b609a471ff57bacb77f47a192b85352e77135a37c964d0ade5df4b4e37fe7d996eab13649dd4c6a3bc3fc0479294f840c82f9 SHA512 ca266040294c064b499763174613628125a9d426f37eddb8f63806d5774ce8828d514ca30ea4b42f6e2529aa34344c601ece05b6c1b42dcedd71c7b62ed0afba
DIST jsondiff-2.1.1.gh.tar.gz 18691 BLAKE2B 4b58ce8d637b139c233860f21a98e6561f620bcabb8239e651bc34300163684f16ebbc8c1cd4d619ce7ffdd118e78db497a2897b176727942594c3ac8c7c41cf SHA512 d906cce6ff94e475f079e9ef2210fbb200a134ac3723cf36f3737c2bc722892eef74860c30feba7961b75b320882bed74921150173852b5154406259184715a5
+DIST jsondiff-2.1.2.gh.tar.gz 22307 BLAKE2B 33a95eb842659e4d0d02aa7f591f942e5bc1b361e99860fbda57d7743cbed9951a4509571e53a44c66c6c7ecccd90985abeb577a80c2f8c7cb58b104e0e409e9 SHA512 c4d8aac26a2c094178ff21dc7f3aee919bf49c18fd2b0ffdb993c32fb2575b18b60b49db784a14059709ecaf928eb8ff18ca1731e2ed26dd587c69d40adca260
diff --git a/dev-python/jsondiff/jsondiff-2.1.2.ebuild b/dev-python/jsondiff/jsondiff-2.1.2.ebuild
new file mode 100644
index 000000000000..1f6ddda4fc90
--- /dev/null
+++ b/dev-python/jsondiff/jsondiff-2.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff JSON and JSON-like structures in Python"
+HOMEPAGE="
+ https://github.com/xlwings/jsondiff/
+ https://pypi.org/project/jsondiff/
+"
+SRC_URI="
+ https://github.com/xlwings/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}