summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-02 10:56:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-02 10:56:34 +0200
commita6d0f7cb95ec0cafb4b7e2de124f2c7ed25e34fe (patch)
tree4cd153f66cfc94eba5ce3871a62392a10f455e62
parentdev-python/wsproto: Remove old (diff)
downloadgentoo-a6d0f7cb95ec0cafb4b7e2de124f2c7ed25e34fe.tar.gz
gentoo-a6d0f7cb95ec0cafb4b7e2de124f2c7ed25e34fe.tar.bz2
gentoo-a6d0f7cb95ec0cafb4b7e2de124f2c7ed25e34fe.zip
dev-python/sqlalchemy: Skip tests requiring greenlet if not avail.
Closes: https://bugs.gentoo.org/842117 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.4.35.ebuild8
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.4.36.ebuild8
2 files changed, 16 insertions, 0 deletions
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.4.35.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.4.35.ebuild
index d49130048380..d990b9e3bac3 100644
--- a/dev-python/sqlalchemy/sqlalchemy-1.4.35.ebuild
+++ b/dev-python/sqlalchemy/sqlalchemy-1.4.35.ebuild
@@ -49,6 +49,14 @@ python_test() {
[[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
test/ext/test_associationproxy.py::ProxyHybridTest::test_msg_fails_on_cls_access
)
+ if ! has_version "dev-python/greenlet[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_execution
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_run_sync
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[True-_exclusions0]"
+ "test/engine/test_pool.py::QueuePoolTest::test_userspace_disconnectionerror_weakref_finalizer[True-_exclusions0]"
+ )
+ fi
# upstream's test suite is horribly hacky; it relies on disabling
# the warnings plugin and turning warnings into errors; this also
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.4.36.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.4.36.ebuild
index f22213fbdeb6..4eb4a4e1ddec 100644
--- a/dev-python/sqlalchemy/sqlalchemy-1.4.36.ebuild
+++ b/dev-python/sqlalchemy/sqlalchemy-1.4.36.ebuild
@@ -49,6 +49,14 @@ python_test() {
[[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
test/ext/test_associationproxy.py::ProxyHybridTest::test_msg_fails_on_cls_access
)
+ if ! has_version "dev-python/greenlet[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_execution
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_run_sync
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[True-_exclusions0]"
+ "test/engine/test_pool.py::QueuePoolTest::test_userspace_disconnectionerror_weakref_finalizer[True-_exclusions0]"
+ )
+ fi
# upstream's test suite is horribly hacky; it relies on disabling
# the warnings plugin and turning warnings into errors; this also