summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Denoncin <ddenoncin@gmail.com>2020-09-03 13:41:38 +0200
committerSam James <sam@gentoo.org>2020-09-16 02:05:25 +0000
commit94fa574aee6117e61a339044d58215ba8c0d799c (patch)
tree0ae91c254ffa2de4725e78ff7fae0c6d696e5e20
parentdev-cpp/popl: add new proxy maintainer (diff)
downloadgentoo-94fa574aee6117e61a339044d58215ba8c0d799c.tar.gz
gentoo-94fa574aee6117e61a339044d58215ba8c0d799c.tar.bz2
gentoo-94fa574aee6117e61a339044d58215ba8c0d799c.zip
app-misc/timew: vbump 1.4.2
Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: David Denoncin <ddenoncin@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17397 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-misc/timew/Manifest1
-rw-r--r--app-misc/timew/timew-1.4.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/timew/Manifest b/app-misc/timew/Manifest
index 49739f108655..2b76625ad9c6 100644
--- a/app-misc/timew/Manifest
+++ b/app-misc/timew/Manifest
@@ -1 +1,2 @@
DIST timew-1.3.0.tar.gz 1125892 BLAKE2B 7ef9f6f405d710addd90758ea1188678aa3269354f81be583f63eb920c0163d0a428e9b62d896ba189f842494835df785e1f26d877bda03205a94067af8456d0 SHA512 38bf44c83d2315155ee43085957824db69d9501abf2cf0bdf51636169043d82b701ebfac3176bc1dfc0186abb7db7a3a40111968c85597e7edb73c66083f0ab0
+DIST timew-1.4.2.tar.gz 1316841 BLAKE2B c451f37aeb32e999fe2cdca2eb5f234c7424b76f489324d5723a3649da37f53f5094989bdf8d5c2d27f5daa0d75c72ec4a01e3c19b8b064f28e4db82587498b9 SHA512 fe4c3def6b2cd78793dd97a38a61497b3910cd87a3315f826c64893b96a998bf30363f0df1892b74b718d03a279d51c1a636739225e101c5c126794e434076f0
diff --git a/app-misc/timew/timew-1.4.2.ebuild b/app-misc/timew/timew-1.4.2.ebuild
new file mode 100644
index 000000000000..86785cd3972f
--- /dev/null
+++ b/app-misc/timew/timew-1.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Tracks your time from the command line, and generates reports"
+HOMEPAGE="https://timewarrior.net"
+SRC_URI="https://github.com/GothenburgBitFactory/timewarrior/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ mycmakeargs=(
+ -DCMAKE_BUILD_TYPE=release
+ -DTIMEW_DOCDIR=share/doc/"${PF}"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ dodoc -r ext
+ docompress -x /usr/share/doc/${PF}/ext/{on-modify.timewarrior,README}
+}
+
+pkg_postinst() {
+ elog "To integrate timewarrior with taskwarrior, issue the following commands:"
+ elog "cp /usr/share/doc/${PF}/ext/on-modify.timewarrior ~/.task/hooks/"
+ elog "chmod +x ~/.task/hooks/on-modify.timewarrior"
+ elog "see https://timewarrior.net/docs/taskwarrior.html"
+}