summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-31 17:57:06 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-31 18:18:19 +0200
commit839e01b803759a31fceaa05a3d33824c5bfb2b28 (patch)
tree627944c1f011e113ab8a0b02a0cd4d0c0c4eaf54
parentmedia-gfx/inkscape: add patch for C++20 syntax break (diff)
downloadgentoo-839e01b803759a31fceaa05a3d33824c5bfb2b28.tar.gz
gentoo-839e01b803759a31fceaa05a3d33824c5bfb2b28.tar.bz2
gentoo-839e01b803759a31fceaa05a3d33824c5bfb2b28.zip
dev-python/ansible-compat: Bump to 24.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ansible-compat/Manifest1
-rw-r--r--dev-python/ansible-compat/ansible-compat-24.6.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index f9da22d4cff0..13e28bb0fb66 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1 +1,2 @@
+DIST ansible-compat-24.6.0.gh.tar.gz 74286 BLAKE2B e61b9501aad867e738d128397f4b37e1299f4bc249e4217def60a704dd470886d269b2b61b738a644300085c4d46793bd32982c470de7a26590990c14eab4810 SHA512 217faed3354e459d9541962778f455b34b4ddf1c9b8141752645b25fd68747305de5d08d65b01c8168907e70c1dc31aeb2099420bf1e3553cd7f41627a12f0da
DIST ansible-compat-4.1.12.gh.tar.gz 67966 BLAKE2B 3c665eb2cb87e184042da78ed1c41e7ca2b437c5151ba21bdd609104b44fa28c5f03247d275c58cfdf04a8e9ed328947cb0c2670603218798e3a484861274af2 SHA512 c9b2c340dc2b1ffb6f6db76017f7537e20307a7519a4df2dfb31811180cd647e39812bc433db51bd94d42f4c52a6c2f729d81edadcd615a5e0d23566969d8911
diff --git a/dev-python/ansible-compat/ansible-compat-24.6.0.ebuild b/dev-python/ansible-compat/ansible-compat-24.6.0.ebuild
new file mode 100644
index 000000000000..18c39cfc27c2
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-24.6.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+# We normally use PyPI here but 4.1.12 has never been uploaded there for some reason
+SRC_URI="https://github.com/ansible/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.14[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+ # pip, failing due to internets
+ test/test_runtime_scan_path.py::test_scan_sys_path
+ # internets?
+ test/test_runtime.py::test_runtime_has_playbook
+)
+
+distutils_enable_tests pytest