summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-23 08:52:19 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-23 09:41:10 +0100
commit749cd710575cce64830a0fac23969b6ef2400387 (patch)
treea0c2ee8d2b6fea765b7ec7dd258820b37eadc62a
parentnet-wireless/blueman: Bump to 2.3.5 (diff)
downloadgentoo-749cd710575cce64830a0fac23969b6ef2400387.tar.gz
gentoo-749cd710575cce64830a0fac23969b6ef2400387.tar.bz2
gentoo-749cd710575cce64830a0fac23969b6ef2400387.zip
dev-python/cleo: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cleo/Manifest1
-rw-r--r--dev-python/cleo/cleo-2.0.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/cleo/Manifest b/dev-python/cleo/Manifest
index bba90d117976..14814f035330 100644
--- a/dev-python/cleo/Manifest
+++ b/dev-python/cleo/Manifest
@@ -1,2 +1,3 @@
DIST cleo-0.8.1.gh.tar.gz 96220 BLAKE2B 57971f6254a31ecf5101d89e96607b5915ab5138d727279d445172b89a10acd6b76619d344973fa2bdbc320866fa1dbdf05c889f4eca879839fa6bcbbad0af7c SHA512 9cd470063db9866a526f0bb8619d772c585377d5b1a662e0f94bad9fb9c853598b176444ca1ac0fadec82992196c471646504d6a28d4dcd1171433b8d160be9c
DIST cleo-1.0.0.gh.tar.gz 154114 BLAKE2B 7a8906b4a40c1d1a9899f2195a4e4a35a828c2ea7713df31a94e40e7e930b8624a24ff5bc219140b5e42e100f96199393c940aa1bac24991c380f2136762dbff SHA512 a45af3f4ff0fc9535363bdcf265ab3d7726af99cf4b48e896f9d5fb1404721b4641f80e37a7266690a1f7d4a261cbd4c746338294ff29745f782f8657cd2bb07
+DIST cleo-2.0.1.gh.tar.gz 154222 BLAKE2B dcaeff38c2dcb13b3c11200aa97cb2a1c16004558aabf9b44f1ba7ddd5d9c8c7784ea0ba1c50c19b015a6ff0659cb116b8ee926670091e39fd2b1cfd426cb72a SHA512 57a8e9cfc5486f73ade424199aaeb3def787a958031691aba2c6a230323d1c816316e3639dee7a07111aa0fc852d7088756f515cb24fdc84a40056ce969e5884
diff --git a/dev-python/cleo/cleo-2.0.1.ebuild b/dev-python/cleo/cleo-2.0.1.ebuild
new file mode 100644
index 000000000000..c3e87c88a8bd
--- /dev/null
+++ b/dev-python/cleo/cleo-2.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python tool for building testable command-line interfaces"
+HOMEPAGE="
+ https://github.com/python-poetry/cleo/
+ https://pypi.org/project/cleo/
+"
+SRC_URI="
+ https://github.com/python-poetry/cleo/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+
+RDEPEND="
+ dev-python/crashtest[${PYTHON_USEDEP}]
+ dev-python/rapidfuzz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_mock
+ epytest
+}