summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2017-04-25 18:22:05 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2017-04-25 18:22:05 +0000
commit66011deabdd58e81dd0db480f929cd7905354468 (patch)
treee2032710d1a88017322c967bead0151ea7fee6b7
parent2017-04-25 17:45:43 UTC (diff)
parentwww-apache/mod_gnutls: 0.8.2 can be built with gnutls-3.3 (diff)
downloadgentoo-66011deabdd58e81dd0db480f929cd7905354468.tar.gz
gentoo-66011deabdd58e81dd0db480f929cd7905354468.tar.bz2
gentoo-66011deabdd58e81dd0db480f929cd7905354468.zip
Merge updates from master
-rw-r--r--dev-db/etcd/Manifest1
-rw-r--r--dev-db/etcd/etcd-2.3.8.ebuild58
-rw-r--r--dev-python/awscli/metadata.xml5
-rw-r--r--dev-python/carbon/metadata.xml5
-rw-r--r--eclass/ELT-patches/nocxx/nocxx-2.64.patch13
-rw-r--r--eclass/ELT-patches/nocxx/nocxx.patch15
-rw-r--r--eclass/epunt-cxx.eclass26
-rw-r--r--eclass/eutils.eclass7
-rw-r--r--eclass/gnome2-utils.eclass23
-rw-r--r--eclass/gnome2.eclass4
-rw-r--r--eclass/kde4-base.eclass4
-rw-r--r--eclass/kde5.eclass4
-rw-r--r--eclass/python-utils-r1.eclass6
-rw-r--r--eclass/xfconf.eclass4
-rw-r--r--sys-cluster/cinder/metadata.xml1
-rw-r--r--sys-cluster/openstack-meta/openstack-meta-2016.1.9999.ebuild20
-rw-r--r--sys-cluster/openstack-meta/openstack-meta-2016.2.9999.ebuild4
-rw-r--r--www-apache/mod_gnutls/mod_gnutls-0.8.2-r1.ebuild2
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.4.1-r1.ebuild79
-rw-r--r--www-apps/icingaweb2/icingaweb2-9999.ebuild16
20 files changed, 186 insertions, 111 deletions
diff --git a/dev-db/etcd/Manifest b/dev-db/etcd/Manifest
index 838f156271f3..6dba5b767429 100644
--- a/dev-db/etcd/Manifest
+++ b/dev-db/etcd/Manifest
@@ -1,3 +1,4 @@
DIST etcd-2.3.7.tar.gz 2209051 SHA256 aa3a6340bb08d072d1d2ecfbe3c1e02235251760d031a2b699ee1710510ee883 SHA512 a551287ebf6e881e2c6a56a7e75c273d125ed2b4b3ea58533e4481bc12ca21167de02820aaa1f4775b81385e96e65f882e97121920be02d72abe82f43652daf9 WHIRLPOOL e01bf51978b9287e9e662f8689630d80eb79aace43fe0c81f1898718ccec1a0a93e53543c3df001dfc12dac2a3844f5a4fe2de28d97654b671648ad93681185a
+DIST etcd-2.3.8.tar.gz 2206562 SHA256 6a138b2005e42b0961a12886cc641b792e991cd631fdb502ec5c614b65231cd1 SHA512 4268de32797cab23e9e47784d31d5abd6982068c53d3cc9735a06719740dba45b73f4e067cbc7aa8aef5ca7c56d8be067f1076685ac82f64012b760d8b7f2bfc WHIRLPOOL 4db1b4fe6d0ff917adfc53bd959bb7ac2937da794483e4a4a95e5fb557cf4fbfd43d5bb3c5e21e499432f80f6606407accaa69bc03a3982621276deb529c07da
DIST etcd-3.0.17.tar.gz 2208002 SHA256 c56c68a8cd5d120a51432f3a79a2c19082a6824493e4bb08c4e440aefbf73d8f SHA512 6eb6a61210f225b6fe7e911ad135e5014f80f71a04adccc3f382ca7b5e1b1b692b12dde26335ecac176cb8b8f4586732cb6e650b32730ec68ef7fbcbba7ab160 WHIRLPOOL 102dc47d120a1f4173b67168e5e51f64025da280ca41161131a6bd2ef9521605ef19e03166848f6c32862a3adbfc0a026f547dc7764018e85f6ac28f89c8d256
DIST etcd-3.1.0.tar.gz 2516872 SHA256 62ecb70a470b45436814e2882d36742a4035e1d62e6634450e71ca0ed951919b SHA512 b377ac492dd842a0f24d2816cd37bb40e692289efbbab63ab54e1b31e7999f26c6c0f2887249f5fd775266919a614699e561ecfc82c8a687d2cf1b25fdb7478f WHIRLPOOL b47a81ea597617a4eab6ee29d51b964f942b8dc324063e6633e2818320ce3b19e1907975a28ca3186cc112553b4e8580c210ad4854945484dcc26f359d0c60e6
diff --git a/dev-db/etcd/etcd-2.3.8.ebuild b/dev-db/etcd/etcd-2.3.8.ebuild
new file mode 100644
index 000000000000..f20ed84c75b8
--- /dev/null
+++ b/dev-db/etcd/etcd-2.3.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit user systemd
+
+KEYWORDS="~amd64"
+DESCRIPTION="Highly-available key value store for shared configuration and service discovery"
+HOMEPAGE="https://github.com/coreos/etcd/"
+SRC_URI="https://github.com/coreos/etcd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc"
+DEPEND=">=dev-lang/go-1.4:="
+RDEPEND="!dev-db/etcdctl"
+
+#pkg_setup() {
+# enewgroup ${PN}
+# enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+#}
+
+src_prepare() {
+ sed -e 's|GIT_SHA=.*|GIT_SHA=v${PV}|'\
+ -e 's|-ldflags "-s.*"|-v -x|' \
+ -e 's|-ldflags "-s|-v -x "|' \
+ -i build || die
+ sed -e 's|go test|\0 -v|'\
+ -i test || die
+}
+
+src_compile() {
+ ./build || die
+}
+
+src_install() {
+ insinto /etc/${PN}
+ doins "${FILESDIR}/${PN}.conf"
+ dobin bin/*
+ dodoc README.md
+ use doc && dodoc -r Documentation
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+ dodir /var/lib/${PN}
+ fowners ${PN}:${PN} /var/lib/${PN}
+ fperms 755 /var/lib/${PN}
+ dodir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+ fperms 755 /var/log/${PN}
+}
+
+src_test() {
+ ./test || die
+}
diff --git a/dev-python/awscli/metadata.xml b/dev-python/awscli/metadata.xml
index bfb840c1706e..07a14144d9eb 100644
--- a/dev-python/awscli/metadata.xml
+++ b/dev-python/awscli/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
<upstream>
<remote-id type="pypi">awscli</remote-id>
</upstream>
diff --git a/dev-python/carbon/metadata.xml b/dev-python/carbon/metadata.xml
index d369dee7ff6d..a7cca6f85130 100644
--- a/dev-python/carbon/metadata.xml
+++ b/dev-python/carbon/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
<upstream>
<remote-id type="pypi">carbon</remote-id>
</upstream>
diff --git a/eclass/ELT-patches/nocxx/nocxx-2.64.patch b/eclass/ELT-patches/nocxx/nocxx-2.64.patch
deleted file mode 100644
index 4b10e4697185..000000000000
--- a/eclass/ELT-patches/nocxx/nocxx-2.64.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/configure
-+++ b/configure
-@@ -5148,8 +5148,8 @@
- else
- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
- $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
--as_fn_error $? "C++ preprocessor \"$CXXCPP\" fails sanity check
--See \`config.log' for more details" "$LINENO" 5; }
-+$as_echo "See \`config.log' for more details." >&5;
-+$ac_echo "C++ sucks, ignoring ..." >&5; }
- fi
-
- ac_ext=c
diff --git a/eclass/ELT-patches/nocxx/nocxx.patch b/eclass/ELT-patches/nocxx/nocxx.patch
deleted file mode 100644
index 4b326924e18f..000000000000
--- a/eclass/ELT-patches/nocxx/nocxx.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/configure
-+++ b/configure
-@@ -5148,10 +5148,8 @@
- :
- else
- { { echo "$as_me:$LINENO: error: C++ preprocessor \"$CXXCPP\" fails sanity check
--See \`config.log' for more details." >&5
--echo "$as_me: error: C++ preprocessor \"$CXXCPP\" fails sanity check
--See \`config.log' for more details." >&2;}
-- { (exit 1); exit 1; }; }
-+See \`config.log' for more details." >&5;}
-+ { echo "C++ sucks, ignoring ..." >&5; }; }
- fi
-
- ac_ext=cc
diff --git a/eclass/epunt-cxx.eclass b/eclass/epunt-cxx.eclass
index 660b1d138fac..30802af340b0 100644
--- a/eclass/epunt-cxx.eclass
+++ b/eclass/epunt-cxx.eclass
@@ -11,28 +11,10 @@
if [[ -z ${_EPUNT_CXX_ECLASS} ]]; then
-# TODO: replace this with 'inherit eutils' once eutils stops inheriting
-# us
-if ! declare -F eqawarn >/dev/null ; then
- eqawarn() {
- has qa ${PORTAGE_ELOG_CLASSES} && ewarn "$@"
- :
- }
-fi
+# eutils for eqawarn
+inherit eutils
-# If an overlay has eclass overrides, but doesn't actually override the
-# libtool.eclass, we'll have ECLASSDIR pointing to the active overlay's
-# eclass/ dir, but libtool.eclass is still in the main Gentoo tree. So
-# add a check to locate the ELT-patches/ regardless of what's going on.
-# Note: Duplicated in libtool.eclass.
-_EUTILS_ECLASSDIR_LOCAL=${BASH_SOURCE[0]%/*}
-eutils_elt_patch_dir() {
- local d="${ECLASSDIR}/ELT-patches"
- if [[ ! -d ${d} ]] ; then
- d="${_EUTILS_ECLASSDIR_LOCAL}/ELT-patches"
- fi
- echo "${d}"
-}
+DEPEND=">=app-portage/elt-patches-20170317"
# @FUNCTION: epunt_cxx
# @USAGE: [dir to scan]
@@ -47,7 +29,7 @@ epunt_cxx() {
ebegin "Removing useless C++ checks"
local f p any_found
while IFS= read -r -d '' f; do
- for p in "$(eutils_elt_patch_dir)"/nocxx/*.patch ; do
+ for p in "${EPREFIX}/usr/share/elt-patches"/nocxx/*.patch ; do
if patch --no-backup-if-mismatch -p1 "${f}" "${p}" >/dev/null ; then
any_found=1
break
diff --git a/eclass/eutils.eclass b/eclass/eutils.eclass
index ea2a76200f09..fe4339f6b89a 100644
--- a/eclass/eutils.eclass
+++ b/eclass/eutils.eclass
@@ -20,8 +20,7 @@ _EUTILS_ECLASS=1
# implicitly inherited (now split) eclasses
case ${EAPI:-0} in
0|1|2|3|4|5|6)
- # note: we want to remove epunt-cxx retroactively for #566424
- inherit epatch epunt-cxx estack ltprune multilib toolchain-funcs
+ inherit epatch estack ltprune multilib toolchain-funcs
;;
esac
@@ -275,13 +274,11 @@ make_desktop_entry() {
# Don't append another ";" when a valid category value is provided.
type=${type%;}${type:+;}
- eshopts_push -s extglob
if [[ -n ${icon} && ${icon} != /* ]] && [[ ${icon} == *.xpm || ${icon} == *.png || ${icon} == *.svg ]]; then
ewarn "As described in the Icon Theme Specification, icon file extensions are not"
ewarn "allowed in .desktop files if the value is not an absolute path."
- icon=${icon%.@(xpm|png|svg)}
+ icon=${icon%.*}
fi
- eshopts_pop
cat <<-EOF > "${desktop}"
[Desktop Entry]
diff --git a/eclass/gnome2-utils.eclass b/eclass/gnome2-utils.eclass
index f2aa2391a532..a89b9885c391 100644
--- a/eclass/gnome2-utils.eclass
+++ b/eclass/gnome2-utils.eclass
@@ -230,40 +230,35 @@ gnome2_icon_cache_update() {
return
fi
- if [[ -z "${GNOME2_ECLASS_ICONS}" ]]; then
- debug-print "No icon cache to update"
- return
- fi
-
ebegin "Updating icons cache"
local retval=0
local fails=( )
- for dir in ${GNOME2_ECLASS_ICONS}
+ for dir in "${EROOT%/}"/usr/share/icons/*
do
- if [[ -f "${EROOT}${dir}/index.theme" ]] ; then
+ if [[ -f "${dir}/index.theme" ]] ; then
local rv=0
- "${updater}" -qf "${EROOT}${dir}"
+ "${updater}" -qf "${dir}"
rv=$?
if [[ ! $rv -eq 0 ]] ; then
- debug-print "Updating cache failed on ${EROOT}${dir}"
+ debug-print "Updating cache failed on ${dir}"
# Add to the list of failures
- fails[$(( ${#fails[@]} + 1 ))]="${EROOT}${dir}"
+ fails+=( "${dir}" )
retval=2
fi
- elif [[ $(ls "${EROOT}${dir}") = "icon-theme.cache" ]]; then
+ elif [[ $(ls "${dir}") = "icon-theme.cache" ]]; then
# Clear stale cache files after theme uninstallation
- rm "${EROOT}${dir}/icon-theme.cache"
+ rm "${dir}/icon-theme.cache"
fi
- if [[ -z $(ls "${EROOT}${dir}") ]]; then
+ if [[ -z $(ls "${dir}") ]]; then
# Clear empty theme directories after theme uninstallation
- rmdir "${EROOT}${dir}"
+ rmdir "${dir}"
fi
done
diff --git a/eclass/gnome2.eclass b/eclass/gnome2.eclass
index 8a83297b0959..feb6301221ea 100644
--- a/eclass/gnome2.eclass
+++ b/eclass/gnome2.eclass
@@ -337,7 +337,9 @@ gnome2_pkg_preinst() {
gnome2_pkg_postinst() {
xdg_pkg_postinst
gnome2_gconf_install
- gnome2_icon_cache_update
+ if [[ -n ${GNOME2_ECLASS_ICONS} ]]; then
+ gnome2_icon_cache_update
+ fi
gnome2_schemas_update
gnome2_scrollkeeper_update
gnome2_gdk_pixbuf_update
diff --git a/eclass/kde4-base.eclass b/eclass/kde4-base.eclass
index 999c8a05fee2..97f4dfd4eda9 100644
--- a/eclass/kde4-base.eclass
+++ b/eclass/kde4-base.eclass
@@ -907,7 +907,9 @@ kde4-base_pkg_preinst() {
kde4-base_pkg_postinst() {
debug-print-function ${FUNCNAME} "$@"
- gnome2_icon_cache_update
+ if [[ -n ${GNOME2_ECLASS_ICONS} ]]; then
+ gnome2_icon_cache_update
+ fi
fdo-mime_desktop_database_update
fdo-mime_mime_database_update
buildsycoca
diff --git a/eclass/kde5.eclass b/eclass/kde5.eclass
index 38b0fcda905c..102a41545a66 100644
--- a/eclass/kde5.eclass
+++ b/eclass/kde5.eclass
@@ -723,7 +723,9 @@ kde5_pkg_preinst() {
kde5_pkg_postinst() {
debug-print-function ${FUNCNAME} "$@"
- gnome2_icon_cache_update
+ if [[ -n ${GNOME2_ECLASS_ICONS} ]]; then
+ gnome2_icon_cache_update
+ fi
xdg_pkg_postinst
if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index a67e378d3997..49a605b9e159 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -943,7 +943,7 @@ python_wrapper_setup() {
rm -f "${workdir}"/bin/2to3 || die
rm -f "${workdir}"/pkgconfig/python{,2,3}.pc || die
- local EPYTHON PYTHON PYTHON_CONFIG
+ local EPYTHON PYTHON
python_export "${impl}" EPYTHON PYTHON
local pyver pyother
@@ -970,11 +970,9 @@ python_wrapper_setup() {
# CPython-specific
if [[ ${EPYTHON} == python* ]]; then
- python_export "${impl}" PYTHON_CONFIG
-
cat > "${workdir}/bin/python-config" <<-_EOF_ || die
#!/bin/sh
- exec "${PYTHON_CONFIG}" "\${@}"
+ exec "${PYTHON}-config" "\${@}"
_EOF_
cp "${workdir}/bin/python-config" \
"${workdir}/bin/python${pyver}-config" || die
diff --git a/eclass/xfconf.eclass b/eclass/xfconf.eclass
index 2655420ddd35..b91d0fe1eda3 100644
--- a/eclass/xfconf.eclass
+++ b/eclass/xfconf.eclass
@@ -139,7 +139,9 @@ xfconf_pkg_postinst() {
debug-print-function ${FUNCNAME} "$@"
fdo-mime_desktop_database_update
fdo-mime_mime_database_update
- gnome2_icon_cache_update
+ if [[ -n ${GNOME2_ECLASS_ICONS} ]]; then
+ gnome2_icon_cache_update
+ fi
}
# @FUNCTION: xfconf_pkg_postrm
diff --git a/sys-cluster/cinder/metadata.xml b/sys-cluster/cinder/metadata.xml
index 87b3d0f2fc0c..1ad12f6ac35b 100644
--- a/sys-cluster/cinder/metadata.xml
+++ b/sys-cluster/cinder/metadata.xml
@@ -12,7 +12,6 @@
<use>
<flag name="api">Installs the initscripts for the cinder api service</flag>
<flag name="iscsi">Allow using an iSCSI remote storage server as pool for disk image storage</flag>
- <flag name="lio">Enable lio storage backend support</flag>
<flag name="lvm">Allow using the Logical Volume Manager (<pkg>sys-fs/lvm2</pkg>) as pool for disk image storage</flag>
<flag name="memcached">Installs the memcached server</flag>
<flag name="rdma">Enable rdma storage backend support</flag>
diff --git a/sys-cluster/openstack-meta/openstack-meta-2016.1.9999.ebuild b/sys-cluster/openstack-meta/openstack-meta-2016.1.9999.ebuild
deleted file mode 100644
index cae347a1736e..000000000000
--- a/sys-cluster/openstack-meta/openstack-meta-2016.1.9999.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-DESCRIPTION="A openstack meta-package for installing the various openstack pieces"
-HOMEPAGE="https://openstack.org"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS=""
-IUSE="keystone swift neutron glance cinder nova"
-
-DEPEND=""
-RDEPEND="keystone? ( ~sys-auth/keystone-2016.1.9999 )
- swift? ( ~sys-cluster/swift-2.9.0 )
- neutron? ( ~sys-cluster/neutron-2016.1.9999 )
- glance? ( ~app-admin/glance-2016.1.9999 )
- cinder? ( ~sys-cluster/cinder-2016.1.9999 )
- nova? ( ~sys-cluster/nova-2016.1.9999 )"
diff --git a/sys-cluster/openstack-meta/openstack-meta-2016.2.9999.ebuild b/sys-cluster/openstack-meta/openstack-meta-2016.2.9999.ebuild
index 6e11d28d3c8c..d857a5f9b151 100644
--- a/sys-cluster/openstack-meta/openstack-meta-2016.2.9999.ebuild
+++ b/sys-cluster/openstack-meta/openstack-meta-2016.2.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,7 +14,7 @@ IUSE="cinder glance heat keystone neutron nova swift"
DEPEND=""
RDEPEND="
keystone? ( ~sys-auth/keystone-${PV} )
- swift? ( || ( ~sys-cluster/swift-2.9.0 ~sys-cluster/swift-2.10.0 ) )
+ swift? ( ~sys-cluster/swift-2.10.0 )
neutron? ( ~sys-cluster/neutron-${PV} )
glance? ( ~app-admin/glance-${PV} )
cinder? ( ~sys-cluster/cinder-${PV} )
diff --git a/www-apache/mod_gnutls/mod_gnutls-0.8.2-r1.ebuild b/www-apache/mod_gnutls/mod_gnutls-0.8.2-r1.ebuild
index 9be94a7ac4d7..f8664b4985e3 100644
--- a/www-apache/mod_gnutls/mod_gnutls-0.8.2-r1.ebuild
+++ b/www-apache/mod_gnutls/mod_gnutls-0.8.2-r1.ebuild
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
-CDEPEND=">=net-libs/gnutls-3.4.0:="
+CDEPEND=">=net-libs/gnutls-3.3.0:="
DEPEND="${CDEPEND}
test? ( app-crypt/monkeysphere )"
RDEPEND="${CDEPEND}"
diff --git a/www-apps/icingaweb2/icingaweb2-2.4.1-r1.ebuild b/www-apps/icingaweb2/icingaweb2-2.4.1-r1.ebuild
new file mode 100644
index 000000000000..9c54138b2b4f
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.4.1-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit depend.apache eutils multilib user
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 ldap mysql nginx pdf postgres"
+REQUIRED_USE="^^ ( apache2 nginx )"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-php/pecl-imagick
+ pdf? ( media-gfx/imagemagick[png] )
+ apache2? (
+ >=www-servers/apache-2.4.0
+ || (
+ dev-lang/php:5.6[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.0[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.1[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ )
+ nginx? (
+ >=www-servers/nginx-1.7.0:*
+ || (
+ dev-lang/php:5.6[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.0[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.1[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ )"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ enewgroup icingaweb2
+ enewgroup icingacmd
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}
diff --git a/www-apps/icingaweb2/icingaweb2-9999.ebuild b/www-apps/icingaweb2/icingaweb2-9999.ebuild
index 693ad5ef3a6f..77eb59b174d2 100644
--- a/www-apps/icingaweb2/icingaweb2-9999.ebuild
+++ b/www-apps/icingaweb2/icingaweb2-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
-inherit depend.apache eutils git-2 multilib user
+inherit depend.apache eutils git-r3 multilib user
DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
HOMEPAGE="http://www.icinga.org/"
@@ -22,17 +22,17 @@ DEPEND=">=net-analyzer/icinga2-2.1.1
apache2? (
>=www-servers/apache-2.4.0
|| (
- dev-lang/php:5.6[apache2?,cli,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
- dev-lang/php:7.0[apache2?,cli,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
- dev-lang/php:7.1[apache2?,cli,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:5.6[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.0[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.1[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
)
)
nginx? (
>=www-servers/nginx-1.7.0:*
|| (
- dev-lang/php:5.6[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
- dev-lang/php:7.0[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
- dev-lang/php:7.1[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:5.6[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.0[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.1[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
)
)"
RDEPEND="${DEPEND}"