summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-14 21:49:35 +0000
committerSam James <sam@gentoo.org>2022-05-14 21:49:49 +0000
commit5e5b47da8f273d33e6925688c794be2332ab5142 (patch)
treebc96076d3515f970517e46d35c49aa031f622055
parentapp-editors/emacs: Stabilize 28.1 x86, #844181 (diff)
downloadgentoo-5e5b47da8f273d33e6925688c794be2332ab5142.tar.gz
gentoo-5e5b47da8f273d33e6925688c794be2332ab5142.tar.bz2
gentoo-5e5b47da8f273d33e6925688c794be2332ab5142.zip
dev-db/mongodb: fix build with Boost 1.79 (for Mongo 4.4.10)
Closes: https://bugs.gentoo.org/843290 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-db/mongodb/files/mongodb-4.4.10-boost-1.79.patch84
-rw-r--r--dev-db/mongodb/mongodb-4.4.10-r1.ebuild5
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-db/mongodb/files/mongodb-4.4.10-boost-1.79.patch b/dev-db/mongodb/files/mongodb-4.4.10-boost-1.79.patch
new file mode 100644
index 000000000000..df7dbc001b05
--- /dev/null
+++ b/dev-db/mongodb/files/mongodb-4.4.10-boost-1.79.patch
@@ -0,0 +1,84 @@
+diff --git a/src/mongo/db/auth/security_key_test.cpp b/src/mongo/db/auth/security_key_test.cpp
+index fc1787b5..70b977c1 100644
+--- a/src/mongo/db/auth/security_key_test.cpp
++++ b/src/mongo/db/auth/security_key_test.cpp
+@@ -30,6 +30,7 @@
+ #include "mongo/platform/basic.h"
+
+ #include <boost/filesystem.hpp>
++#include <boost/filesystem/fstream.hpp>
+
+ #include "mongo/base/string_data.h"
+ #include "mongo/db/auth/authorization_manager.h"
+diff --git a/src/mongo/db/storage/storage_repair_observer.cpp b/src/mongo/db/storage/storage_repair_observer.cpp
+index 22b76a6a..ec5bcece 100644
+--- a/src/mongo/db/storage/storage_repair_observer.cpp
++++ b/src/mongo/db/storage/storage_repair_observer.cpp
+@@ -41,6 +41,7 @@
+ #include <sys/types.h>
+ #endif
+
++#include <boost/filesystem/fstream.hpp>
+ #include <boost/filesystem/path.hpp>
+
+ #include "mongo/db/dbhelpers.h"
+diff --git a/src/mongo/db/storage/wiredtiger/wiredtiger_kv_engine_test.cpp b/src/mongo/db/storage/wiredtiger/wiredtiger_kv_engine_test.cpp
+index 01bb7806..78c15609 100644
+--- a/src/mongo/db/storage/wiredtiger/wiredtiger_kv_engine_test.cpp
++++ b/src/mongo/db/storage/wiredtiger/wiredtiger_kv_engine_test.cpp
+@@ -34,6 +34,7 @@
+ #include "mongo/db/storage/kv/kv_engine_test_harness.h"
+
+ #include <boost/filesystem.hpp>
++#include <boost/filesystem/fstream.hpp>
+ #include <boost/filesystem/path.hpp>
+ #include <memory>
+
+diff --git a/src/mongo/db/storage/wiredtiger/wiredtiger_util.cpp b/src/mongo/db/storage/wiredtiger/wiredtiger_util.cpp
+index 58e85385..0f8a5148 100644
+--- a/src/mongo/db/storage/wiredtiger/wiredtiger_util.cpp
++++ b/src/mongo/db/storage/wiredtiger/wiredtiger_util.cpp
+@@ -36,6 +36,7 @@
+ #include <limits>
+
+ #include <boost/filesystem.hpp>
++#include <boost/filesystem/fstream.hpp>
+ #include <boost/filesystem/path.hpp>
+
+ #include "mongo/base/simple_string_data_comparator.h"
+diff --git a/src/mongo/shell/shell_utils_extended.cpp b/src/mongo/shell/shell_utils_extended.cpp
+index 8cd7f035..cd672eb5 100644
+--- a/src/mongo/shell/shell_utils_extended.cpp
++++ b/src/mongo/shell/shell_utils_extended.cpp
+@@ -37,6 +37,7 @@
+ #endif
+
+ #include <boost/filesystem.hpp>
++#include <boost/filesystem/fstream.hpp>
+ #include <fstream>
+
+ #include "mongo/bson/bson_validate.h"
+diff --git a/src/mongo/util/processinfo_linux.cpp b/src/mongo/util/processinfo_linux.cpp
+index de4b84bc..b01fa7a2 100644
+--- a/src/mongo/util/processinfo_linux.cpp
++++ b/src/mongo/util/processinfo_linux.cpp
+@@ -36,6 +36,7 @@
+ #include <iostream>
+ #include <malloc.h>
+ #include <pcrecpp.h>
++#include <fstream>
+ #include <sched.h>
+ #include <stdio.h>
+ #include <sys/mman.h>
+diff --git a/src/mongo/util/stacktrace_threads.cpp b/src/mongo/util/stacktrace_threads.cpp
+index 4667a261..73a36015 100644
+--- a/src/mongo/util/stacktrace_threads.cpp
++++ b/src/mongo/util/stacktrace_threads.cpp
+@@ -36,6 +36,7 @@
+ #include <array>
+ #include <atomic>
+ #include <boost/filesystem.hpp>
++#include <boost/filesystem/fstream.hpp>
+ #include <cctype>
+ #include <cstdint>
+ #include <cstdlib>
diff --git a/dev-db/mongodb/mongodb-4.4.10-r1.ebuild b/dev-db/mongodb/mongodb-4.4.10-r1.ebuild
index a110d8e1be17..aa4c846908a2 100644
--- a/dev-db/mongodb/mongodb-4.4.10-r1.ebuild
+++ b/dev-db/mongodb/mongodb-4.4.10-r1.ebuild
@@ -58,6 +58,7 @@ PATCHES=(
"${FILESDIR}/${PN}-4.4.1-boost.patch"
"${FILESDIR}/${PN}-4.4.1-gcc11.patch"
"${FILESDIR}/${PN}-5.0.2-glibc-2.34.patch"
+ "${FILESDIR}/${PN}-4.4.10-boost-1.79.patch"
)
S="${WORKDIR}/${MY_P}"
@@ -121,6 +122,10 @@ src_configure() {
use lto && scons_opts+=( --lto=on )
use ssl && scons_opts+=( --ssl )
+ # Needed to avoid forcing FORTIFY_SOURCE
+ # Gentoo's toolchain applies these anyway
+ scons_opts+=( --runtime-hardening=off )
+
# respect mongoDB upstream's basic recommendations
# see bug #536688 and #526114
if ! use debug; then