summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-07-08 08:13:56 -0500
committerBen Kohler <bkohler@gentoo.org>2023-07-08 13:41:40 -0500
commit4785682b90d67f3062d084f1a07152301e8bd7be (patch)
tree6767110e5f446386ce056f95abda1dd86944d380
parentapp-admin/xkcdpass: update EAPI 7 -> 8, use PEP517 build (diff)
downloadgentoo-4785682b90d67f3062d084f1a07152301e8bd7be.tar.gz
gentoo-4785682b90d67f3062d084f1a07152301e8bd7be.tar.bz2
gentoo-4785682b90d67f3062d084f1a07152301e8bd7be.zip
dev-python/path-and-address: update EAPI 7 -> 8, use PEP517 build
Closes: https://bugs.gentoo.org/909926 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--dev-python/path-and-address/path-and-address-2.0.1-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/path-and-address/path-and-address-2.0.1-r1.ebuild b/dev-python/path-and-address/path-and-address-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..f6f7f08dd053
--- /dev/null
+++ b/dev-python/path-and-address/path-and-address-2.0.1-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+PYPI_NO_NORMALIZE=1
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Functions for server CLI applications used by humans"
+HOMEPAGE="https://github.com/joeyespo/path-and-address"
+LICENSE="MIT"
+
+SLOT="0"
+SRC_URI="$(pypi_sdist_url --no-normalize ${PN} ${PV} .zip)"
+
+KEYWORDS="~amd64"
+
+BDEPEND="app-arch/unzip"