summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-09 13:57:56 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-09 13:57:56 +0200
commit45ba9bad940dc95121cb082d5dacd4b4a0cddc86 (patch)
treef66e239e71d627951defac1a8a331e6ab617b7a1
parentsci-geosciences/gtk-g-rays2: Drop old (diff)
downloadgentoo-45ba9bad940dc95121cb082d5dacd4b4a0cddc86.tar.gz
gentoo-45ba9bad940dc95121cb082d5dacd4b4a0cddc86.tar.bz2
gentoo-45ba9bad940dc95121cb082d5dacd4b4a0cddc86.zip
gnome-extra/gucharmap: Bump eapi and update ebuild
Package-Manager: portage-2.3.1
-rw-r--r--gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild47
1 files changed, 23 insertions, 24 deletions
diff --git a/gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild b/gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild
index 4c578c79d3fb..e08d151bbc24 100644
--- a/gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild
+++ b/gnome-extra/gucharmap/gucharmap-3.0.1-r200.ebuild
@@ -1,57 +1,56 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
-GCONF_DEBUG="yes"
+EAPI=6
GNOME2_LA_PUNT="yes"
GNOME_TARBALL_SUFFIX="bz2"
inherit gnome2
DESCRIPTION="Unicode character map viewer library"
-HOMEPAGE="https://live.gnome.org/Gucharmap"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="cjk doc +introspection"
+IUSE="cjk debug doc +introspection"
-RDEPEND=">=dev-libs/glib-2.16.3:2
+RDEPEND="
+ >=dev-libs/glib-2.16.3:2
>=x11-libs/pango-1.2.1[introspection?]
>=x11-libs/gtk+-2.14.0:2[introspection?]
-
- introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0:= )
+"
DEPEND="${RDEPEND}
- app-text/scrollkeeper
- virtual/pkgconfig
+ dev-util/gtk-doc-am
>=dev-util/intltool-0.40
-
sys-devel/gettext
-
- doc? ( >=dev-util/gtk-doc-1.0 )"
+ virtual/pkgconfig
+"
src_prepare() {
- G2CONF="${G2CONF}
- --disable-static
- --with-gtk=2.0
- --disable-charmap
- --disable-gconf
- $(use_enable introspection)
- $(use_enable cjk unihan)"
- # gconf is only needed for the gucharmap program
- DOCS="AUTHORS ChangeLog NEWS README TODO"
-
# .desktop and schema files are only needed for the gucharmap program
sed -e 's:desktop_DATA\s*=.*:desktop_DATA = :' \
-e 's:schema_DATA\s*=.*:schema_DATA = :' \
-i Makefile.* || die "sed Makefile.* failed"
- epatch "${FILESDIR}/${PN}-3.4.1.1-fix-doc.patch" # bug 436710, fixed in 3.6
+ eapply "${FILESDIR}/${PN}-3.4.1.1-fix-doc.patch" # bug 436710, fixed in 3.6
gnome2_src_prepare
}
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-gtk=2.0 \
+ --disable-charmap \
+ --disable-gconf \
+ $(use_enable cjk unihan) \
+ $(use_enable debug) \
+ $(use_enable introspection)
+}
+
pkg_postinst() {
gnome2_pkg_postinst
if ! has_version "gnome-extra/gucharmap:2.90" ; then