summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-02-25 16:08:04 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-02-25 16:08:04 +0000
commit396cf51f44a505d02344bad2fa34b43fc00d957f (patch)
treec514cd7582bfbf7828051a71cee5a559b00f47ff
parent2022-02-25 15:07:03 UTC (diff)
parentdev-python/ipykernel: Bump to 6.9.1 (diff)
downloadgentoo-396cf51f44a505d02344bad2fa34b43fc00d957f.tar.gz
gentoo-396cf51f44a505d02344bad2fa34b43fc00d957f.tar.bz2
gentoo-396cf51f44a505d02344bad2fa34b43fc00d957f.zip
Merge updates from master
-rw-r--r--dev-python/ipykernel/Manifest1
-rw-r--r--dev-python/ipykernel/ipykernel-6.6.1.ebuild8
-rw-r--r--dev-python/ipykernel/ipykernel-6.9.1.ebuild70
-rw-r--r--eclass/distutils-r1.eclass22
-rw-r--r--eclass/python-any-r1.eclass8
-rw-r--r--eclass/verify-sig.eclass6
-rw-r--r--sys-auth/seatd/Manifest2
-rw-r--r--sys-auth/seatd/seatd-0.5.0-r1.ebuild53
-rw-r--r--sys-auth/seatd/seatd-0.5.0.ebuild48
-rw-r--r--sys-auth/seatd/seatd-0.6.2-r1.ebuild57
10 files changed, 104 insertions, 171 deletions
diff --git a/dev-python/ipykernel/Manifest b/dev-python/ipykernel/Manifest
index bccd4984844e..ed7218e3531e 100644
--- a/dev-python/ipykernel/Manifest
+++ b/dev-python/ipykernel/Manifest
@@ -1 +1,2 @@
DIST ipykernel-6.6.1.tar.gz 123915 BLAKE2B 136a3acdea6790d4666c3f5b0d040a91be405ff35e510456d920d0d2d2fb4f4076eb8e74089d08c42f0eba50caa48da929c1a684ad414919a67748f13d6fdf78 SHA512 bfe37f3d69c9b05f9bbbdec7f2103c353433b402474507a9d17c02f224e3a80eaea010b5a8bcebfd4410fbba661feae74107a4904c0af7835c6c1aa6bd0c1159
+DIST ipykernel-6.9.1.tar.gz 127244 BLAKE2B 13f3860f4d565bb4b362841bdcdd81ed5e3284ca6b4750c491cf5895d09fa1a1671acc8529066355cf2f549f89099dfaf8024281ab445b5db0e5ae52062c36d4 SHA512 5c977b01068153762817a372a20e8f3c7055f1cca16d4a4a03f73f4d9c5ce78597a106a4d153fd04dc601129fd8e1993d686e8ff6e299c2169a9d6f1272de58a
diff --git a/dev-python/ipykernel/ipykernel-6.6.1.ebuild b/dev-python/ipykernel/ipykernel-6.6.1.ebuild
index 0c8dcaed30e2..d87d63c16af8 100644
--- a/dev-python/ipykernel/ipykernel-6.6.1.ebuild
+++ b/dev-python/ipykernel/ipykernel-6.6.1.ebuild
@@ -49,6 +49,14 @@ PATCHES=(
distutils_enable_tests pytest
+EPYTEST_DESELECT=(
+ # TODO
+ ipykernel/tests/test_debugger.py::test_attach_debug
+ ipykernel/tests/test_debugger.py::test_set_breakpoints
+ ipykernel/tests/test_debugger.py::test_rich_inspect_not_at_breakpoint
+ ipykernel/tests/test_debugger.py::test_rich_inspect_at_breakpoint
+)
+
src_prepare() {
sed -i -e 's:^TIMEOUT = .*:TIMEOUT = 120:' ipykernel/tests/*.py || die
distutils-r1_src_prepare
diff --git a/dev-python/ipykernel/ipykernel-6.9.1.ebuild b/dev-python/ipykernel/ipykernel-6.9.1.ebuild
new file mode 100644
index 000000000000..8c593a257ad4
--- /dev/null
+++ b/dev-python/ipykernel/ipykernel-6.9.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython Kernel for Jupyter"
+HOMEPAGE="https://github.com/ipython/ipykernel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/debugpy-1.0.0[${PYTHON_USEDEP}]
+ <dev-python/debugpy-2.0[${PYTHON_USEDEP}]
+ >=dev-python/ipython-7.23.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1.0[${PYTHON_USEDEP}]
+ <dev-python/traitlets-6.0[${PYTHON_USEDEP}]
+ <dev-python/jupyter_client-8.0[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.2[${PYTHON_USEDEP}]
+ <www-servers/tornado-7.0[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-inline-0.1.0[${PYTHON_USEDEP}]
+ <dev-python/matplotlib-inline-0.2.0[${PYTHON_USEDEP}]
+ dev-python/nest_asyncio[${PYTHON_USEDEP}]
+"
+# RDEPEND seems specifically needed in BDEPEND, at least jupyter
+# bug #816486
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose_warnings_filters[${PYTHON_USEDEP}]
+ dev-python/ipyparallel[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.5.0-drop-pytest-cov.patch
+)
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ ipykernel/tests/test_debugger.py::test_attach_debug
+ ipykernel/tests/test_debugger.py::test_set_breakpoints
+ ipykernel/tests/test_debugger.py::test_stop_on_breakpoint
+ ipykernel/tests/test_debugger.py::test_breakpoint_in_cell_with_leading_empty_lines
+ ipykernel/tests/test_debugger.py::test_rich_inspect_not_at_breakpoint
+ ipykernel/tests/test_debugger.py::test_rich_inspect_at_breakpoint
+)
+
+src_prepare() {
+ sed -i -e 's:^TIMEOUT = .*:TIMEOUT = 120:' ipykernel/tests/*.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ # Use python3 in kernel.json configuration, bug #784764
+ sed -i -e '/python3.[0-9]\+/s//python3/' \
+ "${BUILD_DIR}/install${EPREFIX}/usr/share/jupyter/kernels/python3/kernel.json" || die
+}
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index f0059d2756bf..4ce666eee902 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -82,11 +82,16 @@ esac
# @PRE_INHERIT
# @DEFAULT_UNSET
# @DESCRIPTION:
-# Enable experimental PEP 517 mode for the specified build system.
-# In this mode, the complete build and install is done
-# in python_compile(), venv-style install tree is provided
-# to python_test() and python_install() just merges the temporary
-# install tree into real fs.
+# Enable the PEP 517 mode for the specified build system. In this mode,
+# the complete build and install is done in python_compile(),
+# a venv-style install tree is provided to python_test(),
+# and python_install() just merges the temporary install tree
+# into the real fs.
+#
+# This mode is recommended for Python packages. However, some packages
+# using custom hacks on top of distutils/setuptools may not install
+# correctly in this mode. Please verify the list of installed files
+# when using it.
#
# The variable specifies the build system used. Currently,
# the following values are supported:
@@ -934,10 +939,13 @@ _distutils-r1_get_backend() {
# if pyproject.toml exists, try getting the backend from it
# NB: this could fail if pyproject.toml doesn't list one
build_backend=$(
- "${EPYTHON}" - <<-EOF 2>/dev/null
+ "${EPYTHON}" - 3>&1 <<-EOF
+ import os
import tomli
print(tomli.load(open("pyproject.toml", "rb"))
- ["build-system"]["build-backend"])
+ .get("build-system", {})
+ .get("build-backend", ""),
+ file=os.fdopen(3, "w"))
EOF
)
fi
diff --git a/eclass/python-any-r1.eclass b/eclass/python-any-r1.eclass
index 4e954f57cd2d..805981bb7aa8 100644
--- a/eclass/python-any-r1.eclass
+++ b/eclass/python-any-r1.eclass
@@ -302,9 +302,11 @@ python_setup() {
local epython_impl=${EPYTHON/./_}
if [[ ${epython_impl} ]]; then
if ! has "${epython_impl}" "${_PYTHON_SUPPORTED_IMPLS[@]}"; then
- einfo "EPYTHON (${EPYTHON}) not supported by the package"
- elif ! has "${epython_impl}" "${_PYTHON_ALL_IMPLS[@]}"; then
- ewarn "Invalid EPYTHON: ${EPYTHON}"
+ if ! has "${epython_impl}" "${_PYTHON_ALL_IMPLS[@]}"; then
+ ewarn "Invalid EPYTHON: ${EPYTHON}"
+ else
+ einfo "EPYTHON (${EPYTHON}) not supported by the package"
+ fi
elif _python_run_check_deps "${epython_impl}"; then
_python_export EPYTHON PYTHON
_python_wrapper_setup
diff --git a/eclass/verify-sig.eclass b/eclass/verify-sig.eclass
index 9121d85bbeaf..dadfd456e101 100644
--- a/eclass/verify-sig.eclass
+++ b/eclass/verify-sig.eclass
@@ -1,4 +1,4 @@
-# Copyright 2020-2021 Gentoo Authors
+# Copyright 2020-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: verify-sig.eclass
@@ -22,6 +22,10 @@
#
# If you need to use signify, you may want to copy distfiles into WORKDIR to
# work around "Too many levels of symbolic links" error.
+#
+# A more complete guide can be found at:
+# https://mgorny.pl/articles/verify-sig-by-example.html
+#
# @EXAMPLE:
# Example use:
#
diff --git a/sys-auth/seatd/Manifest b/sys-auth/seatd/Manifest
index 9419af2c6ac5..071f4ce2188e 100644
--- a/sys-auth/seatd/Manifest
+++ b/sys-auth/seatd/Manifest
@@ -1,4 +1,2 @@
-DIST seatd-0.5.0.tar.gz 34762 BLAKE2B 054bd64800b734f6092f856540217e5ea4872c5a363960bac6c5aa7dac5355bdbd982232efd2f8078ad326ec0e6257f3ee7643384c88a3bbe15255d65f02540c SHA512 a6b1f11313411fe99e8bdd64aa493fc19bde7b0b927f21e2c3ec8a7fadc6cf2f04fcefa73fa033d971d1dc482665d3dc927ec168026289fe88b2593a45adbc0f
-DIST seatd-0.6.2.tar.gz 37713 BLAKE2B 001c6269bcc83488099f9237a3412b61f89cf653fcb5b0d1ada3f5fbdb17ec604d881ce3d835ff1ea3bc683bb143bab75de88d67b55f508e6a9dd2e958347567 SHA512 47e3aec819f43e72913be1cac2c0db26287f1ef8ecc738845d3591b3e2b4fee3441ac50ea45ac75a5da774e5305a18a02b8375f76f71644c8c07e95bcad52762
DIST seatd-0.6.3.tar.gz 38525 BLAKE2B e1bdb85f9432a9a407ea7a72ed5790debf01a410546e9162641ab55179b3beefba0eb45fd24e2643dc5cfb2a26db2490f49095ff1d08b4a38663f93e46dc2ed5 SHA512 28c979e8c2fc73a8607c6085f2e27dc6e2630bc874f98686ce22aa797e74fdad1cc9fca8649eaf8920e93f01a852fbe209bde86ebf582e81060d4ca015425815
DIST seatd-0.6.4.tar.gz 38393 BLAKE2B 2d01dbf00846c311daa3b4ac2bf87e818c722fa38e84b4cf83470803c23f779f12e4efe922f0b09ec8ef35ca913178a7f76bcded75dd7f7a7431e3a838c6bcc6 SHA512 0e2b23eca2e7978e3f914433caa6f84243a20487c6fe9fe3e42a7bf663a4a0872482aa334a3f5dc9b6625c565b408c3c78310b5575b9fb2e2919efdb9620ec57
diff --git a/sys-auth/seatd/seatd-0.5.0-r1.ebuild b/sys-auth/seatd/seatd-0.5.0-r1.ebuild
deleted file mode 100644
index 4e1943599a35..000000000000
--- a/sys-auth/seatd/seatd-0.5.0-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson systemd
-
-DESCRIPTION="Minimal seat management daemon and universal library"
-HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
-else
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
- SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-LICENSE="MIT"
-SLOT="0/1"
-IUSE="builtin elogind +server systemd"
-REQUIRED_USE="?? ( elogind systemd )"
-
-DEPEND="
- elogind? ( sys-auth/elogind )
- systemd? ( sys-apps/systemd )
-"
-RDEPEND="${DEPEND}"
-BDEPEND=">=app-text/scdoc-1.9.7"
-
-src_configure() {
- local emesonargs=(
- -Dman-pages=enabled
- -Dwerror=false
- $(meson_feature builtin)
- $(meson_feature server)
- )
-
- if use elogind || use systemd; then
- emesonargs+=( -Dlogind=enabled )
- else
- emesonargs+=( -Dlogind=disabled )
- fi
-
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
-
- if use server; then
- newinitd "${FILESDIR}/seatd.initd" seatd
- systemd_dounit contrib/systemd/seatd.service
- fi
-}
diff --git a/sys-auth/seatd/seatd-0.5.0.ebuild b/sys-auth/seatd/seatd-0.5.0.ebuild
deleted file mode 100644
index c5affa2fcc9a..000000000000
--- a/sys-auth/seatd/seatd-0.5.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson systemd
-
-DESCRIPTION="Minimal seat management daemon and universal library"
-HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
-else
- KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
- SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-LICENSE="MIT"
-SLOT="0/1"
-IUSE="elogind systemd"
-REQUIRED_USE="?? ( elogind systemd )"
-
-DEPEND="
- elogind? ( sys-auth/elogind )
- systemd? ( sys-apps/systemd )
-"
-RDEPEND="${DEPEND}"
-BDEPEND=">=app-text/scdoc-1.9.7"
-
-src_configure() {
- local emesonargs=(
- -Dman-pages=enabled
- -Dwerror=false
- )
-
- if use elogind || use systemd; then
- emesonargs+=( -Dlogind=enabled )
- else
- emesonargs+=( -Dlogind=disabled )
- fi
-
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- newinitd "${FILESDIR}/seatd.initd" seatd
- systemd_dounit contrib/systemd/seatd.service
-}
diff --git a/sys-auth/seatd/seatd-0.6.2-r1.ebuild b/sys-auth/seatd/seatd-0.6.2-r1.ebuild
deleted file mode 100644
index 2c8b264374b9..000000000000
--- a/sys-auth/seatd/seatd-0.6.2-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit meson systemd
-
-DESCRIPTION="Minimal seat management daemon and universal library"
-HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
-else
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
- SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-LICENSE="MIT"
-SLOT="0/1"
-IUSE="builtin elogind +server systemd"
-REQUIRED_USE="?? ( elogind systemd )"
-
-DEPEND="
- elogind? ( sys-auth/elogind )
- systemd? ( sys-apps/systemd )
-"
-RDEPEND="${DEPEND}
- server? ( acct-group/seat )
-"
-BDEPEND=">=app-text/scdoc-1.9.7"
-
-src_configure() {
- local emesonargs=(
- -Dman-pages=enabled
- -Dwerror=false
- $(meson_feature builtin libseat-builtin)
- $(meson_feature server)
- )
-
- if use elogind ; then
- emesonargs+=( -Dlibseat-logind=elogind )
- elif use systemd; then
- emesonargs+=( -Dlibseat-logind=systemd )
- else
- emesonargs+=( -Dlibseat-logind=disabled )
- fi
-
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
-
- if use server; then
- newinitd "${FILESDIR}/seatd.initd" seatd
- systemd_dounit contrib/systemd/seatd.service
- fi
-}