summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-02-24 03:10:07 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-02-24 04:21:08 +0100
commit30ca123634c8f5a1310fe2466ae1342182deef90 (patch)
tree752f66596a228487ce73d5c4c1ac18606bc29a23
parentdev-python/py: Bump to v1.5.2 (diff)
downloadgentoo-30ca123634c8f5a1310fe2466ae1342182deef90.tar.gz
gentoo-30ca123634c8f5a1310fe2466ae1342182deef90.tar.bz2
gentoo-30ca123634c8f5a1310fe2466ae1342182deef90.zip
dev-python/pytest-flake8: Bump to v0.9.1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-python/pytest-flake8/Manifest1
-rw-r--r--dev-python/pytest-flake8/pytest-flake8-0.9.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-flake8/Manifest b/dev-python/pytest-flake8/Manifest
index cd86caea576d..1360ec299cb1 100644
--- a/dev-python/pytest-flake8/Manifest
+++ b/dev-python/pytest-flake8/Manifest
@@ -1 +1,2 @@
DIST pytest-flake8-0.8.1.tar.gz 7359 BLAKE2B fd45d50fa68e329569a5964407fae301075907aabf0ec2c85c7ad9b9c28aa7a92acfaf9b7b4e06036c940ca6c7a35388cefb0d9b9151471fe98c968a43cf5a95 SHA512 b49b4d42712040492161f144cce807b661f2d8fe5b484b29ad1a519fd5b0b0cfb6abd42c3ae8999f21263c4776fb773f91bf0776971b6b6727607d33fb49ca89
+DIST pytest-flake8-0.9.1.tar.gz 7959 BLAKE2B d0ef55385dbbf47968abdfc14e69a0420cd52bdf65c0f74ec72abeb1ab28ad27806593dd592f448f3c01dcdf29af4042c1e1c8affde46a1405ba7b4155c174a4 SHA512 eeb4f66022e367d92dee94544ae8fa99b79c1de0579a80e91c22e6f050752010cb7ad6c24094736d23ae753615b186a957b8b0f94c09754005183a971a1e4aa1
diff --git a/dev-python/pytest-flake8/pytest-flake8-0.9.1.ebuild b/dev-python/pytest-flake8/pytest-flake8-0.9.1.ebuild
new file mode 100644
index 000000000000..9b0fa3e9c971
--- /dev/null
+++ b/dev-python/pytest-flake8/pytest-flake8-0.9.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for flake8"
+HOMEPAGE="https://github.com/tholo/${PN} https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/flake8-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ pytest -v || die "tests failed with ${EPYTHON}"
+}