summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-02 20:09:34 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-02 20:41:18 +0200
commit230deeaaadc22c1f1cd03043fa76c60db2d09b9b (patch)
tree38ebb6d80042fa6ade756c5d60b80ecd68ff4ef4
parentdev-python/pypy3_9: Bump to 7.3.16_p1 (diff)
downloadgentoo-230deeaaadc22c1f1cd03043fa76c60db2d09b9b.tar.gz
gentoo-230deeaaadc22c1f1cd03043fa76c60db2d09b9b.tar.bz2
gentoo-230deeaaadc22c1f1cd03043fa76c60db2d09b9b.zip
sys-devel/llvm: Fix sanity check w/ USE=-debuginfod
Closes: https://bugs.gentoo.org/937149 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/llvm/llvm-20.0.0.9999.ebuild4
-rw-r--r--sys-devel/llvm/llvm-20.0.0_pre20240801.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/sys-devel/llvm/llvm-20.0.0.9999.ebuild b/sys-devel/llvm/llvm-20.0.0.9999.ebuild
index 9ff1ecc4c46c..8401f1a55543 100644
--- a/sys-devel/llvm/llvm-20.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-20.0.0.9999.ebuild
@@ -154,6 +154,10 @@ check_distribution_components() {
docs-llvm-html)
use doc || continue
;;
+ # used only w/ USE=debuginfd
+ llvm-debuginfod)
+ use debuginfod || continue
+ ;;
esac
all_targets+=( "${l}" )
diff --git a/sys-devel/llvm/llvm-20.0.0_pre20240801.ebuild b/sys-devel/llvm/llvm-20.0.0_pre20240801.ebuild
index 9ff1ecc4c46c..8401f1a55543 100644
--- a/sys-devel/llvm/llvm-20.0.0_pre20240801.ebuild
+++ b/sys-devel/llvm/llvm-20.0.0_pre20240801.ebuild
@@ -154,6 +154,10 @@ check_distribution_components() {
docs-llvm-html)
use doc || continue
;;
+ # used only w/ USE=debuginfd
+ llvm-debuginfod)
+ use debuginfod || continue
+ ;;
esac
all_targets+=( "${l}" )