summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2024-12-02 10:11:06 +0100
committerViorel Munteanu <ceamac@gentoo.org>2024-12-02 18:42:24 +0200
commit17f698c6765bba6fbb337147f488df97f34aa0c6 (patch)
tree586843fcb297d522e0f922c15f3fecacf6f266be
parentwww-apps/rutorrent: update 9999 date in header (diff)
downloadgentoo-17f698c6765bba6fbb337147f488df97f34aa0c6.tar.gz
gentoo-17f698c6765bba6fbb337147f488df97f34aa0c6.tar.bz2
gentoo-17f698c6765bba6fbb337147f488df97f34aa0c6.zip
www-apps/rutorrent: add 5.1.1
Signed-off-by: Henning Schild <henning@hennsch.de> Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--www-apps/rutorrent/Manifest1
-rw-r--r--www-apps/rutorrent/rutorrent-5.1.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
index 5b547dc022b5..cad5c2c0f1d0 100644
--- a/www-apps/rutorrent/Manifest
+++ b/www-apps/rutorrent/Manifest
@@ -1,2 +1,3 @@
DIST rutorrent-4.3.8.tar.gz 2378281 BLAKE2B 74a982e6d2bd9a9961c5d9a36de924c202d3e8f6235846c1961abb6a39818b387ce4814dfc8f8be167f242946ddfb46a691147b166d0b46ebf6c8c1b92068b50 SHA512 dae1984020ae590ab20ce25bcdef0b6f598c8cf30c66b8cf0e860570f78ea1d9dda2f98a2566637c79207fd12d2eafb02b98179fd9e9a138b5495d53081b1d1d
DIST rutorrent-4.3.9.tar.gz 2378293 BLAKE2B 49f38626c69d70d502dcc8c1d9306920069a6072357d7152b8aa52e6de64ab0411948d0177bc973cdaebdfa7ffe6432c8d76683b6f427c5800bdc6b4aa496465 SHA512 5b4b35055a30c0295f693f9a94389e8df63ab234dd1f550a92b47efe2480b124fcac8a539c31ead910e3504feaace31e7bbdff76ddab77e1d268b00dc0a6cef2
+DIST rutorrent-5.1.1.tar.gz 2694677 BLAKE2B 6cca0e9cd0078bc6024e55fc229ab3a392dd269b829be538bd045e861a12d66a77f7ba94fa17cdd4c7b47bb38a460e7961f1b7e1bb569c843cbdc0eb58b320b6 SHA512 59e93390ce189ff08af484add97b922cd002ef4622d0eed012da1263ffcc0850effec4fe4e05c95bcd9a2de24f314895b4b44b8473de629822f7b72195049856
diff --git a/www-apps/rutorrent/rutorrent-5.1.1.ebuild b/www-apps/rutorrent/rutorrent-5.1.1.ebuild
new file mode 100644
index 000000000000..97453fadf5c8
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-5.1.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp optfeature
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="https://github.com/Novik/ruTorrent"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Novik/ruTorrent.git"
+else
+ SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ S="${WORKDIR}/ruTorrent-${PV}"
+fi
+
+LICENSE="GPL-2+ MIT"
+
+RDEPEND="
+ dev-lang/php[xml,gd]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ rm -r .github || die
+ find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
+ if [[ ${PV} == 9999 ]]; then
+ rm -r .git .gitattributes || die
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # can not use fperms beacuse of globbing
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ keepdir "${MY_HTDOCSDIR}"/conf/users
+ keepdir "${MY_HTDOCSDIR}"/share/settings
+ keepdir "${MY_HTDOCSDIR}"/share/torrents
+ keepdir "${MY_HTDOCSDIR}"/share/users
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/share
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "Show audio file spectogram" media-sound/sox
+ optfeature "Display media file information" media-video/mediainfo
+ optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
+}