summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-05 19:37:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-05 20:02:14 +0100
commit126f14c546f257e9c18d7bef7a0d4d22cab528e9 (patch)
tree803b95062b07c41688c5ebca683598711af407a1
parentkde-plasma/plasma-firewall: 6.2.3 version bump (diff)
downloadgentoo-126f14c546f257e9c18d7bef7a0d4d22cab528e9.tar.gz
gentoo-126f14c546f257e9c18d7bef7a0d4d22cab528e9.tar.bz2
gentoo-126f14c546f257e9c18d7bef7a0d4d22cab528e9.zip
kde-plasma/plasma-integration: 6.2.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-6.2.3.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 41b6a2bb5f35..5e777667e586 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-integration-6.1.5.tar.xz 93124 BLAKE2B 7b3e503f412342927ca934a4d2473676b551208fc00a0ce74d1abc7c72bc4ec99204e244f7589106a8f788a78d175923ffc451dde7bdc19eecc9ece13399e32d SHA512 1b5e82484c5a952f58fd93a2a76012331b226981527dc304b70f365abe1c2a2ccbb27b7f6194efe7a42fddfdf42c695d65dccd9e5907ee7a09f98a2c268b5020
DIST plasma-integration-6.2.2.tar.xz 95904 BLAKE2B a9ac23ac32f811f7aff8b094591e2d558f2caf8a43f94cbb0b2e2e8d0a9ad29b9631bb5c970d99db036d04a165c8f0cab812c70b46c8ad3c87649346df7e021e SHA512 dacfc85f96892e0ce082668d5066b943d1b4d97ec9b627b17b663833dc6628408bb2a5fcbcf0e5a04a96f7f56e4156f02f3d0757697c5787cddd2d3e97c43d3b
+DIST plasma-integration-6.2.3.tar.xz 95912 BLAKE2B 4e529a329f9d9e7fb265e0ff989c65e41bcffbb27dcb9988c421ad9c8c45fc877d911dd853cd5c54335e3be4162de83de50f28e8c8a509be368a7a6a9bd92070 SHA512 c88861b5e68ba1a5fdcde6ad2f2f51ae4a85abff7da03aa378f2cf10ad6630272f53d443c109d0f4a3813817ee157e30e94c22f8125126a4907b2c5f02ffda10
diff --git a/kde-plasma/plasma-integration/plasma-integration-6.2.3.ebuild b/kde-plasma/plasma-integration/plasma-integration-6.2.3.ebuild
new file mode 100644
index 000000000000..c5a688372e04
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-6.2.3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KF5MIN=5.115.0
+KFMIN=6.6.0
+PVCUT=$(ver_cut 1-3)
+QT5MIN=5.15.12
+QTMIN=6.7.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+
+LICENSE="LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="qt5"
+
+# requires running kde environment
+RESTRICT="test"
+
+# slot ops: qdbus*_p.h and Qt6::GuiPrivate for qtx11extras_p.h
+COMMON_DEPEND="
+ dev-libs/wayland
+ >=dev-qt/qtbase-${QTMIN}:6=[dbus,gui,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=dev-qt/qtwayland-${QTMIN}:6
+ >=kde-frameworks/kcolorscheme-${KFMIN}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kguiaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kstatusnotifieritem-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ x11-libs/libXcursor
+ x11-libs/libxcb
+ qt5? (
+ >=dev-qt/qtdbus-${QT5MIN}:5
+ >=dev-qt/qtgui-${QT5MIN}:5=[dbus]
+ >=dev-qt/qtquickcontrols2-${QT5MIN}:5
+ >=dev-qt/qtwayland-${QT5MIN}:5
+ >=dev-qt/qtwidgets-${QT5MIN}:5
+ >=dev-qt/qtx11extras-${QT5MIN}:5
+ >=kde-frameworks/kcompletion-${KF5MIN}:5
+ >=kde-frameworks/kconfig-${KF5MIN}:5
+ >=kde-frameworks/kconfigwidgets-${KF5MIN}:5
+ >=kde-frameworks/kcoreaddons-${KF5MIN}:5
+ >=kde-frameworks/kguiaddons-${KF5MIN}:5
+ >=kde-frameworks/ki18n-${KF5MIN}:5
+ >=kde-frameworks/kiconthemes-${KF5MIN}:5
+ >=kde-frameworks/kio-${KF5MIN}:5
+ >=kde-frameworks/kjobwidgets-${KF5MIN}:5
+ >=kde-frameworks/knotifications-${KF5MIN}:5
+ >=kde-frameworks/kwindowsystem-${KF5MIN}:5
+ >=kde-frameworks/kxmlgui-${KF5MIN}:5
+ >=kde-plasma/kwayland-${KF5MIN}:5
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.14.0
+"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+ media-fonts/noto-emoji
+"
+PDEPEND="
+ >=kde-plasma/xdg-desktop-portal-kde-${PVCUT}:6
+"
+BDEPEND="
+ >=dev-qt/qtwayland-${QTMIN}:6
+ qt5? ( >=dev-qt/qtwaylandscanner-${QT5MIN}:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_QT6=ON
+ -DBUILD_QT5=$(usex qt5)
+ )
+ ecm_src_configure
+}