summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-29 04:59:00 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-29 05:01:03 +0200
commit0a8a5c98d8cbe741d4908d0975bd3e9311863add (patch)
tree380f8132e6b14214d531ad38461e6003784b4e69
parentRename dev-python/{nest_asyncio → nest-asyncio} (diff)
downloadgentoo-0a8a5c98d8cbe741d4908d0975bd3e9311863add.tar.gz
gentoo-0a8a5c98d8cbe741d4908d0975bd3e9311863add.tar.bz2
gentoo-0a8a5c98d8cbe741d4908d0975bd3e9311863add.zip
dev-python/nest-asyncio: Bump to 1.5.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nest-asyncio/Manifest1
-rw-r--r--dev-python/nest-asyncio/nest-asyncio-1.5.7.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/nest-asyncio/Manifest b/dev-python/nest-asyncio/Manifest
index 092e8aa8389f..58eab65d12a4 100644
--- a/dev-python/nest-asyncio/Manifest
+++ b/dev-python/nest-asyncio/Manifest
@@ -1 +1,2 @@
DIST nest_asyncio-1.5.6.tar.gz 7444 BLAKE2B 04b5808b3187c1155c440c903f0e1d5593f49204e6ffea2a37dc2b6112a365b94ab80823ce512a4cdf6c0799ef1c18d55fc0a841030a2cb93e0913fdf770f247 SHA512 9672cdd72b2bad7c968fa23c94e8bf8014aabf0aefd79b260503e7fe640cb7649f5c266133a4eb87aedcd99cea644fa51f8cd09d789777aca11eb64e84cf4ca5
+DIST nest_asyncio-1.5.7.tar.gz 7456 BLAKE2B 1ff61ec62a7cc90bbf293fe2190f70dd914fed673e669bf3425116435b69329f4411dc4a37df3b5be825ab8ce3d0be3cebbb3cdc6558f2771aaeef2023c8e036 SHA512 52d0a014487b4addcdc41024ddde41ed32c4b239a4bc19169b81c7553fc2e931c7a3a6848bd11b8937c721282ef2f8c0d2d352ac7852e661a48f046fb2dee2e6
diff --git a/dev-python/nest-asyncio/nest-asyncio-1.5.7.ebuild b/dev-python/nest-asyncio/nest-asyncio-1.5.7.ebuild
new file mode 100644
index 000000000000..42f6ac1eea82
--- /dev/null
+++ b/dev-python/nest-asyncio/nest-asyncio-1.5.7.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Patch asyncio to allow nested event loops"
+HOMEPAGE="
+ https://github.com/erdewit/nest_asyncio/
+ https://pypi.org/project/nest-asyncio/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest