summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-07 02:57:44 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-07 02:57:44 +0200
commit0638b3c545dc46bdd3f8d96c7c15b46103ec74ed (patch)
treec250e91328580369d4b872f0a16fe15d359717ad
parentdev-python/boto3: Bump to 1.34.121 (diff)
downloadgentoo-0638b3c545dc46bdd3f8d96c7c15b46103ec74ed.tar.gz
gentoo-0638b3c545dc46bdd3f8d96c7c15b46103ec74ed.tar.bz2
gentoo-0638b3c545dc46bdd3f8d96c7c15b46103ec74ed.zip
app-admin/awscli: Bump to 1.33.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.33.3.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 2c4a970d609b..33dac8a395e9 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.32.117.gh.tar.gz 2732508 BLAKE2B 699d7596ea0e417f624f72e801d2c6e5
DIST aws-cli-1.33.0.gh.tar.gz 2737941 BLAKE2B 1572e517dd627870611b54bae77bb7c6a3eddcb882af0f18a7da51e302dd4db97609d315416cb0acaa1898e08881779a79f9a22795e99de8aa79577d4b858e61 SHA512 4473b068cfc5848335fbcfa0237f1f00d8bb76cde6936d1f07bc6637c6721c3d6ea0172437fcbc99459a6a2508983d598583c8d80c66573752a80615202abf08
DIST aws-cli-1.33.1.gh.tar.gz 2738329 BLAKE2B 46aea84b6ca6ca43d74bb24236aa3d8b9dbf71ad0197efb349001a6dfebd1d6309c9ed5b37a241a5b472263b2dd6e54a977b32ad2ff387891af863129089c5cc SHA512 2317c1f6c7b8c766ef381401eb45356cc297b35a9fd6431ba38f56f4b9c8e4880d3a71002bdcde088cb71002608c6ea9f15d5d08c50723f1a2f71d389e19408b
DIST aws-cli-1.33.2.gh.tar.gz 2738575 BLAKE2B 0d8ccf9e9831cf43b4dab50a871ebd7e9bc81b769d7742b2ccc4f1cdbb5da4d26b2e3812004642222d2ba1e7fe2734426edca731afe64b17d1f5ef1a144b485a SHA512 ca1cf2e18b6bcb99741fc62fa1d78850bc74bb68b3896b4f8c97f5f10d9d8758f4826d388b1ad38615071331a67274798e57bee1f95e385c4a5076a94b6640c0
+DIST aws-cli-1.33.3.gh.tar.gz 2739705 BLAKE2B 5b486d4028b4e3963a1dccf714d2beb2cd7438efbcea09a96b6c383717586da24afcbfbb6bb84a40bbafb8c82e7feb6fad51dc10396fe8ac6460c38198e419f6 SHA512 46b468791d9d14689fe59afaab037be88989a1772bfe8c43d890a7cb262ea77e0560550e4b8136aa6689f2ebeaa73e06e36ded1c2340dc62da97fa14a795bb8f
diff --git a/app-admin/awscli/awscli-1.33.3.ebuild b/app-admin/awscli/awscli-1.33.3.ebuild
new file mode 100644
index 000000000000..a7a293c4a8e8
--- /dev/null
+++ b/app-admin/awscli/awscli-1.33.3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+1).(z+118), sigh
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1 )).$(( $(ver_cut 3-) + 118 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}