summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYifeng Li <tomli@tomli.me>2023-02-18 22:29:10 +0000
committerSam James <sam@gentoo.org>2023-02-19 18:53:03 +0000
commit5ceb16d0ba609a4d29d5eccf24b01b2942a16a98 (patch)
tree30038fc137ace5e41500e65103e653069583c5dc /sys-devel
parent*/*: add ~arm64-macos (diff)
downloadprefix-5ceb16d0ba609a4d29d5eccf24b01b2942a16a98.tar.gz
prefix-5ceb16d0ba609a4d29d5eccf24b01b2942a16a98.tar.bz2
prefix-5ceb16d0ba609a4d29d5eccf24b01b2942a16a98.zip
sys-devel/gcc-12.2.0: mask macOS, it's broken.
When bootstrapping Gentoo Prefix on macOS 13.2 (Ventura) on an Apple M1 system, it will fail at stage2 due to a sys-devel/gcc-12.2.0 build failure. make[3]: Entering directory '/Users/leo/Gentoo/tmp/var/tmp/portage/sys-devel/gcc-12.2.0/work/build/libcc1' /Users/leo/Gentoo/tmp/bin/bash ./libtool --tag=CXX --mode=link g++ -m64 -std=gnu++11 -W -Wall -fvisibility=hidden -Wl,-undefined,dynamic_lookup -I/Users/leo/Gentoo/tmp/usr/include -pipe -O2 -module -export-symbols /Users/leo/Gentoo/tmp/var/tmp/portage/sys-devel/gcc-12.2.0/work/gcc-12-branch-gcc-12.2-darwin-r0/libcc1/libcc1.sym -Wc,-nodefaultrpaths,-nodefaultexport -Wl,-rpath,@loader_path '-Wl,-search_paths_first' '-L/Users/leo/Gentoo/tmp/usr/lib' -o libcc1.la -rpath /Users/leo/Gentoo/tmp/usr/lib/ findcomp.lo libcc1.lo libcp1.lo compiler.lo names.lo callbacks.lo connection.lo marshall.lo -Wc,../libiberty/pic/libiberty.a libtool: link: sed -e 's,^,_,' < /Users/leo/Gentoo/tmp/var/tmp/portage/sys-devel/gcc-12.2.0/work/gcc-12-branch-gcc-12.2-darwin-r0/libcc1/libcc1.sym > .libs/libcc1-symbols.expsym libtool: link: g++ -m64 -std=gnu++11 -o .libs/libcc1.0.so -bundle .libs/findcomp.o .libs/libcc1.o .libs/libcp1.o .libs/compiler.o .libs/names.o .libs/callbacks.o .libs/connection.o .libs/marshall.o -L/Users/leo/Gentoo/tmp/usr/lib -m64 -Wl,-undefined -Wl,dynamic_lookup -nodefaultrpaths -nodefaultexport -Wl,-rpath -Wl,@loader_path -Wl,-search_paths_first ../libiberty/pic/libiberty.a -Wl,-exported_symbols_list,.libs/libcc1-symbols.expsym clang: error: unknown argument: '-nodefaultrpaths' clang: error: unknown argument: '-nodefaultexport' make[3]: *** [Makefile:576: libcc1.la] Error 1 make[3]: Leaving directory '/Users/leo/Gentoo/tmp/var/tmp/portage/sys-devel/gcc-12.2.0/work/build/libcc1' make[3]: *** Waiting for unfinished jobs.... Currently, both sys-devel/gcc-12.1.0 and sys-devel/gcc-12.2.0 have problems. However, sys-devel/gcc-12.1.0 can be fixed after applying two patches, as I've described in Bug #895332 [1]. Meanwhile, the solution of this sys-devel/gcc-12.2.0 bug [2] is unclear. This commit masks sys-devel/gcc-12.2.0 on macOS for now until someone finishes investigation of the issue. Meanwhile, we can fix sys-devel/gcc-12.1.0 according to Bug #895332. It would allow a successful bootstrap on macOS 13.2. P.S: although the KEYWORDS says ~x64-macos, it's actually also controlling the behavior of ~arm64-macos as well. [1] https://bugs.gentoo.org/895332 [2] https://bugs.gentoo.org/895334 Bug: https://bugs.gentoo.org/895334 Signed-off-by: Yifeng Li <tomli@tomli.me> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-12.2.0.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-devel/gcc/gcc-12.2.0.ebuild b/sys-devel/gcc/gcc-12.2.0.ebuild
index 24b6f17fa0..20a8ca2ca6 100644
--- a/sys-devel/gcc/gcc-12.2.0.ebuild
+++ b/sys-devel/gcc/gcc-12.2.0.ebuild
@@ -15,7 +15,7 @@ inherit toolchain
if ! tc_is_live && [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
# fails to compile on Solaris and macOS, need to check why
: KEYWORDS="~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- KEYWORDS="~x64-macos ~x64-solaris ~x86-solaris"
+ KEYWORDS="~x64-solaris ~x86-solaris"
fi
# use alternate source for Apple M1 (also works for x86_64)