aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/nheko/nheko-9999.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/net-im/nheko/nheko-9999.ebuild b/net-im/nheko/nheko-9999.ebuild
index b8c1fc4..a136a47 100644
--- a/net-im/nheko/nheko-9999.ebuild
+++ b/net-im/nheko/nheko-9999.ebuild
@@ -27,20 +27,30 @@ RDEPEND=">=dev-qt/qtgui-5.7.1
media-libs/fontconfig
app-text/cmark
dev-libs/tweeny
- dev-db/lmdb++"
+ dev-db/lmdb++
+ "
DEPEND="${RDEPEND}
>=dev-qt/linguist-tools-5.7.1
dev-util/ninja
- >=dev-libs/mtxclient-0.3.0"
+ >=dev-libs/mtxclient-0.3.0
+ dev-libs/spdlog
+ "
CMAKE_BUILD_TYPE=Release
-src_prepare ()
+src_prepare()
{
sed -i '/-Werror/d' CMakeLists.txt || die
cmake-utils_src_prepare
}
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_CXX_STANDARD=17
+ )
+ cmake-utils_src_configure
+}
+
pkg_postinst() {
xdg_desktop_database_update
}