aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-15 16:40:00 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-04-02 13:14:15 +0200
commite3487a605ee0081815d51637b5c40f083bb5a08a (patch)
tree7739950914d365029cf12bc0586662c3d927ac8b /x11-plugins/purple-matrix
parentx11-plugins/purple-matrix: Update copyright (diff)
downloadmatrix-e3487a605ee0081815d51637b5c40f083bb5a08a.tar.gz
matrix-e3487a605ee0081815d51637b5c40f083bb5a08a.tar.bz2
matrix-e3487a605ee0081815d51637b5c40f083bb5a08a.zip
x11-plugins/purple-matrix: Bump to EAPI-7
- Added sub-slot dep operators where useful - sorted deps alphabetically - Added pkgconfig dep to BDEPEND
Diffstat (limited to 'x11-plugins/purple-matrix')
-rw-r--r--x11-plugins/purple-matrix/purple-matrix-9999.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/x11-plugins/purple-matrix/purple-matrix-9999.ebuild b/x11-plugins/purple-matrix/purple-matrix-9999.ebuild
index 41e96b4..e594045 100644
--- a/x11-plugins/purple-matrix/purple-matrix-9999.ebuild
+++ b/x11-plugins/purple-matrix/purple-matrix-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit git-r3
@@ -14,17 +14,22 @@ SLOT="0"
KEYWORDS=""
IUSE="olm"
-RDEPEND="net-im/pidgin
+RDEPEND="
+ dev-db/sqlite:3
dev-libs/glib
dev-libs/json-glib
- net-libs/http-parser
- dev-db/sqlite:3
+ net-im/pidgin
+ net-libs/http-parser:=
olm? (
- dev-libs/olm
- dev-libs/libgcrypt:0
+ dev-libs/libgcrypt:0=
+ dev-libs/olm:=
)"
DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
src_compile() {
use olm || export MATRIX_NO_E2E=1
emake || die "Make failed!"